NuxUtilAccessible requires to implement support to key event listeners

Bug #702672 reported by Alejandro Piñeiro on 2011-01-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Alejandro Piñeiro
unity (Ubuntu)
Undecided
Unassigned

Bug Description

NuxUtilAccessible is the implementation of AtkUtil for Unity/Nux. Recently it was added to Unity in the first bunch of bugs related to the Atk support, but for the moment it lack some methods, included this.

More info [1][2]

[1] http://library.gnome.org/devel/atk/stable/AtkUtil.html#atk-add-key-event-listener
[2] http://library.gnome.org/devel/atk/stable/AtkUtil.html#atk-remove-key-event-listener

Related branches

Changed in unity:
assignee: nobody → Alejandro Piñeiro (apinheiro)
Alejandro Piñeiro (apinheiro) wrote :

I was trying to set a bug dependency but it seems that this is not implemented yet (see bug 95419)

So, for the record, this bug depends on bug 702671

David Barth (dbarth) on 2011-01-17
Changed in unity:
importance: Undecided → Medium
status: New → In Progress
milestone: none → 3.4
Changed in unity:
status: In Progress → Confirmed
Alejandro Piñeiro (apinheiro) wrote :

Moved from "In Progress" to "Cofirmed" as this bug is blocked by bug 702671

Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.2.16
Alejandro Piñeiro (apinheiro) wrote :

Bug 702671 was FIXED, so setting status to "In progress". I will work on it as soon as I finish (or in parallel) with bug 702696

Changed in unity:
status: Confirmed → In Progress
Neil J. Patel (njpatel) on 2011-01-27
Changed in unity:
milestone: 3.2.16 → 3.4
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.4 → 3.4.2
David Barth (dbarth) on 2011-02-11
Changed in unity:
milestone: 3.4.2 → 3.4.4
Neil J. Patel (njpatel) on 2011-02-18
Changed in unity:
milestone: 3.4.4 → 3.4.6
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → In Progress
Alejandro Piñeiro (apinheiro) wrote :

Due some other things with more priority (Launcher), I will change the status to New. I will go back to this bug once I finish that other tasks

Changed in unity:
status: In Progress → New
Changed in unity (Ubuntu):
status: In Progress → New
Alex Launi (alexlauni) wrote :

NEW is not for waiting/blocked bugs. Marking as triaged since you know exactly what needs done, and it's just deferred.

affects: nux → null
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
milestone: 3.4.6 → 3.6
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Didier Roche (didrocks) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Changed in unity:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in null:
status: New → Fix Released
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers