dash - search string not always taken into account

Reported by Florian Boucault on 2011-01-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
High
Neil J. Patel
unity-2d
Medium
Unassigned
unity-lens-applications
Medium
Mikkel Kamstrup Erlandsen
unity-lens-files
High
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

When I type in a search string, it seems that only the first (n-1) characters are taken into account. To observe:
   1. show the home screen of the dash
   2. type in "aui" - there are search results displayed (files here)
   3. append "e" to the search query - the same results remain displayed
   4. press backspace once to erase the last character ("e") - suddenly there are no results any longer!

Note that another clue that seems related is when searching a string that has no matches in one of the places (applications or files), if clicking on the button to search on the web, the search query issued to google is not the actual string typed in, it’s the first string that raised no results.

David Barth (dbarth) on 2011-01-11
tags: added: bitesize

Florian - is this both the files place and the apps place or just one of them? Or are we talking the global search here?

Florian Boucault (fboucault) wrote :

@Mikkel: I only tried in the global search actually

David Barth (dbarth) on 2011-01-17
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
Changed in unity-2d:
importance: Undecided → Medium
Changed in unity-2d:
status: New → Confirmed
David Barth (dbarth) on 2011-01-24
Changed in unity:
milestone: none → 3.4
Changed in unity:
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
milestone: 3.4 → 3.4.4
Neil J. Patel (njpatel) wrote :

I'm seeing this too in search, it feels like the views are broken but inspecting the models over d-feet shows that it's actually the results.

Changed in unity:
importance: Medium → High
milestone: 3.4.4 → 3.4.6
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Mio (m10) wrote :

I-m seeing something similar:
the first 3 typed letters return results as expected,
all subsequent typed letters result in a (completely) empty Dash.. (typed slowly giving the Dash time to reload)
hitting backspace makes them reappear, retyping (if there are more than 3 letters) again results in an empty Dash
e.g. the search terms "f", "fi", "fir" all show results as normal (although on each new letter it seems to reload completely new results instead of just removing the non-matches), while "fire", "firef", "firefo",.. show an empty dash but "firefo<backslash>" shows result again..
BUT.. if i type quickly (without giving the dash time to load result before i finish typing) "fire" for example results are shown! (but "fire<delay>f" doesn't)

Neil J. Patel (njpatel) wrote :

At least from my tests the results from the daemon are accurate through d-feet, in Unity we're just missing some paints to draw the results (i.e. try hovering over where you think the results should be and you'll see them).

Changed in unity:
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Neil J. Patel (njpatel)
status: Confirmed → Triaged
Neil J. Patel (njpatel) wrote :

I should add, the hovering works with latest trunk, where I landed a branch that fixed some other bits related to this.

Neil J. Patel (njpatel) wrote :

Actually , I take that back. Just as I was fixing the showing of tiles in my branch (so unity itself isn't hiding anything), this issue has reappeared in the files place. If i slowly type "this is a test", then I get all sorts of useless results. If I type "this is a test" quickly and so unity only sents the search string once, then I get no results.

I've checked d-feet so this is definitely inside the daemon. From what I can tell it's the files daemon only, the f-i-r-e-f-o-x issue is solved in my branch, it's definitey just re-painting.

Ok, I've been poking at this a bit, and I still can't reproduce it locally. I think I'm on to something anyway...

So my box has SSD and runs the latest Zeitgeist which is 0.7.0 which is about 2-3 times faster then 0.5.2 which are in the archives right now.

On non-SSD and with ZG 0.5.2 Neil can reproduce from D-feet with SetGlobalSearch("t", {}); SetGlobalSearch("th", {}); SetGlobalSearch("this is a test", {}). The two first queries will have a lot of hits and put a good deal of pressure on ZG, if the last query comes when while we're still handling the "th"-query I think the place daemons might have reentrancy issues.

The reason I can't reproduce on my box is then that my system is just too fast! :-) Still all speculation though...

Changed in unity-place-files:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
status: New → Fix Committed
Changed in unity-place-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Fix Committed
Neil J. Patel (njpatel) on 2011-02-24
Changed in unity:
status: Triaged → Fix Committed
Changed in unity-place-files:
milestone: none → 0.5.38
status: Fix Committed → Fix Released
Changed in unity-place-applications:
milestone: none → 0.2.34
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-02-24
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.34-0ubuntu1

---------------
unity-place-applications (0.2.34-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dash - search string not always taken into account (LP: #701569)
    - Sync problems when restarting Unity place daemons (LP: #721289)
    - Super-shortcuts for apps, files, and workspace switcher (LP: #617356)
    - Place icons should be in their respective packages (LP: #672447)
  * debian/control:
    - bump release req.
 -- Didier Roche <email address hidden> Thu, 24 Feb 2011 20:11:50 +0100

Changed in unity-place-applications (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.38-0ubuntu1

---------------
unity-place-files (0.5.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dash - search string not always taken into account (LP: #701569)
    - Sync problems when restarting Unity place daemons (LP: #721289)
    - Super-shortcuts for apps, files, and workspace switcher (LP: #617356)
    - Place icons should be in their respective packages (LP: #672447)
  * update build-deps
 -- Didier Roche <email address hidden> Thu, 24 Feb 2011 20:12:32 +0100

Changed in unity-place-files (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.6-0ubuntu1

---------------
unity (3.4.6-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dash times out (LP: #662618)
    - possible memory leak in compiz when using places, dashboard
      (LP:#720446)
    - compiz crashed with SIGSEGV in IconTexture::~IconTexture() (LP: #721907)
    - dash - search string not always taken into account (LP: #701569)
    - Unity allows you to Quit itself (LP: #705536)
    - invisible window border problems (LP: #710271)
    - Slowliness in the file places (LP: #710791)
    - add super shortcuts to the launcher - logic (LP: #721264)
    - key navigation doesn't activate trash, keys, expo or places
      (LP:#723141)
    - Super-shortcuts for apps, files, and workspace switcher (LP: #617356)
    - New launcher tile super key overlay aesthetic (LP: #646712)
    - add cursor-key navigation to quicklists (LP: #701543)
    - Super key should open Dash (LP: #706713)
    - Dash view should use "Prefferred Applications" icons where appropriate
      (LP: #708479)
    - some partitions appear with questionmark icon (LP: #710809)
    - Unity wrongly resizes thumbnails after first opening of Files place
      (LP:#721123)
    - Change the fading and showing curve effect when hovering the bfb
      (LP:#721125)
    - Recent files appear duplicated in the Dash (LP: #646758)
    - All Applications tab only shows first 100 applications (LP: #660979)
    - slide animation typo in unity configuration (LP: #723354)
    - Place icons should be in their respective packages (LP: #672447)
    - Trash right click menu is positioned incorrectly (LP: #718880)
    - Require to use gconf to check on unity and the panel-service if the
      accessibility should be enabled (LP: #723699)
  * debian/control:
    - dep on latest nux
 -- Didier Roche <email address hidden> Thu, 24 Feb 2011 20:16:29 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers