[panel] Window title could use a little fade

Reported by Omer Akram on 2010-12-28
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Low
Marco Trevisan (Treviño)
unity-2d
Low
Aurélien Gâteau
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

when the title of a window is too long that its cut by indicators the last letter looks little odd it would be nice if there is a little fade there. (screenshot of the problem attached).

Fix bug #704615 at the same time.

Omer Akram (om26er) wrote :

 status confirmed

Agree, we definitely need a designed treatment of this case. Am happy
with the fade, matching the current fade of the app name when a menu is
overlayed in the panel. Whichever treatment we settle on, we should be
consistent in its use across those cases.

Could you post the full panel? I don't understand how your window title is conflicting with indicators, they should be at opposite ends of the panel. Is your monitor 200px wide?

Changed in unity:
status: New → Incomplete
Changed in ayatana-design:
status: New → Confirmed
Paul Sladen (sladen) wrote :

Alex: Not everyone has a 1400-pixel or 1920-pixel widescreen display! It still needs to work with prettiness on a netbook, or portrait tablet. For example, the title of this bug report as viewed in Firefox ("Bug #694924 in Unity: "Window title could use a little fade" - Mozilla Firefox 4.0 Beta 8") has a 60-pixel overlap with the default indicators on a 1024-pixel screen.

 ... and we need to handle pathologically long window titles, even for
the widescreen case.

Changed in unity-2d:
status: New → Incomplete

I agree, it looks dreadful and out of place at this stage. Fading would be great :)

Mirco Müller (macslow) on 2011-01-28
Changed in unity:
importance: Undecided → Low
Changed in unity-2d:
importance: Undecided → Low
tags: added: bitesize
Changed in unity-2d:
milestone: none → 3.8
Omer Akram (om26er) wrote :

setting to confirmed since the design is already approved ;)

Changed in unity:
status: Incomplete → Confirmed
Changed in unity-2d:
status: Incomplete → Confirmed
Changed in unity:
assignee: nobody → Treviño (Marco Trevisan) (3v1n0)
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2011-02-09
Changed in unity:
milestone: none → 3.4.2

Bug is now fixed like shown here: http://www.flickr.com/photos/trevi55/5431631622/ ;)

Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.2-0ubuntu1

---------------
unity (3.4.2-0ubuntu1) natty; urgency=low

  * New upstream release:
    - add --distro switch to remove local installation of unity with default
      options (LP: #715703)
    - global search and speedups in places
    - Using fade effect to cut the window Title when it's longer than the panel
      (LP: #694924)
    - Launcher - Add ability for apps to indicate progress through Launcher icon
      (LP: #676596)
    - calling unity should kill unity-panel-service (LP: #711289)
    - unity places should return a default icon when no matching icon is found
      (LP: #711200)
    - the launcher should start hidding when an icon is clicked (LP: #709178)
    - Highlight drag-friendly Launcher tiles when dragging a file (LP: #607782)
    - Fix migrate_favorites.py crashed with OSError in get_log_file(): [Errno 2]
      No such file or directory: '/home/ubuntu/.local/share/unity' (LP: #711964)
    - places should support wrong Icon= format (with extensions) (LP: #711189)
    - unity crashed with AttributeError in reset_unity_compiz_profile():
      'NoneType' object has no attribute 'get_default_value' (LP: #711105)
    - unity crashed with GError in reset_unity_compiz_profile() (LP: #710876)
    - Middle click on application icon should open a new window (LP: #709707)
    - Launcher - Add interaction to support dragging and dropping behind the
      launcher (LP: #702482)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Launcher - Add number notifier to Launcher icons (LP: #676455)
    - Support dragging files to trash to delete them (LP: #619686)
    - [launcher] Indicator-only applications showing as open applications
      (LP: #703396)
    - Unity does not accept mouse clicks (LP: #683328)
    - dash is empty (LP: #710792)
  * debian/control:
    - depends on latest nux
 -- Didier Roche <email address hidden> Thu, 10 Feb 2011 20:45:47 +0100

Changed in unity (Ubuntu):
status: New → Fix Released

About Unity (standard version), I've uploaded to my branch (lp:~3v1n0/unity/fading-title) a fixed version (see merge request for further informations).

Plus, to get desktop coherency the bug #717216 should be fixed too (applying the provided patch).

Changed in unity-2d:
milestone: 3.8 → none
tags: added: delta-with-3d
description: updated
summary: - Window title could use a little fade
+ [panel] Window title could use a little fade
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-06-24
Changed in unity-2d (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
assignee: nobody → Aurélien Gâteau (agateau)
milestone: none → 3.8.12
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments