Launcher icon goes behind launcher if dialog pops up while dragging icon

Reported by Alex Launi on 2010-12-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Undecided
Unassigned
Unity
Undecided
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

If a dialog appears while mid-drag, the icon being dragged will appear behind the launcher. I would make a short video but I am almost out disk space. This can be easily reproduced by running
$ sleep 5; zenity --info --text="See what I mean, Vern?"
then dragging a launcher icon until the dialog appears. Move the icon into the launcher and see it obscured by the launcher.

Alex Launi (alexlauni) on 2010-12-23
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Jorge O. Castro (jorge) on 2011-01-03
tags: added: bitesize
Michael Terry (mterry) wrote :

Really, an Ernest reference? :)

Changed in unity:
assignee: nobody → Michael Terry (mterry)
status: Confirmed → In Progress
Alex Launi (alexlauni) wrote :

According to Jason nux::GetWindowCompositor().SetAlwaysOnFrontWindow(window) is the call not working correctly.

Changed in nux:
status: New → Triaged
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-02-21
Changed in nux (Ubuntu):
status: New → Triaged
Omer Akram (om26er) wrote :

setting the status to reflect the current state so that its open for other contributors.

Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in nux:
status: Triaged → Confirmed
Changed in nux (Ubuntu):
status: Triaged → Confirmed
Changed in unity:
status: In Progress → Confirmed
assignee: Michael Terry (mterry) → Omer Akram (om26er)
assignee: Omer Akram (om26er) → nobody
Andrea Azzarone (andyrock) wrote :

I can no longer reproduce the bug.

Hernando Torque (htorque) wrote :

This seems to be fixed.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in nux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers