xterms broken in unity

Bug #692463 reported by Fabien Tassin on 2010-12-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury

Bug Description

In Natty, when i start an xterm while in unity, i get a transparent window (unexpected), with decorations, and it's totally unresponsive and unusable (it's not accepting inputs).

I can't grab it or move it, it seems to let some events pass through to nautilus in the background, like if the xterm is over a file or a folder, even if it does do anything when i click on it, i can drag "something" and if i drop it in.. say a gnome term, i get its filename.

As i use xterms instead of gnome terminals (faster & lighter), unity is totally unusable for me at the moment.

It's totally reproducible here.

(moving back to Classic, i revisit Unity periodically)

ii libunity-misc0 0.1.1-0ubuntu3 Miscellaneous functions for Unity - shared library
ii libunity0 0.2.46-0ubuntu5 binding to get places into the launcher - shared library
ii libunity3 3.2.8-0ubuntu1 binding to get places into the launcher - shared library
ii unity 3.2.8-0ubuntu1 Interface for Ubuntu Desktop Edition
ii unity-asset-pool 0.8.18-0ubuntu2 Unity Assets Pool
ii unity-common 3.2.8-0ubuntu1 Common files for the interface for Ubuntu Desktop Edition
ii unity-place-applications 0.2.26-0ubuntu2 Application place for unity
ii unity-place-files 0.5.32-0ubuntu1 File place for unity

Jorge Castro (jorge) on 2010-12-20
Changed in unity:
status: New → Confirmed
Fabien Tassin (fta) wrote :

still unusable with 3.2.14-0ubuntu2. it's probably just a z-axis issue as an xprop of the xterm shows it's in fact nautilus.

Fabien Tassin (fta) wrote :

slightly more usable with 3.4.0-0ubuntu2, but it's still impossible to resize xterms.
The decorations are resized, but not the content.
Also, only the top border is usable to resize the window, and not even the full width (a click on the right part of the decoration title bar passes through to nautilus).

Neil J. Patel (njpatel) on 2011-02-20
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → High
milestone: none → 3.8
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Sam Spilsbury (smspillaz) wrote :

Can't find the right branch to push to ... attaching a patch instead

Changed in compiz:
status: New → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Fix Committed
Changed in compiz:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in compiz:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → ubuntu-11.04-beta-1
tags: added: patch
Fabien Tassin (fta) wrote :

I tried the patch, it works fine for the xterm itself, but there's a new problem: the xterms are moving unexpectedly when switching workspaces.

It's easy to reproduce:
open an xterm on a workspace, move to the next workspace and back. the xterm moved a few pixels upward. Do that several times and the title bar goes underneath the top panel, making the xterm unmovable (except with Alt+F7).

xterms works perfectly well for me and I can't reproduce any of the symptoms. Would be most odd if this was GPU related (i have an i945 here).

@Fabien: Do you have some non-standard xterm config or something that may trigger this?

Fabien Tassin (fta) wrote :

@kamstrup: no, and i can reproduce at will on different boxes. iirc, smspillaz said he knew what the new problem is.

Fabien Tassin (fta) wrote :

a video just switching workspaces left and right

Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: 3.8 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Fabien Tassin (fta) wrote :

hm, not completely fixed. See #4 and #6

Fabien Tassin (fta) wrote :

Here is a patch fixing the regression I mentioned in #4 and showed in #7.
wfm now.

David Barth (dbarth) wrote :

Hi Fabien,

Here is the additional branch i just merged earlier today: https://code.launchpad.net/~unity-team/compiz/trunk.fix-xterms/+merge/56144

Could you review it as well (even if it's already merged in) and confirm that does fix the problem in your context as well. It seems to be a more general version of your patch, but I'd like to ensure the "extra bits" don't create regressions elsewhere.

David

Fabien Tassin (fta) wrote :

David, just by reading the patch in the merge proposal, i see the regression is still there.
I can try it tomorrow if you want but i doubt it will work.

David Barth (dbarth) wrote :

Sam says you're right ;) So i'll apply the patch, considering that this thread is equivalent to a code review. Thanks!

Stephen M. Webb (bregma) wrote :

Looks like this has been in trunk and released for the last several releases.

Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments