Autohide less frequently used indicators

Bug #691904 reported by Calota Romeo
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Wishlist
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Many applications do not have any other windows or menus except for an indicator applet (eg.: Pastie, Dropbox, Network Manager, Volume control, Redshift) and in time the topbar gets pretty clutterd with icons that don't fit into any category (i.e. don't integrate into the sound menu or messaging menu). This isn't a big issue with larger screens but on a netbook can get verry troublesome.
The problem will get even worse since starting with Natty the classic system tray and gnome-panel applets won't be supported.
An autohide functionality like in KDE would be very helpful.

Revision history for this message
Calota Romeo (kicsyromy) wrote :
Ted Gould (ted)
Changed in indicator-application:
status: New → Won't Fix
importance: Undecided → Wishlist
status: Won't Fix → Confirmed
affects: indicator-application → unity
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 691904] [NEW] Autohide less frequently used indicators

 We would not do an auto-hide system without substantial justification.
What would be most helpful for this analysis is a list of existing
indicators, perhaps one could be started on the wiki?

Mark

Revision history for this message
Calota Romeo (kicsyromy) wrote :

I've been busy with exams all month and haven't checked out the bug report in a while. Thank you for the reply. I will get started on a wiki page ASAP.

Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er)
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Omer Akram (om26er) wrote :

The gap between indicators have decreased since the issue was reported so I believe its not an issue anymore.

Calota Romeo (kicsyromy)
Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity:
status: Invalid → Fix Released
Changed in ayatana-design:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments