Update managers Apply Settings window doesn't trigger unity's smarthide

Reported by Dave Morley on 2010-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Medium
Michael Terry
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Unity's smart hide feature for the launcher isn't triggered by update managers Apply Settings window (install progress bar window)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.6-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
Uname: Linux 2.6.37-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,expo,move,compiztoolbox,place,gnomecompat,wall,ezoom,resize,fade,scale,session,staticswitcher,unityshell]
Date: Mon Dec 13 22:49:35 2010
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
InstallationMedia_: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: Hewlett-Packard Compaq Mini 110c-1000
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-8-generic root=UUID=6e89a720-6500-4834-b7f7-56501b87b0d6 ro quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 06/18/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 308F0 Ver. F.07
dmi.board.name: 308F
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 02.0B
dmi.chassis.asset.tag: CNU9334ZN9
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr308F0Ver.F.07:bd06/18/2009:svnHewlett-Packard:pnCompaqMini110c-1000:pvr03A8100000000000100300000:rvnHewlett-Packard:rn308F:rvrKBCVersion02.0B:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: Compaq Mini 110c-1000
dmi.product.version: 03A8100000000000100300000
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-8-generic

Related branches

Dave Morley (davmor2) wrote :
Didier Roche (didrocks) wrote :

Thanks for reporting this bug and help to make ubuntu better.
However, I'm not sure to understand what do you mean, can you make a video of it with gtk-recordmydesktop or a screenshot with some descriptions, please?

Changed in unity (Ubuntu):
status: New → Incomplete
Dave Morley (davmor2) wrote :

Didier I will do as soon as I get a desktop again, current update (20101214) has broken all of unity by the look of it.

Dave Morley (davmor2) wrote :

Attached is a video of a similar issue with a first run of Ubuntu One settings, as sson as there are some updates I'll repeat the process for update manager.

Didier Roche (didrocks) wrote :

ok, it depends on the window type then. Thanks a lot.

Changed in unity (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
tags: added: bitesize
Kyle Clarke (kyleclarke) wrote :

These two windows are relatively small windows and thus don't actually require the space created by hiding the launcher.

The update window described can't even be maximised and the Ubuntu One window probably shouldn't be able to be maximised (it's really ugly, and nothing).

To have some windows not trigger "intelihide" makes it seem more "intellegent" in my books.

Michael Terry (mterry) on 2011-01-07
Changed in unity:
assignee: nobody → Michael Terry (mterry)
status: Triaged → In Progress
Michael Terry (mterry) wrote :

Kyle, this is about when the dialog is behind the launcher, so naturally you would want the launcher to get out of the way. The launcher will still be visible if the dialog is on another part of the screen.

Omer Akram (om26er) wrote :

the issue is fixed with latest updates to unity in Natty

Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers