Select quicklist items with just one right click

Reported by David Prieto on 2010-12-11
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Nux
Undecided
Unassigned
Unity
Medium
Zaid Yeganeh
unity-2d
Medium
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

I'm used from gnome right-click menus to being able to right click, move the mouse and release the right button over an item to select it. Unity's quicklist, however, don't let you do this: you have to right-click the launcher AND then click the quicklist item again, which is not consistent.

Didier Roche (didrocks) wrote :

I'm pretty sure that can be mentored and bitesize with good mentorship :)

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
tags: added: bitesize
Changed in unity (Ubuntu):
status: Triaged → Invalid
Josh Headapohl (joshhead) wrote :

Going to take a stab at this. I accidentally marked the Ubuntu package bug as invalid but I don't think I can change it back so someone else will have to.

Changed in unity:
assignee: nobody → Josh Headapohl (joshhead)
status: Triaged → In Progress
Omer Akram (om26er) wrote :

Unity(ubuntu) is the package bug which will be closed when the version of unity that fixes the issue is in Ubuntu, setting to triaged.

Changed in unity (Ubuntu):
status: Invalid → Triaged
Josh Headapohl (joshhead) wrote :

Not making clear progress on this, so unassigning myself.

Changed in unity:
assignee: Josh Headapohl (joshhead) → nobody
Changed in unity-2d:
status: New → Triaged
importance: Undecided → Medium
Omer Akram (om26er) wrote :

setting back to complete since no one is working on it at the moment.

Changed in unity:
status: In Progress → Confirmed
Changed in unity:
assignee: nobody → Reuben Swartz (rbn-swartz)
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: Triaged → In Progress
Reuben Swartz (rbn-swartz) wrote :

I no longer have the patience to work on this bug. Unassigning.

Changed in unity:
assignee: Reuben Swartz (rbn-swartz) → nobody
Changed in unity (Ubuntu):
status: In Progress → Triaged
Changed in unity:
status: In Progress → Confirmed
Didier Roche (didrocks) on 2011-04-13
Changed in unity:
status: Confirmed → Triaged
Ian Liu Rodrigues (ian-liu88) wrote :

I would like to work on this one. Could someone give me a starting point? I could find the Right-Click menu items definitions, but not the interface definition.

Changed in unity:
status: Triaged → In Progress
assignee: nobody → Ian Liu Rodrigues (ian-liu88)
Ian Liu Rodrigues (ian-liu88) wrote :

I've been studying on how to solve this bug. This is what I've got so far:

There are two places in the code which I find relevant to this bug. Both of them are signals to Mouse Up events, one for the launcher icon[1] and another for each quick list item[2]. It seems the quick list events aren't emitted before the first one is finished. For example, the items in the quick list aren't highlighted when hovering them with the mouse pressed. But the event *is* implemented.

To conclude my thoughts, I think the only work to be done is to enable events in quick list while mouse button is pressed, since the mouse up event is already handled by the items in the quick list.

[1] - src/LauncherIcon.cpp @ LauncherIcon::RecvMouseUp
[2] - src/QuicklistView.cpp @ QuicklistView::RecvItemMouseRelease

Changed in unity (Ubuntu):
assignee: nobody → Ian Liu Rodrigues (ian-liu88)
status: Triaged → In Progress
Changed in unity-2d:
importance: Medium → Low
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Triaged
Andrea Azzarone (andyrock) wrote :

@Ian Liu Rodrigues, are you still working on that?

Oh, I've completely forgot about this bug!
I have a lot of work to do now.
I will remove my name from it.

Thanks!
Ian

On Mon, Jun 6, 2011 at 7:10 AM, Andrea Azzarone
<email address hidden>wrote:

> @Ian Liu Rodrigues, are you still working on that?
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/688830
>
> Title:
> Select quicklist items with just one right click
>

Omer Akram (om26er) wrote :

assigned Andy so that he could look into this bug, if interested.

Changed in unity (Ubuntu):
assignee: Ian Liu Rodrigues (ian-liu88) → nobody
Changed in unity:
assignee: Ian Liu Rodrigues (ian-liu88) → Omer Akram (om26er)
assignee: Omer Akram (om26er) → nobody
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity-2d:
importance: Low → Medium
Andrea Azzarone (andyrock) wrote :

I have no time to work on this bug. Sorry for the inconvenience.

Changed in unity (Ubuntu):
assignee: Andrea Azzarone (andyrock) → nobody
Changed in unity:
assignee: Andrea Azzarone (andyrock) → nobody
Omer Akram (om26er) wrote :

> I have no time to work on this bug. Sorry for the inconvenience.

no hay problema, you are still awesome :-)

Milo Gertjejansen (milo-h) wrote :

I would like to work on this bug. Trying this out for the first time (all my free time in the summer should go somewhere). I will start looking where Ian Liu Rodrigues left off.

I can assign my self to it, but which one? (Out of the four "Affects" items)

Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed

@Milo: it's nice to see your interest in helping!

The "affects" items can be classified in two parts:

1. Upstream projects: where the commits happen, the focus of development. It's here where you should work.

2. Distribuition packages (downstream): this is used to control when the bug fixes are delivered to users.

You should set the status as "In Progress" both in upstream and downstream. The assignee need to be set only in one of them (this way, other people can know that your are working on this bug). By convenience, we set the assignee in upstream.

Finally, to answer your question: if you want to help with unity project, you should set the status "In Progress" in "unity" and in "unity (ubuntu)" and set the assignee in "unity". If you want to help the unity-2d project, set the "In Progress" status in "unity-2d" and "unity-2d (ubuntu)" and the assignee in "unity-2d".

Changed in unity:
assignee: nobody → Abhishek Singh (abhishek1729)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Grandi (andreagrandi) wrote :

I assigned myself this bug because I want to try fixing it on Unity-2D.

In this version we don't have these two files:
[1] - src/LauncherIcon.cpp @ LauncherIcon::RecvMouseUp
[2] - src/QuicklistView.cpp @ QuicklistView::RecvItemMouseRelease

so I think I will have to look inside some QML file.

I suspect we're only managing the Click event and not the Press event of the mouse.
I've probably to connect the other signal too to make it work, but I'm not sure yet.

First I've to find where the code is in Unity-2D. If anyone of you has any idea I would be glad to fix it.

Changed in unity-2d:
assignee: nobody → Andrea Grandi (andreagrandi)
tags: removed: bitesize
Omer Akram (om26er) wrote :

unassigned as Abishek is not working on the bug clearly.

Changed in unity:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Changed in unity:
assignee: Abhishek Singh (abhishek1729) → nobody
Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
Omer Akram (om26er) on 2011-09-15
Changed in unity-2d:
status: Triaged → Confirmed
Changed in unity-2d (Ubuntu):
status: Triaged → Confirmed
Zaid Yeganeh (yeganeh) on 2011-10-02
Changed in unity:
assignee: nobody → Zaid Yeganeh (yeganeh)
Changed in unity (Ubuntu):
assignee: nobody → Zaid Yeganeh (yeganeh)
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Zaid Yeganeh (yeganeh) on 2011-10-02
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed

@Zaid: The bug report should be changed to "Fix Committed" only when the merge proposal is approved.

Thanks.

Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Zaid Yeganeh (yeganeh) wrote :

@Marco: Understood - thanks

Zaid Yeganeh (yeganeh) on 2011-10-06
Changed in unity (Ubuntu):
assignee: Zaid Yeganeh (yeganeh) → nobody
Changed in nux (Ubuntu):
status: New → In Progress
Changed in unity:
status: In Progress → Invalid
Changed in nux:
status: New → In Progress
Changed in unity-2d:
assignee: Andrea Grandi (andreagrandi) → nobody
Changed in nux:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Gord Allott (gordallott) on 2012-01-12
Changed in unity:
status: Invalid → Fix Committed
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.0.0-0ubuntu1

---------------
nux (2.0.0-0ubuntu1) precise; urgency=low

  [ Aurélien Gâteau ]
  * New upstream release:
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #881106)
    - compiz crashed with SIGSEGV in
      nux::WindowCompositor::FindKeyFocusAreaFrom() (LP: #860852)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #848952)
    - compiz crashed with SIGILL in typeinfo for std::ostream() (LP: #849881)
    - compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()
      (LP: #864686)
    - Select quicklist items with just one right click (LP: #688830)
    - OnMouseDoubleClick in InputArea isn't working (LP: #708020)
    - Menubar - horizontal scroll over a menu opens it (LP: #775872)
    - Clicking on a dash category header should not give it keyboard focus
      (LP: #905921)
    - Horizontal scroll on maximize/restore window control restores window.
      (LP: #809717)
    - Horizontally scrolling while highlighting an item in the dash or on an
      indicator will open the item. (LP: #837004)
    - compiz crashed with SIGSEGV in free() (LP: #864446)
    - Mouse wheel doesn't works if the mouse pointer is inside dash scrollbar.
      (LP: #888819)
  * debian/rules, debian/control:
    - add nuxabiversion capability as upstream is breaking a lot the ABI
      wasn't bumping the soname. Create a virtual package similar to what
      we already do in compiz to ensure we dep on the right version.
      Remove the makeshlibs override then as not needed anymore.
    - bump to nux 2.0 with new libnux-2.0-0, libnux-2.0-common, libnux-2.0-dev
      packages. Make the necessary changes in .install files as well
    - don't ship anymore the -doc package.
  * debian/nux-tools.install:
    - move the apport file there instead of the -common package to enable
      co-instability
 -- Didier Roche <email address hidden> Fri, 13 Jan 2012 09:04:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers