Global menu causes white "flashes" when scrubbing/moving with mouse fast over menus

Bug #687567 reported by Krzysztof Klimonda on 2010-12-08
562
This bug affects 112 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
unity (Ubuntu)
High
Daniel van Vugt
Nominated for Natty by Omer Akram

Bug Description

When I open menu in some application and then move mouse fast to the left or right so different items are expanded I see ugly white flash before content of the menu is rendered.

Related branches

Omer Akram (om26er) wrote :

does that happen in unity?

Omer Akram (om26er) on 2010-12-10
Changed in appmenu-gtk:
status: New → Incomplete
Krzysztof Klimonda (kklimonda) wrote :

Yes, both this and bug 687569 happen in unity

Omer Akram (om26er) on 2010-12-10
affects: appmenu-gtk → unity
Changed in unity:
status: Incomplete → Confirmed
Paul Sladen (sladen) wrote :

Confirming, really need to video it and slow it down, it's possible that the rendered pixmap is being dropped/cleared before the menu (X Window) referencing it is hidden from view.

summary: - white "flashes" when moving mouse fast over menu items
+ Global menu causes white "flashes" when scrubbing/moving with mouse fast
+ over menus
David Barth (dbarth) on 2011-01-07
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.4

Here is a video of the problem. I also had this problem with Firefox's menu before I upgrade to 11.04, and I still have.

Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
assignee: Neil J. Patel (njpatel) → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Medium → High
milestone: 3.4 → 3.6
description: updated
Neil J. Patel (njpatel) on 2011-02-07
Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Neil J. Patel (njpatel)
milestone: 3.6 → 3.4.4
Neil J. Patel (njpatel) wrote :

I looked into this, it's the fade animation on close being slowed by something inside Unity. Even if I stop emitting the signals that tell the panel to repaint itself, this still happens, so it's not dbus-traffic or anything like that causing it.

If I switch off the animation plugin, then the effect is greatly reduced, however then you can still sometimes see the shadow of the of menu hang around a bit longer than necessary.

If I was going to guess, it looks like either there is a repaint going on in Compiz just before the menu goes away, which causes the next paint to use an invalid TFP and hence we see white (i.e. the menu closes before the animation plugin has time to take a snapshot, or we're causing an extra paint before the plugin is ready).

I'm going to assign to sam as I need his input on this. Also, moving to next week as he as quite a bit on his plate this week.

Changed in unity:
assignee: Neil J. Patel (njpatel) → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: 3.4.4 → 3.4.6
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-02-24
Changed in unity:
milestone: 3.4.6 → 3.6
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.8
AleCutu (ale-cut) wrote :

This bug is also in unity-2d and in the classic desktop session ._.

> This bug is also in unity-2d and in the classic desktop session ._.
>

Thats a totally different issue which you might want to report for
'metacity' I guess.

Omer Akram (om26er) wrote :

My testing reveals thats this is not specific to the menubar. Menu's in general are slow under Unity whether they are in the panel or right click menus inside an application window, that causes application slowness which is very much notable on slower devices like netbooks. also (this might not be related to this bug) dialogs inside an application are slow to appear when compared to the classic desktop all in all there is certainly something wrong in the picture that is causing the slowness.

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Loïc Molinari (loic.molinari)
Changed in unity (Ubuntu):
assignee: nobody → Loïc Molinari (loic.molinari)
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
nickm (nickm) wrote :

I can confirm that the latest version of Unity (aptitude full-upgrade just now) on my Intel-GPU netbook also redraws menus much more slowly than under Maverick's Compiz.

Didier Roche (didrocks) on 2011-04-01
Changed in unity:
milestone: 3.8.2 → 3.8.4
Florian Boucault (fboucault) wrote :

Not affecting Unity 2D.

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
milestone: 3.8.4 → 3.8.6
pablomme (pablomme) wrote :

There is a report of these white flashes in maverick, see bug #664614, so the root cause may be elsewhere other than unity..

Tobias Wolf (towolf) wrote :

I get flashes on an indicator-appmenu loaded in a gnome-panel whenever the menu changes to a horizontally longer menu.

This might have to do with gnome-panel and the variable length of the appmenu applet. So dunno if it’s a dupe.

pablomme (pablomme) wrote :

Sorry, I misunderstood the other bug; it's about the menu entries flashing white, not the menus themselves flashing white. Disregard my previous comment.

zzarko (zzarko-gmail) wrote :

I have posted my own bug report (bug 748267), and it was considered as a duplicate of this one. There is one difference, which I didn't see in the example video (post #4) - the menu isn't flickering while moving slowly over one menu-item, but while moving fast between different menu-items. My video can be found at:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/748267/+attachment/2004610/+files/Flicker.mkv

My problem is that I'm getting the flashes even while slowly moving mouse over just one menu-item. If you play video slowly, on 00:06. for example, while cursor is over View menu-item, you could see that File menu is being displayed for a fraction of a second (together with activating File menu-item), and then View menu is displayed for a fraction of a second. Also, when cursor went behind last menu-item (Help, position 00:20), in the situation when no menus should be displayed, Bookmark menu is displayed, and after moving cursor even further, Help menu is displayed. If I try an application that doesn't use Global menu (Synaptic, for example), menus inside the application are displayed without problems.

Today, I installed 11.04 beta1 on my HD, did a complete update, and all is the same. I also installed proprietary ATI drivers (Radeon 4870), and the problem is still there...

zzarko (zzarko-gmail) wrote :

I also noticed that I don't have Ubuntu's button in the upper left corner (while using Live CD, and after the installation). Why is that?

zzarko (zzarko-gmail) wrote :

And I noticed that I'm not the only one with this problem (missing Ubuntu button, bug 752807). I found it beneath the pannel (I could see it if I change panel's opacity, but I cannot access it). This could be the cause of strange menu behavior (I have two video outputs - 1 monitor and 1 projector; option "Same image in all monitors" is checked from the beginning).

Neil J. Patel (njpatel) wrote :

zzarko, I've fixed the bug with regards to "same image in all monitors", it will be part of the 3.8.6 release this monday

Didier Roche (didrocks) on 2011-04-11
Changed in unity:
milestone: 3.8.6 → 3.8.8

This is a bug, and should be fixed, but I think High is a bit too much importance at this stage. Should this rather be a Medium and we pick up a proper fix in 11.10?

David Barth (dbarth) wrote :

Most of the flashing is due to the animation plugin that triggers an effect when a menu closes. Scrubing the menubar create a rapid succession of those effects and products the artifacts. If the fade on close option is removed from the animation plugin, the artifacts go away.

We can't workaround either the animation or suppress it now, unless we change the design requirement to have fade on close.

Changed in unity:
assignee: Loïc Molinari (loic.molinari) → nobody
Changed in unity (Ubuntu):
assignee: Loïc Molinari (loic.molinari) → nobody
Changed in unity:
milestone: 3.8.8 → backlog
John Lea (johnlea) wrote :

A fade on close is desirable, however temporally disabling this effect is an acceptable short term fix. The the white flashing is causing a larger problem than the gain we receive from the fade on close. +1 to disable this effect until we have solved the underlying issue. I have added re-enabling the fade on menu close to our 11.10 to do list.

pablomme (pablomme) wrote :

I don't think the flashing is due to the fade animation at all. With no fade effect it is still possible to see the white flashes. For some reason, a blank surface is being created on opening a menu, only to be destroyed and replaced with the actual menu - the fade effect only makes it more obvious because it takes 50ms to complete, and disabling it improves the appearance of the desktop, but this is just a workaround, not the cause of the problem.

Omer Akram (om26er) wrote :

I think the menus in general are quite slow under Unity. even the
right click menus in chromium.

Sam Spilsbury (smspillaz) wrote :

Just braindumping here for Neil.

The problem is definitely that the pixmap of the menu is being lost
before the window is destroyed or hidden. The same thing happens with
firefox menus too. Compiz will keep the old pixmap around for as long
as possible when the window goes away (since the referenced memory is
still somewhat safe to use directly, even if attempting to access the
pixmap data will fail through X)

--
Sam Spilsbury

Omer Akram (om26er) on 2011-04-17
Changed in unity (Ubuntu):
importance: Undecided → High
Dustan Ashley (dashley) wrote :

Problem behavior still exists. Tested with both nVidia (nonfree-bin driver) and intel systems running fully up to date Natty beta2 installs.

Disabling the fade animation on the menus mitigates the problem, but it seems to only be removing the extra 80ms that the menu would normally be fading out. The white boxes are definitely still present when switching between menus rapidly with the fade animation disabled.

Changed in unity:
status: Confirmed → Opinion
billytalent (billytalent) wrote :

Why is an opinion now ? The problem still exists....I still have it.

Omer Akram (om26er) on 2011-04-22
Changed in unity:
status: Opinion → Confirmed
billytalent (billytalent) wrote :

I guess this isn't being fixed before the release eh ? - Talk about eating the ice cream with the fly in it!

Ronald Kinard (furyhunter) wrote :

Confirmed. I have an NVidia graphics card, and I am using the proprietary driver. Menus opening and closing exhibit this blinking pattern. My Intel graphics-using laptop is also doing the same thing.

And yes, billytalent, it seems they let this get past release! Seems like a fairly irritating bug, too. I might be abandoning Unity for Gnome-shell because of this...

Didier Roche (didrocks) wrote :

@Furyhunter, billytalent: Please keep in mind that this issue is located to some configuration (for instance, with nvidia, proprietary driver here, I don't reproduce it, despite having a fairly old card).

One way for you to workaround this seems to change in ccsm the fade option to disable fade on close.
Thanks for your understanding.

Indeed. Disabling the Fade effect on the close animation fixes it for
me on my i945 card.

Daniel van Vugt (vanvugt) wrote :

Disabling all effects on the close animation only makes the problem dramatically less visible. I find if you scrub very quickly you can still see the white flashes occasionally even with Effects>Animations>Close Animation>Close Effect = None.

It certainly makes most instances of the bug invisible though. So a good workaround.

Module: i915
Xorg.0.log: (II) intel(0): Integrated Graphics Chipset: Intel(R) Q35

Dustan Ashley (dashley) wrote :

Yes. I think Daniel is correct in this regard. As mentioned in #21 and #24 disabling the fade animation only reduces the time that the artifact is displayed, it is definitely still there.

I can also confirm that the problem behavior exists on Intel graphics chips as well as nVidia.

There's no impact to functionality though, so I can see why it was a lower priority during the release push.

Ronald Kinard (furyhunter) wrote :

I'll confirm what Dustan and Daniel said -- it's only visible for a shorter amount of time with fades disabled.

MixiM (joakimleufstedt) wrote :

Same issue here.
- Radeon X1950 graphics... (does it matter) ?

Should be prioritized as so many of us have the issue!

CrusaderAD (crusaderad-gmail) wrote :

+1 here guys and gals. Looks terrible. Not so bad with other themes... but the "default" theme does this??

If you set the fade duration really high, like 2000, you can more easily see the problem.

Maybe approach mentioned here bug 783624 could help solve this problem...

CrusaderAD (crusaderad-gmail) wrote :

Nearly a month later, no updates?

papukaija (papukaija) wrote :

Unfortunately this bug isn't assigned to anyone which means that no one is working on this bug.

Daniel van Vugt (vanvugt) wrote :

You can see similar "flashes" in some apps if you have a fade-out effect set for closing windows. Closing Thunderbird you see the same kind of white flash as this bug discusses. Closing Chrome you see the client/page area similarly flash to black while the window fades out.

At a guess, it looks like the "flashing" is the result of windows, or sub-windows, being explicitly unmapped by the application before they're destroyed. So I doubt this is actually a bug in the compiz effects, but the apps themselves, including the code that renders indicator menus, need to be made to not unmap their windows if they're being destroyed anyway. That might stop this problem from occurring. Just a theory.

Sam Spilsbury (smspillaz) wrote :

On Sun, Jun 12, 2011 at 2:45 PM, Daniel van Vugt <email address hidden> wrote:
> You can see similar "flashes" in some apps if you have a fade-out effect
> set for closing windows. Closing Thunderbird you see the same kind of
> white flash as this bug discusses. Closing Chrome you see the
> client/page area similarly flash to black while the window fades out.
>
> At a guess, it looks like the "flashing" is the result of windows, or
> sub-windows, being explicitly unmapped by the application before they're
> destroyed. So I doubt this is actually a bug in the compiz effects, but
> the apps themselves, including the code that renders indicator menus,
> need to be made to not unmap their windows if they're being destroyed
> anyway. That might stop this problem from occurring. Just a theory.

Compiz uses the last bound pixmap to texture in animations for windows
that have been unmapped or destroyed.

If the application calls XClearArea () before being unmapped then
compiz will use the last bound pixmap, which may be white.

>
> --
> You received this bug notification because you are a member of Unity
> Bugs, which is subscribed to unity in Ubuntu.
> https://bugs.launchpad.net/bugs/687567
>
> Title:
>  Global menu causes white "flashes" when scrubbing/moving with mouse
>  fast over menus
>
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  When I open menu in some application and then move mouse fast to the
>  left or right so different items are expanded I see ugly white flash
>  before content of the menu is rendered.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/687567/+subscriptions
>

--
Sam Spilsbury

Re: comment #39
I can reproduce the Chrome black flash under KDE's Kwin, but not the Thunderbird flash to white. In fact, I've never seen anything flash to white during the fade-out effects in Kwin. Are there any other apps that cause white flashes before fade-out that I could test on Kwin? My theory is that if the bug doesn't effect Kwin, then there should be a way to keep it from happening in Compiz as well.

Jussi Lind (jussi-lind) wrote :

I'm having this problem with "01:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)" which is using the 173 driver.

Switching off the compiz animations trashed the top panel completely and now there are only some random pixels drawn on it. I can still open the menus and with less flickering this time.

Omer Akram (om26er) wrote :

> Switching off the compiz animations trashed the top panel completely and
> now there are only some random pixels drawn on it. I can still open the
> menus and with less flickering this time.

Logout and login again or restart unity, not related to this bug at all.

Daniel van Vugt (vanvugt) wrote :

@juzzlin: The trashed panel you describe is bug 769957.

I have this bug in Oneiric too, with Unity 3D.

The Fiddler (stapostol) wrote :

Confirm this issue with (open-source) R600g on a 4850 and a 4670 on Natty.

Simon Allen (garfunkel) wrote :

I have this on Oneiric with the non-free nvidia driver. Looks very ugly.

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
John Holcepl (knucklemedude) wrote :

it seems that the flicker is the selected animation choosing the color of the "Windows - Background" color from your current theme. the color it should be matching, i believe, is what "Controls" color scheme you may have selected.
the way to recreate this is to change the "Windows - Background" color in your Appearance Settings with the animation setting in Compiz active and you'll see that it grabs that color.

Daniel van Vugt (vanvugt) wrote :

A fix is now available for testing in ppa:vanvugt/unity -
https://launchpad.net/~vanvugt/+archive/unity

pablomme (pablomme) wrote :

Nice, it works.

I can see the shadows around not-drawn menus if I scrub really fast, but that is a separate issue - the panel shadow is rather suboptimal anyway. This is definitely a huge improvement.

works for mee too. nvidia prop. driver.

dimitri (dimitri-vanlanduyt) wrote :

Works for me as well; samsung n310 netbook (intel GPU)!

Wow, superb work Daniel! This was a long standing highly technical bug, and more importantly one with a massive amount of dupes. You're made of awesome!

A round of applause for Daniel please!

Andrzej Kłapeć (solidslash) wrote :

Works amazingly well with AMD's fglrx driver. Thanks!

Andrea Azzarone (azzar1) wrote :

I still have the problem: http://twitpic.com/5q1dso

pablomme (pablomme) wrote :

@Andrea: the rectangle in your screenshot is partially transparent - wouldn't this be part of a "fade in" animation?

Andrea Azzarone (azzar1) wrote :

@pablomme: it is not trasparent... maybe the video logo makes it looks like trasparent.

Daniel van Vugt (vanvugt) wrote :

Fix committed to both unity 3 and 4 branches. It should (?) get pulled into the next unity update for natty, whenever that is...

Changed in unity:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

@Andrea: It does look like you still have the problem. Can you please report the version you have installed:
  dpkg -l | grep unity
and make sure you have logged out and logged in after installing the update?

If it's still a problem please attach details of your graphics hardware and driver so someone can try reproduce the issue.

Andrea Azzarone (azzar1) wrote :

Unity revno: 1279... I know how to compile, build and run unity from sources.

Andrea Azzarone (azzar1) wrote :

glxinfo output.

Andrea Azzarone (azzar1) wrote :

Embedded Intel® GMA X3100 Gfx (GM965/GL960), FSB 533 Max...
Single monitor, 1366x768.

I hope that this information is helpful.

Omer Akram (om26er) on 2011-07-18
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

I think I can confirm with Andrea that the bug is not totally fixed. Working on another bug (742664) in the same area of code, this bug seems to have come back. At least in my development build.

I think it's worth keeping the current fix that's already been committed, because almost everyone reports the bug is no longer visible. But I also think a better fix, perhaps in libdbusmenu (?), is still required.

Andrea Azzarone (azzar1) wrote :

@Daniel, the problem went away... I don't know way, but i think that i had "unupdated" indicators. I still have problems with network manager indicator that is mapped twice (but this is another bug i think).

Daniel van Vugt (vanvugt) wrote :

Well that's good news. I was never going to propose the change that reintroduced this bug. And with Andrea reporting it's "gone away", that means the fix has a 100% success rate.

Still, if another better fix can be found in libdbusmenu or elsewhere, then it would be worth doing also.

Daniel van Vugt (vanvugt) wrote :

Fix was released in Unity 4.4.0.

Changed in unity:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix was released in unity 4.4.0-0ubuntu1 for oneiric. Just missing in the commit log, but the code changes are definitely there.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
eZFlow (breakdevize) wrote :

When will this fix be released for Natty? It's taking way too long for such an ugly bug!

Daniel van Vugt (vanvugt) wrote :

The fix is ready in line for the next natty-update (3.8.18?):
    https://code.launchpad.net/~unity-team/unity/branch-3.0

However there is a pile of other bugs targeted for the same update but not yet fixed:
    https://launchpad.net/unity/+milestone/3.8.18

eZFlow (breakdevize) wrote :

Thanks for the info but i really believe fixes for such bugs should be pushed ASAP, instead of waiting for a pile of other bugs to be fixed who knows when.

Someone really has to change the way updates are released because bugs like this make Ubuntu feel like alpha quality.

pelle.k (pele2) wrote :

I tried the updated unity from daniels ppa, but since i run a gnome classic session, i wasn't sure if/how the fix would affect me. And sure enough, this fix only covers unity, which of course begs the question - isn't that a clear indication that the problem lies deeper than that, perhaps in gtk/metacity/compis/dbusmenu itself? The *menubar* flickers when new windows are opened, in fact, if you remove the "indicator applet appmenu" from the gnome-panel, you can still see the flicker and menu repainting itself in the application window (of say nautilus, that never used to flicker like that) when new windows are spawned. Also, the drop downs from the menubar (when scrubbing it) causes flicker (both with indicator applet appmenu, and in-window menu).
Thoughts?

eZFlow (breakdevize) wrote :

i have red its because of an extra X call being made causing the white boxes
so its not that deep afterall.
On Aug 4, 2011 11:45 PM, "pelle.k" <email address hidden> wrote:
> I tried the updated unity from daniels ppa, but since i run a gnome
classic session, i wasn't sure if/how the fix would affect me. And sure
enough, this fix only covers unity, which of course begs the question -
isn't that a clear indication that the problem lies deeper than that,
perhaps in gtk/metacity/compis/dbusmenu itself? The *menubar* flickers when
new windows are opened, in fact, if you remove the "indicator applet
appmenu" from the gnome-panel, you can still see the flicker and menu
repainting itself in the application window (of say nautilus, that never
used to flicker like that) when new windows are spawned. Also, the drop
downs from the menubar (when scrubbing it) causes flicker (both with
indicator applet appmenu, and in-window menu).
> Thoughts?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/687567
>
> Title:
> Global menu causes white "flashes" when scrubbing/moving with mouse
> fast over menus
>
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> When I open menu in some application and then move mouse fast to the
> left or right so different items are expanded I see ugly white flash
> before content of the menu is rendered.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/687567/+subscriptions

Daniel van Vugt (vanvugt) wrote :

I agree there might be a lower-level issue yet to be fixed. Maybe dbusmenu but I don't think that's used in the Classic session.

I can't reproduce the flickering in the classic session that pelle.k describes. I suggest trying to take a video of the problem and logging a new bug. It does not seem to be the same as this one.

Pako (elektrobank01) wrote :

Others desktop should be reference for responsiveness in Ubuntu. Nobody has the answer why Compiz works extremely fast and responsive only on Mandriva GNOME and no other distribution, there is something in Mandriva that outputs such smooth and responsive desktop effects and frame rates. Put them side by side and you'll see what I'm talking about. You have to examine xorg.conf, nux and theme engines, not Compiz.

Daniel van Vugt (vanvugt) wrote :

Pako, this bug was Ubuntu-specific because it was caused by Unity.

Compiz in general has numerous performance problems that we are aiming to fix in time for Ubuntu 12.04. Early testing suggests that Compiz in Ubuntu 12.04 will be "extremely fast and responsive". Though the only difference between Compiz in Ubuntu 11.10 and Mandriva I can suggest is bug 861061 which is a performance issue caused by Unity.

You can read about some of the performance issues we aim to fix here:

Bug #92599: Incorrect (low/stuttering) refresh rate with NVIDIA driver
Bug #755841: [sandybridge] Graphics tearing when playing video
Bug #798868: unity video tearing when moving windows in oneiric with nvidia-current
Bug #876575: Moving windows between workspaces causes them to "jitter" / jump around
Bug #880707: [regression] Visible tearing is worse in 11.10 than 11.04, even when "Sync To VBlank" is enabled, but only when Unity is active.
Bug #888039: Gradual degradation in desktop performance.
Bug #891744: compiz, stuttering window movement
Bug #773861: Moving windows is very laggy with Compiz
Bug #861061: [regression] All apps have a lower frame rate under Unity.

Alaa Murad (alaamurad) wrote :

I solved this bug by disabling the Animations plugin in Compiz .

I think it related to "(type=Menu | PopupMenu | DropdownMenu | Combo | Dialog | ModalDialog | Normal)" Fade effect setup in that window of configuration.

I found a handy way for debugging Compiz problems is by disabling a plugin at a time, then wait for 10 seconds or more for the action to take effect and move on to the next one until I see some changes.

Aladdin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers