remove Super + scroll shortcut in enhanced zoom

Bug #684925 reported by Didier Roche on 2010-12-03
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
compiz-fusion-plugins-main (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

after the discussion on bug #683635 and rethinking our default, we have the ezoom plugin needed for different tasks in compiz. However, [Super] + using the mouse scroll enables to be in "zoomed" mode, with the mouse tracking the position and typing there.

Even if this functionnality is "fun" and "geeky to show to others how compiz cool is", I'm thinking about when I'm using it, and apart when I have an issue which a flash video which doesn't want to go fullscreen, I would say "never". I think this can be more harmful to the user who triggers that without noticing and without any clue why "it's zoomed" and they can't remove it.

Should we rather disable the "zoom in/zoom out/zoom box" shortcuts?

Didier Roche (didrocks) on 2010-12-03
Changed in unity:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
David Callé (davidc3) wrote :

I'm suscribing themuso to this bug to notify the Accessibility team.

Didier Roche (didrocks) wrote :

Nice idea David. I think that if it's important accessibility wise, the shortcut can be activated (or another one) when accessibility mode is on.

Travis Watkins (amaranth) wrote :

OS X has this enabled by default. ;)

Seriously though, I can't see how someone could hit this combination of keyboard and mouse by accident and not know what buttons they had pressed.

Didier Roche (didrocks) wrote :

Well, I saw that more than once at our ubuntu party with beginners… So yeah, I can see how someone could hit that by accident:
- scroll with the mouse in a browser
- hit accidentely the keyboard ([supe]r is just one key press, not a combination)

Let's see what's the opinion of the design and accessibility teams on that.

I agree, this should be something that's enabled as part of the
accessibility, and not by default.

Mark

I just got myself stuck in this mode without an obvious way out. Using mumble I have push-to-talk set to super+t, so holding super down while speaking I must have bumped the middle click which I think enables zoom box mode. Not only did I end up zoomed in without knowing how/why it happened, but I also have scrolling disabled on my touchpad. To zoom out you have to use super+scroll down. My only escape route was to restart compiz.

Luke Yelavich (themuso) wrote :

The reasons given here are valid, so go ahead. If people want it changed, it can be re-considered then, but can certainly be enabled explicitly for the accessibility cases that need it.

frizzle21 (frederik-nnaji) wrote :

i love the feature, i also agree 100% with the keyboard mapping.
* it is easy to remember
* fast interaction
* super fast response

As long as no equivalently simple alternative becomes available, removing this would feel like a step backwards to me!
I believe removing it for the default installation was already attempted in previous cycles.. then, i was always forced to install CCSM in order to put my precious Compiz feature back on..

my number one Compiz feature for long, until i discovered Super+W ;)

Didier Roche (didrocks) on 2010-12-13
Changed in unity:
status: Incomplete → Fix Released
Changed in ayatana-design:
status: New → Fix Released
affects: compiz (Ubuntu) → compiz-fusion-plugins-main (Ubuntu)
Changed in compiz-fusion-plugins-main (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-fusion-plugins-main - 0.9.2.1-0ubuntu6

---------------
compiz-fusion-plugins-main (0.9.2.1-0ubuntu6) natty; urgency=low

  * debian/control:
    - rebuild and pick latest for ABI breakeage
  * debian/patches/02_no_fade_on_static_switcher.patch:
    - no fade on staticswitcher (LP: #683635)
  * debian/patches/03_default_options.patch:
    - enable window snap by default
    - disable ezoom mouse scrolling by default (LP: #684925)
 -- Didier Roche <email address hidden> Mon, 13 Dec 2010 16:42:59 +0100

Changed in compiz-fusion-plugins-main (Ubuntu):
status: Fix Committed → Fix Released
Léa GRIS (lea-gris) wrote :

Actually I have already re/enabled mouse wheel events for zoom control in compiz using CCSM but, the events are not recieved by compiz when I select/click a window area. I have to be hover some window decoration area for compiz to recieve the wheel super+wheel events, or must step some window switcher before. In all other cases, it no longer work despite beying enabled in compiz.

~/.config/compiz-1/compizconfig/Default.ini
Already having :
[ezoom]
s0_zoom_in_button = <Super>Button4
s0_zoom_out_button = <Super>Button5

As a visually impaired, I rely heavilly on the ezoom feature and the ease of mouse wheel control for zoom. But now in 11.04 latest update, this thing is broken as explained above

Léa GRIS (lea-gris) wrote :

I add that now in compiz zoom, unless having mouse tracking set to 1, there is a huge lag when moving window, having the window moving smoothly and the zoomed mouse pointer lagging behind.
It worked without lag before.

Didier Roche (didrocks) wrote :

Ok, this is a separate issue then, regression from 0.8.
Can you please copy and past that (and give details information) on another bug report, please?

Jiri Grönroos (jiri-gronroos) wrote :

Modifying summary to avoid duplicates (if people search for enhanced zoom, not "ezoom").

summary: - remove Super + scroll shortcut in ezoom
+ remove Super + scroll shortcut in enhanced zoom
NickNackGus (nicknackgus) wrote :

"Fun"? "Geeky"? I use this plug-in every day! It's the best zoom tool I've seen for Ubuntu, allowing me to read fine print with ease, or clearly illustrate a section of a screen for someone. It isn't enabled by default anyway, so it isn't an issue for people who accidentally trigger it. So feel free to leave it disabled by default, but don't remove it altogether. Don't remove scroll-based zoom either, I find both scroll-based zoom and key-based zoom to be very easy to use.

Léa GRIS (lea-gris) wrote :

I do *need* this tool everyday because I am visually impaired. This is the most usefull tool/feature from compiz and all it was done since is disable it? I have no pleasant or soft wording to tell you how bad I feel about that. Please keep in mind removing this compiz enhanced zoom or rendering it impracticable is leaving me and many visually impaired in the dark, for the sake of preventing some random idiot from zooming by accident.

FYI, Mac OS implemented a behavior so that if a user starts using the mouse with zoom set to >=25%, it will automatically zoom back out.

Still, I've seen some mac users confused as to how they got a zoom anyway. So it may be preventative but it in no way eliminates.

Also, this seems to have been enabled by default in 12.04 again (at least for now).

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers