compiz crashed with SIGSEGV in g_source_unref()

Reported by FabrizioOrsini on 2010-12-02
78
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Unity
High
Jason Smith
compiz (Ubuntu)
High
Jason Smith

Bug Description

Binary package hint: compiz

ubuntu desktop i386
natty 11.04 alpha 1

go in appearance preferences select visual effects and then select extra

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop2-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
CompizPlugins: [shift,wobbly]
Date: Thu Dec 2 14:33:51 2010
ExecutablePath: /usr/bin/compiz
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
MachineType: System manufacturer System Product Name
PciDisplay: 01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV770 [Radeon HD 4870] [1002:9440] (prog-if 00 [VGA controller])
ProcCmdline: /usr/bin/compiz
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu2
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SegvAnalysis:
 Segfault happened at: 0x865e09 <g_source_unref+25>: mov 0x10(%eax),%edx
 PC (0x00865e09) ok
 source "0x10(%eax)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 g_source_unref () from /lib/libglib-2.0.so.0
 Glib::Source::unreference() const () from /usr/lib/libglibmm-2.4.so.1
 PrivateScreen::~PrivateScreen() ()
 PrivateScreen::~PrivateScreen() ()
 CompScreen::~CompScreen() ()
Title: compiz crashed with SIGSEGV in g_source_unref()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/25/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2208
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5Q
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2208:bd02/25/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5Q:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-7-generic

FabrizioOrsini (fabrizioorsini) wrote :
tags: added: iso-testing
Paolo Rotolo (paolorotolo) wrote :

Bug confirmed...

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → High
David Barth (dbarth) wrote :

Reproducible and with a rather clean stack trace. Proposing as a bitesize bug.

tags: added: bitesize
David Barth (dbarth) on 2010-12-17
Changed in unity:
status: New → Confirmed
importance: Undecided → High
blizzake (jbb421) on 2010-12-22
description: updated
David Barth (dbarth) on 2011-01-07
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.4
Changed in compiz (Ubuntu):
milestone: none → natty-alpha-2
assignee: nobody → Jason Smith (jassmith)
tags: added: compiz-0.9
David Barth (dbarth) on 2011-01-14
tags: added: unity
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.2.12
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Patrick (patrick-voegeli) wrote :

still happening here.... After it crashes i get:

compiz[14391]: segfault at 28 ip 00007f09ccb08335 sp 00007fffaefb6430 error 4 in libregex.so[7f09ccb03000+8000]

Always because of libregex. I doesn't only crashe in the appearance window, but everytime I open it crashes.

Carey Underwood (cwillu) wrote :

Patrick, see bug #706918

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers