Clicking on a launcher icon does not raise most recent window

Reported by Michael Terry on 2010-11-19
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

With the new compiz-unity, clicking on an application with multiple windows in the launcher seems to always raise the "first" window, not the most recently raised window.

That is, every time I click on the app, I get the same window, regardless of what I was looking at last. This is different than how it used to work and less useful I think.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.1.4-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.37-5.13-generic 2.6.37-rc2
Uname: Linux 2.6.37-5-generic x86_64
Architecture: amd64
Date: Fri Nov 19 13:13:23 2010
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Michael Terry (mterry) wrote :
Michael Terry (mterry) wrote :

Actually, to be more specific, it seems to raise all application windows when I click there. So it is technically raising the most recently used window. But I would expect my windows not to be re-z-stacked when I click the icon.

Didier Roche (didrocks) wrote :

Can reproduce that as well, it seems to raise a "random one" each time…

Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Neil J. Patel (njpatel) wrote :

This could be done in src/BamfLauncherIcon.cpp::OnMouseClick() by first copying the list of children returned by bamf_view_get_children earlier in the function, and then sorting the list by using g_list_sort and using the bamf_window_get_last_active (you only care if the child is a BamfWindow). By sorting the list, both the window spread/scale and the raising of the windows would be done in the correct order, so the most recently used window is at the top.

Be careful not to sort the actual GList returned by get_children, it's internal to bamf, and hence we need to make a copy.

Changed in unity:
milestone: none → 3.2.12
tags: added: bitesize
Jason Smith (jassmith) wrote :

Fixed in my branch

Didier Roche (didrocks) on 2010-12-06
Changed in unity:
milestone: 3.2.12 → 3.2.4
Omer Akram (om26er) wrote :

trunk does indeed fix the issue

Changed in unity:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2010-12-09
Changed in unity:
milestone: 3.2.4 → 3.2.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers