Launcher - Add 'launching' state to launcher icons

Reported by John Lea on 2010-11-17
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
Otto Greenslade
The Charlotte project
Critical
Alex Chiang
Unity
Low
Marco Trevisan (Treviño)
unity-2d
Low
Florian Boucault
unity design (obsolete project)
Triaged
Low
Otto Greenslade
unity-2d (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Add 'launching' state to launcher icons

Description:

1. As soon as a user clicks on a app in the Dash Application Lens, the Launcher should use the 'startup notification protocol' to *instantly* place a icon for the application in the launcher (in the 'launching' state). As soon as the app has finished launching, the Launcher icon should switch to the 'running' state.

2. As soon as a user clicks on a app in the Launcher that is not running, the Launcher icon should instantaneously switch to the 'launching' state. As soon as the app has finished launching, the Launcher icon should instantly switch to the 'running' state.

The following art assets will be attached to this bug:

1. Add 'launching' placeholder Launcher icon to handle the case where we know an app has launched but we don't have it's icon. *important* - this icon should only be used when we know an app has been launched but we don't know its icon. If we can get the application's icon quickly we should use this correct icon instead.

https://chinstrap.canonical.com/~sabdfl/11_04/desktop_and_netbook/launcher/unity_desktop_26_01_11_stages_fixed_10.png (note the outer glow shown in this same design is not the correct cursor select state, for the correct cursor select state see https://chinstrap.canonical.com/~sabdfl/11_04/desktop_and_netbook/launcher/select/ )

Notes:

 - we flash the backlight of the icon during launch

 - as soon as we have startup notification, we create an item in the
launcher, in grayscale, and start flashing its backlight

 - as soon as we know the desktop file and hence icon, we transition to
the icon backlight from grayscale to an appropriate colouring based on the icon

Finally we need a instant "flash" on click. See bug #893140 for a full description of this instant feedback issue.

John Lea (johnlea) on 2010-11-17
Changed in unity-design:
status: New → Incomplete
assignee: nobody → Otto Greenslade (otto-chaotic)
John Lea (johnlea) on 2010-11-17
description: updated
John Lea (johnlea) on 2010-11-17
tags: added: udn-launcher
John Lea (johnlea) on 2010-11-18
tags: added: udt
Changed in unity-design:
status: Incomplete → Triaged
importance: Undecided → Critical
John Lea (johnlea) on 2010-11-19
Changed in ayatana-design:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Otto Greenslade (otto-chaotic)
John Lea (johnlea) on 2010-12-13
description: updated
John Lea (johnlea) on 2010-12-15
description: updated
John Lea (johnlea) on 2010-12-15
description: updated
John Lea (johnlea) on 2010-12-16
description: updated
John Lea (johnlea) wrote :

> > So the thing about startup notification is they are implemented by the
> > launcher and not the launchee. Therefor there should be, in unity, no
> > way to launch something that produces a startup notification where we
> > dont immediately know the .desktop file. If you were to say launcher
> > firefox from a terminal, no startup notification is produced.
> >
> > I cannot think of a situation is the final state of unity, short of
> > running GNOME Panel side by side where we wont know the .desktop file
> > when startup notifications are issued. (startup notifications can pass a
> > ton of optional information, GNOME Panel passes absolutely none)
Ah, that's useful info. Surely the app *can* say "hey, in case the
launcher didn't tell you, I'm starting baby!"?

What about cases like double-clicking a file in Nautilus, which opens it
in a specific app?

The animation I described might also be useful for the case of a USB
device that can be detected before it can be identified (we know a USB
device is there for some time before we know what it is).

Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
milestone: none → 3.6
Changed in unity-2d:
milestone: 3.6 → none
John Lea (johnlea) on 2011-02-23
description: updated
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity-2d:
milestone: none → 3.8
importance: Undecided → High
Changed in unity-2d:
importance: High → Critical
assignee: nobody → Florian Boucault (fboucault)
tags: added: charlotte-backport-needed
John Lea (johnlea) on 2011-03-08
Changed in ayatana-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2011-03-08
Changed in unity:
status: New → Confirmed
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-03-11
description: updated
Alex Chiang (achiang) on 2011-03-11
Changed in charlotte:
assignee: nobody → Alex Chiang (achiang)
milestone: none → m4-rc1
status: New → Triaged
Changed in unity-2d:
status: Confirmed → In Progress
Alex Chiang (achiang) on 2011-03-21
Changed in charlotte:
milestone: m4-rc1 → none
Alex Chiang (achiang) on 2011-03-22
Changed in charlotte:
milestone: none → m4-rc2
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
Florian Boucault (fboucault) wrote :

Fix has been backported from lp:unity-2d (natty) to lp:unity-2d/0.4 (maverick).

Changed in charlotte:
status: Triaged → In Progress
Alex Chiang (achiang) on 2011-03-28
Changed in charlotte:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Alex Chiang (achiang) on 2011-03-29
Changed in charlotte:
importance: Undecided → Critical
Sean Feole (sfeole) wrote :

all icons on the unity taskbar flash as desired. Please see bug# 745336

tags: added: cqa-verified
Sean Feole (sfeole) wrote :

verified on build 20110329-2

Alex Chiang (achiang) on 2011-03-30
Changed in charlotte:
status: Fix Committed → Fix Released
Sean Feole (sfeole) on 2011-06-24
tags: added: cqa-verified-gm
Changed in unity:
assignee: Jason Smith (jassmith) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
importance: Undecided → Critical
John Lea (johnlea) on 2012-04-15
description: updated
tags: added: udp
John Lea (johnlea) on 2012-04-26
Changed in ayatana-design:
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-05-23
Changed in unity:
importance: Critical → Medium
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
John Lea (johnlea) on 2013-09-20
Changed in ayatana-design:
importance: Critical → Low
Changed in unity:
importance: Medium → Low
Changed in unity-2d:
importance: Critical → Low
Changed in unity-design:
importance: Critical → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers