skype instance is not detected properly in the launcher

Reported by Adi Roiban on 2010-10-26
292
This bug affects 71 people
Affects Status Importance Assigned to Milestone
BAMF
Medium
Marco Trevisan (Treviño)
Unity
Medium
Unassigned
Unity Distro Priority
Undecided
Unassigned
skype
Fix Released
Undecided
Unassigned
unity-2d
High
Unassigned
bamf (Ubuntu)
Medium
Unassigned
skype (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Skype locked to Unity launcher and then Skype is only running in system tray, Unity does not notice that skype is running, and when I press the skype button, instead of opening the already existent Skype instance, a new Skype instance is created.

Also transmission has the same issue.

Didier Roche (didrocks) wrote :

This issue is reproduceable and should be in bamf.

Changed in unity:
status: New → Triaged
Changed in bamf:
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
summary: - skype instance is not detected when closed to system tray
+ skype instance is not detected properly in the launcher
Changed in bamf (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: natty
Omer Akram (om26er) wrote :

Thanks for the bug report. Is this still an issue with Ubuntu 11.04? if so, could you please provide us with a few steps to reproduce this problem?

Changed in bamf:
status: Triaged → Incomplete
Changed in bamf (Ubuntu):
status: Triaged → Incomplete
Changed in unity:
status: Triaged → Incomplete
Changed in bamf:
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Changed in bamf (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

Actually I can reproduce this bug after I found the steps in a duplicate bug reported for Ubuntu 11.04

Marius B. Kotsbak (mariusko) wrote :

Japp, it is easy to reproduce. Just start Skype and close the Skype window (do not use minimize button) and the click the Unity icon and another instance starts.

Bilal Shahid (s9iper1) wrote :

i can reproduce this bug i also confirm it

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → High
Florian Boucault (fboucault) wrote :

This bug seems to be a specific instance of bug #705267 but its popularity warrants keeping it separate.

Jacob Mansfield (cyberjacob) wrote :

also exists in 11.11

markus haider (markus.haider) wrote :

I also experience this in 11.10 beta 2

tags: added: natty. oneiric
removed: natty
JamesGthang (jamesgthang) wrote :

I found a workaround on the Skype forums that may be helpful.
http://forum.skype.com/index.php?showtopic=332401

Here's what I did:
- downloaded the python script in that post (ensures that only a single instance of skype is started)
- copied the script to /usr/local/bin
- edit the "Main Menu" and added a new item called skype-single-instance in the network category
  + also used the same skype icon (/usr/share/icons/skype.png)
- started the skype-single-instance from the dash
- when the icon showed up in the launcher I right-clicked and selected "keep in launcher"

now I can close the skype contacts window with ALT-F4 or the close button and if I want Skype back I can click on the skype-single-instance icon in the launcher.

Michał Sawicz (saviq) wrote :

On a related note, as per last paragraph of http://agateau.wordpress.com/2011/09/23/make-skype-a-bit-less-shy/ remember to `sudo apt-get install sni-qt:i386` to get a Skype indicator that might reduce the impact of this bug.

Didier Roche (didrocks) on 2011-11-14
Changed in unity-distro-priority:
status: New → Fix Committed
Bilal Shahid (s9iper1) on 2011-11-17
Changed in unity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Felix Ruess (flixr) wrote :

Still the case in 11.10 with sni-qt and sni-qt:i386 installed. The skype indicator does not change this, as soon as skype is hidden to the tray the dash doesn't pick it up anymore.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Luis Alvarado (luisalvarado) wrote :

Confirmed in 11.04, 11.10 and even on the beta1 of 12.04

tags: added: rls-p-tracking
komputes (komputes) on 2012-03-20
tags: added: css-sponsored-p natty
removed: natty.
komputes (komputes) on 2012-03-20
tags: added: rls-mgr-p-tracking
Tim Penhey (thumper) on 2012-03-28
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Jason Smith (jassmith) wrote :

We can't fix this because skype is unmapping its window when you hit the close button and then launching a new instance when you run its binary again. Unmapping all windows effectively closes an application from the user point of view.

Marius B. Kotsbak (mariusko) wrote :

Well, that is one of the bad things about using non free software (and hopefully we have a good alternative protocol/clients/servers), but it is possible to detect if the Skype process is running and use that to detect that it should be registered as running (probably what the script referred to above does).

Nicolò Zilio (nicolozilio) wrote :

I've Ubuntu 12.04 PP installed and up to date. The problem persist: many times unity don't detect properly skype instance so I need to kill skype and restart it.

description: updated
hdpq (defectoscopny) wrote :

Also having the issue in 12.04.

Todor Velichkov (tosho) wrote :

I had this issue in 11.10 x64 and still in 12.04 x64.
the skype app must die!

For your information, the bug has been fixed in Skype 4.0

Changed in bamf:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in unity-2d:
status: Confirmed → Invalid
Changed in bamf:
status: Invalid → Won't Fix
Changed in bamf (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid

I can also confirm that is is working just fine in ubuntu 12.10 with skype 4.0

Changed in skype:
status: New → Fix Released
Omer Akram (om26er) on 2012-08-16
Changed in skype (Ubuntu):
status: New → Invalid
status: Invalid → Fix Released
Adam Niedling (krychek) wrote :

I still have this issue with 12.04 and skype 4.0.0.8-0oneiric1.
I'm just wondering why it's oneiric instead of precise?

Didier Roche (didrocks) on 2012-12-11
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers