Top bar - Menus should be condensed to fit panel/overlay of appmenu

Bug #655184 reported by Filipp on 2010-10-05
410
This bug affects 65 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Some programs with long menus interfere with the panel items on the right side of the panel. The panel should switch to a condensed font, then elide longer menu names in order to bring the menu into line with panel length. In an extreme case, switch to a vertical
layout:

  File View Edit More
                 Tools >
                 Options >
                 Window >
                 Help

Related branches

Filipp (samoylovfp) on 2010-10-05
description: updated
Filipp (samoylovfp) wrote :
Didier Roche (didrocks) wrote :

Thanks for reporting this bug and help to make ubuntu better.
Can you file a screenshot please?

btw, it's not anymore UNR. It's called since lucid UNE and the project is now called unity.

Filipp (samoylovfp) on 2010-10-05
description: updated
Didier Roche (didrocks) wrote :

ok, good, now we have enough info :) what is your resolution btw?
(please use ubuntu-bug unity next time so that we can have all relevant info).

affects: netbook-remix → unity
Changed in unity:
status: New → Incomplete
description: updated
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Filipp (samoylovfp) wrote :
Didier Roche (didrocks) wrote :

in addition to the resolution, your locale can help, thanks!

Filipp (samoylovfp) wrote :

Resolution is 1028x600 (notebook is Samsung n150)
Ok, i will use ubuntu-bug from now, thank you

Filipp (samoylovfp) wrote :

LANG=ru_RU.utf8
LC_CTYPE="ru_RU.utf8"
LC_NUMERIC="ru_RU.utf8"
LC_TIME="ru_RU.utf8"
LC_COLLATE="ru_RU.utf8"
LC_MONETARY="ru_RU.utf8"
LC_MESSAGES="ru_RU.utf8"
LC_PAPER="ru_RU.utf8"
LC_NAME="ru_RU.utf8"
LC_ADDRESS="ru_RU.utf8"
LC_TELEPHONE="ru_RU.utf8"
LC_MEASUREMENT="ru_RU.utf8"
LC_IDENTIFICATION="ru_RU.utf8"
LC_ALL=

Didier Roche (didrocks) wrote :

great, thanks a lot for the info :-)

Filipp (samoylovfp) wrote :

Thank you for a quick response! =)

Filipp (samoylovfp) wrote :

Oops! Resolution is 1024x600

summary: - menu bar doesn't fit in panel
+ Menu's should be condensed to fit panel
summary: - Menu's should be condensed to fit panel
+ Menus should be condensed to fit panel
description: updated
Changed in unity:
importance: Medium → High
David Barth (dbarth) on 2010-10-06
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: New → Confirmed

+1
this makes unity quite useless for me. In landscape it's okay most times (not if there is a lot of stuff in the notification bar though), but I have a Tablet-PC and like to use it Portrait mode quite frequently, and then this Problem appears most of the time (at a resolution of 768x1024)

It would also help if it was possible to remove stuff from the status bar, like the "username menu"

Changed in ayatana-design:
importance: Undecided → High
Filipp (samoylovfp) on 2010-10-19
description: updated
Didier Roche (didrocks) on 2010-11-01
summary: - Menus should be condensed to fit panel
+ Menus should be condensed to fit panel/overlay of appmenu
David Barth (dbarth) on 2010-11-08
Changed in unity:
milestone: backlog → none
tags: added: backlog

This is still valid with latest Unity.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.2.12
John Lea (johnlea) on 2010-12-15
description: updated
tags: added: udt
Changed in ayatana-design:
status: Confirmed → Fix Committed
assignee: nobody → John Lea (johnlea)

John, we really can't auto-scroll menus. We could switch to a vertical
layout:

  File View Edit More
                 Tools >
                 Options >
                 Window >
                 Help

But auto-scroll... not ;-)

Mark

This doesn't help much, but in the context of the texmaker screenshot above. This application would have difficulties displaying this menu on anything but a fully maximised window on this resolution.

If you take away the ubuntu logo, and the indicators the menu would only just fit in the horizontal space. I'm not really sure what to suggest to fix this. A vertical menu doesn't really light my fire if you know what I mean.

Pako (elektrobank01) wrote :

I think the default font size should be changed from 10 to 9, thus will fit most of the long menus, it is still quite visible and it looks more professional.

John Lea (johnlea) on 2011-01-13
description: updated
Changed in ayatana-design:
status: Fix Committed → Triaged
assignee: John Lea (johnlea) → Otto Greenslade (otto-chaotic)
David Barth (dbarth) on 2011-01-13
Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
milestone: 3.2.12 → none
Paul Sladen (sladen) wrote :

I have three very early test cuts of Ubuntu Condensed (different levels of horizontal condensation), these aren't ready for general testing or variation, but it might be good to test these in anger... pester me if somebody is working on this.

Florian Boucault (fboucault) wrote :

For information, here is how it looks like in Unity 2D: http://people.canonical.com/~kaleo/unity/long_menus.png

Florian, screenshot without a pointer covering the interesting bits
would be more useful :-)

@Mark, yep, that was silly :) Screenshot updated.

Paul Sladen (sladen) wrote :

Would it be worth expanding the ">>" menu to be a bit larger.

One could possibly even be really cunning and make it proportional in size to the number of sub-menus it is replacing. (">> (2)" or ">>>>" ">>>>>>>").

No, please just use "More" and leave it at that. We'll need to make sure
top-level hotkeys (like Alt-H) jump all the way to the correct end menu.

Mark

Some programs show overleaped program titles and menus. So you cannot see what you're doing on the screen. This is the same problem but on the left end of the panel. Who can tell me what ActualiFile is? Longer program names disturb the menu items and make them go blind.

Stefan Löffler (st.loeffler) wrote :

FWIW, here's a screenshot of my netbook/tablet (Asus EeePC T101MT) in portrait mode as already mentioned by sanktnelson (comment #12). Of the 7 menus of gedit, only the first two are visible.

In view of this, I would prefer a "More" button that is considerably small (not wider than, say, the height of the menu bar; though it still has to provide enough area to be clickable reasonably easily). Also note that in some cases, it might happen that no more than one menu icon (or not even that) can be displayed (in which case a button labeled "More" seems out-of-place).

nachokb (nachokb) wrote :

in extreme cases like Stefan's, perhaps something like "if it can't show at least two menus or XXX pixels, default to only show 'More'" but named something like "Menu" and having the whole app's menu in vertical/overflow layout...

Or adopt something like Firefox's approach and make the app name clickable and popup the menu (though that would be inconsistent with the default wide-enough behavior)

nachokb

FernandiTho' (fersss-trs16) wrote :

Use a crevron character (like ») for the menu, it’ll take less space than the word “More”. Agree with nachokb of comment #25 when less than two menus can fit, use a “Menu” button.

John Lea (johnlea) on 2011-06-20
tags: added: udo
Changed in ayatana-design:
assignee: Otto Greenslade (otto-chaotic) → John Lea (johnlea)
status: Triaged → Fix Committed
description: updated
John Lea (johnlea) on 2011-06-30
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jason Smith (jassmith) on 2011-06-30
Changed in unity:
assignee: nobody → Gord Allott (gordallott)

What about considering to fadeout the menu on the right side and to allow to move over the menus by dragging or moving the mouse to the edges of the appmenu as another or fallback solution?

Martín Cigorraga (msx+) wrote :

Hi, I copy here the bug I filled about this issue and was marked as duplicate as this bug, just to simplify's devs life:

[---------------
Hi team,

Early today I found that after installing extra plugins to GIMP -that added a couple of entries to the menu bar- the last two menu topics, Windows and Help, where overlapped by the indicators: you should seriously consider this because it's impossible to access the hidden menus without first quitting some indicators.
I mean, I love the indicators and it's Mac-like look, but there should be a way to hide some of them, either automatically or manually, just as happens on other systems like Win, KDE SC, etc.

Best,
Martin
----------------]

Cheers!

Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Medium → Critical
importance: Critical → High
assignee: nobody → Gord Allott (gordallott)
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
summary: - Menus should be condensed to fit panel/overlay of appmenu
+ Top bar - Menus should be condensed to fit panel/overlay of appmenu
Changed in unity:
status: Triaged → In Progress
assignee: Gord Allott (gordallott) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: Gord Allott (gordallott) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: backlog → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Eugene San (eugenesan) wrote :

What about gnome-fallback(gnome-classic)?
I would expect same behavior from indicator-applet.

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-27
tags: added: reviewedbydesignp
removed: backlog udo udp udt
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.