[dash] scrollbar's clickable zone should extend to the right border of the dash border

Reported by Mikko Ohtamaa on 2010-09-29
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Neil J. Patel
unity-2d
Medium
Florian Boucault
unity (Ubuntu)
Medium
Unassigned

Bug Description

Maverick Meerkat beta

Steps to repeat:

1. Start Unity
2. Open Applications
3. Put mouse cursor to the rightmost edge on the screen
4. Hold mouse button
5. Drag

Expected result:

The scrollbar is being held and the screen is scolled

Actual result:

Nothing. Scrollbar breaks Fitt's law and does not reach the holding area to the edge of the screen.

This greatly reduces usability on netbooks with little, non-accurate, touchpads.

Note that this bug concerns Unity view scrollbars only and applications are not affected.

This bug has been incorrectly marked to be a duplicate of #640858

Didier Roche (didrocks) wrote :

I don't get it then, you have this one pixel off which move all the scene by one pixel. This is a known clutter issue in some driver.

if I point the top-right edge of the scrollbar here with proper drivers, it works.

Ok - I will verify this again later and see it is a hardware issue. In any case the hardware is Asus 1005HA Eee PC with some Intel graphics chipset.

Here are some additional steps to reproduce

1) Scroll down Applications scrollbar to the middle of the screen
2) Move mouse cursor to the rightmost edge in the middle of the scrollbar
3) Press mouse button

Actual result:

Click does not touch the scrollbar and you can't drag it.

Didier Roche (didrocks) wrote :

oh ok, got it now. Yeah, it's not related to that one then and can reproduce it there.

I remember of a discussion on that, but looking for "scrollbar" in all states bug doesn't bring it back, removing duplicate then.

the scrollbar is not at the extreme end of the screen because its aligned
with the whole body of the dash and also the fact that unity is optimized
for touch too. that makes scrolling with thumb easier on a tablet I guess.

On Thu, Sep 30, 2010 at 3:03 PM, Didier Roche <email address hidden> wrote:

> oh ok, got it now. Yeah, it's not related to that one then and can
> reproduce it there.
>
> I remember of a discussion on that, but looking for "scrollbar" in all
> states bug doesn't bring it back, removing duplicate then.
>
> ** This bug is no longer a duplicate of bug 640858
> Launcher title disappears after mouse button is released
>
> --
> One pixel off error in the scroll bar
> https://bugs.launchpad.net/bugs/651398
> You received this bug notification because you are subscribed to Unity.
>
> Status in Unity: New
>
> Bug description:
> Maverick Meerkat beta
>
> Steps to repeat:
>
> 1. Start Unity
> 2. Open Applications
> 3. Put mouse cursor to the rightmost edge on the screen
> 4. Hold mouse button
> 5. Drag
>
> Expected result:
>
> The scrollbar is being held and the screen is scolled
>
> Actual result:
>
> Nothing. Scrollbar breaks Fitt's law and does not reach the holding area to
> the edge of the screen.
>
> This greatly reduces usability on netbooks with little, non-accurate,
> touchpads.
>
> Note that this bug concerns Unity view scrollbars only and applications are
> not affected.
>
>
>

Even if the visuals do not reach the border of the screen it is very important that the touch area would reach.

A similar bug was fixed for FF long time ago:

https://bugzilla.mozilla.org/show_bug.cgi?id=414842

 On 30/09/10 11:32, Omer Akram wrote:
> the scrollbar is not at the extreme end of the screen because its aligned
> with the whole body of the dash and also the fact that unity is optimized
> for touch too. that makes scrolling with thumb easier on a tablet I guess.

But you won't need to touch the scrollbar, just flick any part of the
dash to scroll. Eventually :-) So You should be able to go all the way
to the right with a mouse, click, and scroll.

Yeah, picking any part sounds better :-)

ok, confirming then for matching Fitt's law

Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity-2d:
importance: Undecided → Medium
status: New → Triaged
summary: - One pixel off error in the scroll bar
+ [dash] scrollbar's clickable zone should extend to the right border of
+ the dash border
tags: added: bitesize
Changed in unity-2d:
milestone: none → 3.8
Changed in unity-2d:
milestone: 3.8 → 3.6
assignee: nobody → Florian Boucault (fboucault)
status: Triaged → In Progress
tags: removed: bitesize
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2011-03-15
Changed in unity:
milestone: none → 3.6.6
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.8 KiB)

This bug was fixed in the package unity - 3.6.6-0ubuntu1

---------------
unity (3.6.6-0ubuntu1) natty; urgency=low

  * New upstream release:
    - drag and drop from dash to launcher issues (LP: #727675)
    - unity-panel-service crashed in g_type_class_meta_marshal (LP: #727788)
    - Dash: first-use text entry does not work until Alt-F2 version is used
      (LP: #735342)
    - compiz crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #734721)
    - drag from dash to launcher (LP: #662616)
    - Dash - Create single widget for Dashboard (LP: #683729)
    - [FFe] Recently installed applications should be easy to run
      (LP: #670403)
    - Pressing Alt key does not underline mnemonics (LP: #689179)
    - indicator-appmenu breaks Alt accelerator keys (LP: #663030)
    - can't pin KTouch to the launcher (LP: #693755)
    - Unity paints multiple times with multi-screen (LP: #727116)
    - unitymtgrabhandles crashes when no key is set (LP: #727144)
    - SIGSEGV in PlaceEntryHome::SetSearch (LP: #731927)
    - [launcher] New Default favorites (LP: #714707)
    - Dash: Alt-F2 Pressing enter on the dash can start the first entry of the
      second group from the history (LP: #734738)
    - Dash: keyboard arrow navigation disappears off bottom (LP: #735347)
    - Increase the size of the top left Launcher reveal area from 1px to a 3px
      by 3px square (LP: #736034)
    - [dash] scrollbar's clickable zone should extend to the right border of
      the dash border (LP: #651398)
    - Launcher - Replace Dash lens Launcher icons with updated versions
      (LP: #676613)
    - NuxUtilAccessible requires to implement support to key event listeners
      (LP: #702672)
    - launcher icons dnd doesn't behave correctly when the dash is in use
      (LP: #708885)
    - Keyboard-navigation: highlight stays after losing focus (LP: #713632)
    - Implement AtkComponent for ATK objects in the panel service
      (LP: #715297)
    - Super shortcuts for application place and worskspace swither conflicts
      with compiz keys (LP: #723273)
    - Use DeeIndex instead of strcmp in PlaceEntryHome (LP: #724886)
    - [dash] text cursor not vertically centred in the entry (LP: #724927)
    - Moving cursor in dash text entry field causes cursor artifacts
      (LP: #725493)
    - Missing "children_changed" event emission from the atk support
      (LP: #727137)
    - Typing should immediately search; focusing the search field is fiddly
      (LP: #727295)
    - "Find Internet Apps", "Browse the Web", and "Check Mail" are scattered
      in default Dash (LP: #729009)
    - Press-holding on a icon in the Launcher should de-couple the icon and
      enable the user to reorder the icon vertically without leaving the
      Launcher. (LP: #727922)
    - "Shortcuts" heading in Dash seems pointless (LP: #729000)
    - intellihide is incompatible with totem fullscreen / Still some false
      positive on ws switch (LP: #730679)
    - Launcher - provide visual design for launcher keyboard navigation
      (LP: #702490)
    - Dash - Update the 'Shortcuts' dash home icon (LP: #689763)
    - The Unity panel service Does not connect to the
      INDICATOR_OBJECT...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.