Using unity-launcher crashes Unity and causes a reload.

Bug #647039 reported by Owais Lone
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
Critical
Jason Smith
unity (Ubuntu)
Won't Fix
Critical
Unassigned

Bug Description

I upgraded Unity yesterday and am facing this problem. Whenever I try to use the dock, it crashes and everything is reloaded again. I'm on Maverick with latest updates using an Intel 965GM and the CLUTTER_VBLANK=none hack to workaround the white screen.

Revision history for this message
Didier Roche (didrocks) wrote :

Jason is currently looking at it, it seems (issues with 965GM)

Changed in unity:
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Owais Lone (loneowais)
summary: - Using the dock crashes Unity and causes a reload.
+ Using unity-launcher crashes Unity and causes a reload.
Revision history for this message
Didier Roche (didrocks) wrote :

ok, we can probably consider it as a SRU, can be get a backtrace of the issue, please?

Changed in unity:
milestone: none → 0.2-sru
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Owais Lone (loneowais) wrote :
Download full text (4.6 KiB)

Upon launch from normal Gnome session:

** (unity:14113): WARNING **: Unable to find the file menu stock item
** (unity:14113): DEBUG: New Desktop Window: 1E00023
(unity:14113): Indicator-Sound-DEBUG: At start-up attempting to set the image to audio-volume-muted-panel
** (unity:14113): DEBUG: Evaluating bitmask for '%l:%M %p'
** (unity:14113): DEBUG: Checking against 2 posible times
** (unity:14113): DEBUG: Guessing max time width: 48

(unity:14113): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(unity:14113): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(unity:14113): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(unity:14113): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(unity:14113): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(unity:14113): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
(unity:14113): libunity-private-DEBUG: unity_gesture_xcb_dispatcher_glue_init

** (unity:14113): WARNING **: The dbus name we want is already taken
(unity:14113): Indicator-Application-DEBUG: Connected to Application Indicator Service.
(unity:14113): Indicator-Application-DEBUG: Setup proxy signals
(unity:14113): Indicator-Application-DEBUG: Connect to them.
(unity:14113): Indicator-Application-DEBUG: Request current apps
(unity:14113): Indicator-Sound-DEBUG: about to connect to the signals
** (unity:14113): DEBUG: New Desktop Window: 6C00008
(unity:14113): Indicator-Application-DEBUG: Building new application entry: :1.40 with icon: bluetooth-disabled
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_volume_slider_widget
(unity:14113): Indicator-Sound-DEBUG: VolumeWidget::volume_widget_init
(unity:14113): Indicator-Sound-DEBUG: volume_widget_set_twin_item initial level = 23.999023
(unity:14113): Indicator-Sound-DEBUG: volume_widget_parent_changed
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_title_widget
(unity:14113): Indicator-Sound-DEBUG: new_title_widget ("Banshee")
(unity:14113): Indicator-Sound-DEBUG: TitleWidget::title_widget_init
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_metadata_widget
(unity:14113): Indicator-Sound-DEBUG: MetadataWidget::metadata_widget_init
(unity:14113): Indicator-Sound-DEBUG: Metadata::At startup and image path =
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_transport_bar() called
(unity:14113): Indicator-Sound-DEBUG: TransportWidget::transport_widget_init
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_title_widget
(unity:14113): Indicator-Sound-DEBUG: new_title_widget ("Rhythmbox")
(unity:14113): Indicator-Sound-DEBUG: TitleWidget::title_widget_init
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_metadata_widget
(unity:14113): Indicator-Sound-DEBUG: MetadataWidget::metadata_widget_init
(unity:14113): Indicator-Sound-DEBUG: Metadata::At startup and image path =
(unity:14113): Indicator-Sound-DEBUG: indicator-sound: new_transport_bar() called
(unity:14113): Indicator-Sound-DEBUG: TransportWidget::transport_widget_init
** (unity:14113): D...

Read more...

Revision history for this message
Owais Lone (loneowais) wrote :

and simply segfaults when trying to use the launcher.

If you want anything else, do tell me from where to get. :)

Revision history for this message
Didier Roche (didrocks) wrote :

Here are the infos to get a backtrace : https://wiki.ubuntu.com/UnityFilingBugs

Just cooked :)

Revision history for this message
CLI (m-wichtowski) wrote :

Fresh Maverick Netbook install on EeePC1000HE.
1/ start Firefox,
2/ close Firefox just after it is up and running,
3/ unity crashes and reloads.
I'll make some gdb logs if I'll find opportunity (this is not my netbook :( )

Revision history for this message
lasombra (lasombra) wrote :

This issue happens on Maverick (fully updated). The issue is as follows: While moving mouse from one icon to another or from an icon to the desktop, the restart occurs. It does not happen moving to an icon from outside (means moving from the desktop to an icon on the sidebar).

gnome-session[5350]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
gnome-session[5350]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
gnome-session[5350]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Window manager warning: Log level 8: g_object_ref: assertion `object->ref_count > 0' failed
Window manager warning: Log level 8: g_object_ref: assertion `object->ref_count > 0' failed
gnome-session[5350]: DEBUG(+): GsmXsmpServer: ice_io_error_handler (0x1e12900)
gnome-session[5350]: DEBUG(+): GsmXSMPClient: IceProcessMessagesIOError on '0x1df5da0 [mutter 1073a9cf746d08226e128843708494102600000053500039]'
gnome-session[5350]: DEBUG(+): GsmManager: disconnect client
gnome-session[5350]: DEBUG(+): GsmManager: disconnect client: /org/gnome/SessionManager/Client11
gnome-session[5350]: DEBUG(+): GsmXSMPClient: getting restart style
gnome-session[5350]: DEBUG(+): GsmManager: restarting app
gnome-session[5350]: DEBUG(+): Re-starting app: /org/gnome/SessionManager/App40
gnome-session[5350]: DEBUG(+): GsmAutostartApp: Couldn't stop app: Not running
gnome-session[5350]: DEBUG(+): Starting app: /org/gnome/SessionManager/App40
gnome-session[5350]: DEBUG(+): GsmAutostartApp: starting mutter.desktop: command=mutter startup-id=1073a9cf746d08226e128843708494102600000053500039
gnome-session[5350]: DEBUG(+): GsmAutostartApp: started pid:6698
gnome-session[5350]: DEBUG(+): GsmStore: Unreffing object: 0x1df5da0
gnome-session[5350]: DEBUG(+): GsmManager: Client removed: /org/gnome/SessionManager/Client11
gnome-session[5350]: DEBUG(+): GsmClient: disposing /org/gnome/SessionManager/Client11
gnome-session[5350]: DEBUG(+): GsmXSMPClient: xsmp_finalize (0x1df5da0 [mutter 1073a9cf746d08226e128843708494102600000053500039])
gnome-session[5350]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged

Revision history for this message
lasombra (lasombra) wrote :
Revision history for this message
Didier Roche (didrocks) wrote :

This is still not a backtrace:
Please see:
https://wiki.ubuntu.com/UnityFilingBugs

Revision history for this message
Owais Lone (loneowais) wrote :

Since we are moving to Compiz, I think working on this is a waste of time and resource. Shouldn't it be marked invalid.

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in unity:
status: Invalid → Incomplete
Changed in unity (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Owais Lone (loneowais) wrote :

oops, i forgot there are people on Maverick using mutter unity. Sorry.

Revision history for this message
papukaija (papukaija) wrote :

It's difficult to get a backtrace since, at least for me, this bug happens randomly, but most offen when closing an application.

Revision history for this message
papukaija (papukaija) wrote :

Btw, this bug is similar to bug 634701.

Revision history for this message
Michael Kogan (michael-kogan) wrote :

I'm observing this bug on a Thinkpad X40 with Intel GM855. Unity reproducibly crashes every time I hover the dock with the mouse pointer. Unfortunately the UnityFilingBugs wiki page didn't really work here (no mutter.log file was created) so I just ran gdb with tee (like "gdb mutter | tee mutter.log"), see attachment.

Changed in unity:
status: Incomplete → Confirmed
Revision history for this message
Mauricio Andrés (mauricioandres288) wrote :

I have the same problem, I'm starting like Unity, just fix that problem

Revision history for this message
Omer Akram (om26er) wrote :

how about we close this bug as 'wontfix' ;) since unity moved to compiz this issue should not be happening.

Revision history for this message
Didier Roche (didrocks) wrote :

right, there are little change it will be fixed in natty since we can't affort changing the driver or mutter there.

Changed in unity (Ubuntu):
status: Incomplete → Fix Released
Changed in unity:
status: Confirmed → Won't Fix
Changed in unity (Ubuntu):
status: Fix Released → Won't Fix
Revision history for this message
Michael Kogan (michael-kogan) wrote :

And what do maverick users do?

Revision history for this message
papukaija (papukaija) wrote :

Is this the right way to triage bugs? What those affected by this bug will do until Natty gets released?

Revision history for this message
papukaija (papukaija) wrote :

There seems to be a PPA with Compiz based Unity (both for Maverick and Natty) at https://launchpad.net/~unity/+archive/ppa

Revision history for this message
Didier Roche (didrocks) wrote :

We are really sorry for maverick users getting this bug (which isn't the majority, but still a lot of them, even on ATI card), but the time we would take to fix this bug in maverick will prevent to do a first class natty experience.

There is still the ubuntu desktop session in gdm to get the GNOME environment on maverick, or the netbook-launcher present in Lucid for a netbook environment. In any case, seeing this crash, I don't think maverick users having it is using unity mutter under maverick right now.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers