launcher tile super key overlay aesthetic

Bug #633069 reported by Christian Giordano on 2010-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
Johan Alenius
Unity
Fix Released
Medium
Mirco Müller
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The overlay created over the tile when the super-key is holden has few visual issues:

1) Vertical alignment of the box, should be centered relatively to the tile (now is a bit up, but of course the y position will be depended from the font size which should be customizable by the user at some extents)
2) The numbers (ie. 1) should be horizontally centered to its containing box
3) The text seems blurred, ideally it should be as crisp as in the OSD notification box

Related branches

Changed in ayatana-design:
importance: Undecided → Medium
summary: - launcher tile super key overlay
+ launcher tile super key overlay aesthetic

Also, I think the shape of the overlay is a little arbitrary. The
corners seem too rounded for such a small overlay. We should get a
precise spec of that from Otto.

David Barth (dbarth) on 2010-09-09
Changed in unity:
status: New → Incomplete
assignee: nobody → Mirco Müller (macslow)
milestone: none → backlog
Christian Giordano (nuthinking) wrote :

@mark, will assign it to Otto from the design point of view.

Changed in ayatana-design:
assignee: nobody → Otto Greenslade (otto-chaotic)
Changed in ayatana-design:
assignee: Otto Greenslade (otto-chaotic) → Johan Alenius (info-johanalenius)
Christian Giordano (nuthinking) wrote :

we have some good design but I wonder if for the time being we could just align the box and numbers as in the current specs/prototype.

Mirco Müller (macslow) on 2010-09-20
Changed in unity:
importance: Undecided → Medium
status: Incomplete → Confirmed
Mirco Müller (macslow) on 2010-09-23
Changed in unity:
milestone: backlog → 2010-09-24
Mirco Müller (macslow) wrote :

Although we don't have a new spec for this, I change the mentioned issues to make it at least a bit nicer for the RC.

Changed in unity:
status: Confirmed → In Progress
Mirco Müller (macslow) wrote :

The linked branch makes the overlays look like seen in the attached screenshot.

Changed in unity:
status: In Progress → Fix Committed
Otto Greenslade (otto-chaotic) wrote :

I think '1. Top Right' is how it should look based on our current thinking but I am proposing moving to '4. Key Regular' as it seems to fit more closely with other intended elements.

David Barth (dbarth) wrote :

For Natty Otto, for Natty ;) Mirco's patch fixes the main issue you documented in the bug report.

I've opened this bug to track the design change for the next cycle: https://bugs.launchpad.net/unity/+bug/646712

Mark Shuttleworth (sabdfl) wrote :

There's a lot of great tweaks in those renders, Otto, thank you. Much of
it for Natty, as David said. I'm glad to see the icons are bigger
relative to their containers.

W.r.t. the placement of the hotkey overlay:

 - please keep it at the top right, we only want to unfold as little as
possible (see Christian's mockup) not unfold the whole distance, it's
easier if the overlay wants to be on the top
 - please bear in mind we'll add a numeric emblem (e.g. number of emails
on the email icon).

Mark

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.44-0ubuntu1

---------------
unity (0.2.44-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - refine launcher tile super key overlay aesthetic (LP: #633069)
    - improve Cof logo (LP: #644686)
    - fix a crasher in the place activation (LP: #634364)
    - fixes favorite loading for didrocks (thanks!) (LP: #645835)
    - workaround translation issue for Unity trash (LP: #646653)
    - MT final adjustement for maverick (LP: #645848, #640501)
  * debian/control:
    - depend on latest unity-asset-pool
  * backport fix to respect workspace layout
  * debian/libunity0.symbols:
    - updated
 -- Didier Roche <email address hidden> Fri, 24 Sep 2010 19:57:46 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) on 2010-09-25
Changed in unity:
status: Fix Committed → Fix Released

@Mark, well, actually it's easier if the overlay is vertically in the middle, like in the prototype, because it could go on top or bottom depending in which direction the tile has been folded.

Mark Shuttleworth (sabdfl) wrote :

Ah, good point Christian, yes. Perhaps we could put the hotkey on the
right (vertically in the middle) and emblem on the left? That way, a
reveal could show both.

John Lea (johnlea) on 2011-01-14
Changed in ayatana-design:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers