the extreme top of unity panel has no effect on clicks

Bug #614945 reported by Omer Akram
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
High
Jason Smith
clutter-1.0 (Ubuntu)
Medium
Unassigned

Bug Description

starting with unity 0.2.24 the top 1px(?) does not take mouse clicks into account. indicators/CoF have no effect when clicked. attached video

Revision history for this message
Omer Akram (om26er) wrote :
Revision history for this message
Omer Akram (om26er) wrote :

confirming from the duplicate bug

Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks)
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → Medium
Neil J. Patel (njpatel)
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Medium → High
milestone: none → 2010-08-19
Neil J. Patel (njpatel)
tags: added: clutter
Changed in unity:
milestone: 2010-08-19 → 2010-08-26
Revision history for this message
Jason Smith (jassmith) wrote :

Found the bug, seems to be a simple case of < vs <=. Updated patch included

Changed in unity:
status: Triaged → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug is not an unity bug

affects: unity (Ubuntu) → clutter-1.0 (Ubuntu)
Changed in clutter-1.0 (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
status: In Progress → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutter-1.0 - 1.2.12-0ubuntu11

---------------
clutter-1.0 (1.2.12-0ubuntu11) maverick; urgency=low

  * debian/patches/01_speed_current_position_detection.patch:
    - update from Jason Smith to fix clicks on the first pixel of the unity bar
      (lp: #614945)
 -- Sebastien Bacher <email address hidden> Thu, 26 Aug 2010 10:16:12 +0200

Changed in clutter-1.0 (Ubuntu):
status: Fix Committed → Fix Released
tags: added: patch
Revision history for this message
Michael Terry (mterry) wrote :

I still get this bug with latest maverick. What info can I provide?

Changed in clutter-1.0 (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Michael Terry (mterry) wrote :

(I have clutter-1.0 1.2.12-0ubuntu13)

Revision history for this message
Didier Roche (didrocks) wrote :

targetting for this release. I confirm the latest version of Jason's patch is still in clutter

Changed in unity:
status: Invalid → Triaged
milestone: 2010-08-26 → 2010-09-24
Revision history for this message
Hernando Torque (htorque) wrote :

Works for me (CoF, window buttons, indicators).

Revision history for this message
Didier Roche (didrocks) wrote :

Oh, I mixed with a different issue:
- click on an indicator
- don't move the mouse at all and click again
-> nothing happened.

mterry, are you speaking about that one?
The edge are indeed working for me too

I'm opening another one for the other issue.

Changed in unity:
status: Triaged → Fix Released
Changed in clutter-1.0 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Michael Terry (mterry) wrote :

No, I can confirm that I'm still seeing the original bug. The top pixel of old-school GtkStatusIcons (like NetworkManager) work fine. But the top of indicators, the top-left logo button, and the window controls in unity do not work. I'm in a fully upgraded maverick.

Changed in clutter-1.0 (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 614945] Re: the extreme top of unity panel has no effect on clicks

 status confirmed

I can also confirm this, on Intel GM965 with 1280x800. I see a
single-pixel line at the top of the screen of what looks like the
wallpaper, above the panel, and clicking that top pixel doesn't do
anything, so it feels like the top pixel of all panel menus and
indicators is busted.

Mark

Revision history for this message
Didier Roche (didrocks) wrote :

ok, can't reproduce it on nvidia there, Jason seems to have some idea about this. We'll distro patch it on Monday if required.

Revision history for this message
Didier Roche (didrocks) wrote :

reopening the unity task to ease tracking

Changed in unity:
status: Fix Released → Triaged
Revision history for this message
Michael Terry (mterry) wrote :

I'm on Intel GM965. Here's a screenshot of my desktop to check for top pixel backgroundedness.

Didier Roche (didrocks)
Changed in unity:
milestone: 2010-09-24 → 2010-09-27
David Barth (dbarth)
Changed in unity:
milestone: 2010-09-27 → 0.2-sru
Revision history for this message
David Prieto (frandavid100-gmail) wrote :

I'm getting the bug with an Nvidia card and the nouveau driver.

tags: added: patch-needswork
removed: patch
Jason Smith (jassmith)
Changed in unity:
status: Triaged → Won't Fix
Omer Akram (om26er)
Changed in clutter-1.0 (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers