cannot close panel menus unless clicking on particular zones of the display

Bug #595880 reported by David Barth on 2010-06-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Mirco Müller
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When a panel menu is open (an indicator, or the new menubar), it's very difficult and frustrating to close the menu by clicking outside of it. Unless you click on particular parts of the Unity interface, it seems the system is not routing the clicks to close the menu.

Where it works:
- clicking on another indicator: this closes the first menu and opens the new one
- clicking on an application window or window content

Where it doesn't work:
- clicking on the empty panel zone in the center (between the ubuntu logo and the left-most system indicator)
- clicking on an empty desktop (ie you can see the wallpaper)
- clicking on the ubuntu logo (the menu closes, but the entry is kept highlighted)
- clicking on one of the launcher icons (the launcher is activated but the menu kept open)
- clicking on an empty zone of the launcher bar

Related branches

David Barth (dbarth) wrote :

Mirco: can you do some initial research to determine if the widget is getting any click event or not?
This is a tricky bug, so I assume event routing in mutter is problably the root cause.

Changed in unity:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Medium
milestone: none → 2010-06-24
status: New → Triaged
David Barth (dbarth) wrote :
Mirco Müller (macslow) on 2010-06-18
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) wrote :

I've made the panel-view receive and handle "button-release" events. So that part works. Now it needs to trigger any indicators to close their menu, if they have it open.

Mirco Müller (macslow) wrote :

I've written a patch to fix this bug. See the related branch at the top.

I've added the a public call popdown_current_menu() to MenuManager and added a signal-handler for "button-release-event" to Unity.Panel.View, which calls that. I've also merged-proposed it already:

https://code.edge.launchpad.net/~unity-team/unity/unity.fix-595880/+merge/27944

Mirco Müller (macslow) wrote :

I had to add an additional fix for the cases home-button (Ubuntu-logo), empty launcher-area and launcher-icon. Relevant branch merge-proposed here:

https://code.edge.launchpad.net/~unity-team/unity/unity.fix-595880-2/+merge/28034

Mirco Müller (macslow) on 2010-06-22
Changed in unity:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2010-06-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.12-0ubuntu1

---------------
unity (0.2.12-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - reordered applications launchers don't save their location (LP: #592087)
    - cannot close panel menus unless clicking on particular zones of the
      display (LP: #595880)
    - Add support for switching workspaces (LP: #594157)
    - Indicators should listen to show/hide from GtkWidget (LP: #590920)
    - Race in expose manager event processing (LP: #588299)
    - Files Place (View) - add support for file grouping (LP: #597256)
    - Apps Place (View) - add basic support (LP: #597257)
  * debian/patches/01_draw_background_with_nautilus_off.patch:
    - integrated upstream
  * debian/control:
    - add libclutk-dev as a dep to libunity-dev
    - bump clutk, dee and bamf dep to latest
 -- Didier Roche <email address hidden> Thu, 24 Jun 2010 21:12:40 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers