Add some sort of hint that the Ubuntu circle is click-able

Bug #592787 reported by zp on 2010-06-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Unassigned
Unity
Fix Released
Low
Mirco Müller
unity (Ubuntu)
Undecided
Unassigned

Bug Description

From my point of view the Ubuntu logo in the upper left looks like generic branding and not something you can click. Perhaps adding a glow-on-mouseo-over to it could improve that.

Related branches

Neil J. Patel (njpatel) on 2010-06-25
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Low
milestone: none → 2010-07-01
status: New → Confirmed
Neil J. Patel (njpatel) on 2010-06-25
Changed in unity:
assignee: Neil J. Patel (njpatel) → Mirco Müller (macslow)
Mirco Müller (macslow) on 2010-06-25
Changed in unity:
status: Confirmed → In Progress

Mirco, can you send me the pixel-perfect version of what you are aiming
to achieve here? If you don't have one in hand, please ask for it from
Otto before doing more on the subject. Also, I'd like to see mouse-over
and on-click states.

Mark

Mirco Müller (macslow) wrote :

I was about to ask for some input/direction form Design before getting to this. I'll ping Otto.

Should this bug report be expanded to all the buttons in the panel or
only the circle of friends?

On Mon, Jun 28, 2010 at 10:41 AM, Mirco Müller
<email address hidden> wrote:
> I was about to ask for some input/direction form Design before getting
> to this. I'll ping Otto.
>
> --
> Add some sort of hint that the Ubuntu circle is click-able
> https://bugs.launchpad.net/bugs/592787
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On 28/06/10 11:19, zekopeko wrote:
> Should this bug report be expanded to all the buttons in the panel or
> only the circle of friends?
>

Only the CoF, in part because it's switching from being "attached to the
Applications menu" to being an independent object that does its own
thing when clicked, and in part because it's behaviour is quite
different to everything else on the panel which can be clicked (they all
bring up menus).

Mark

Neil J. Patel (njpatel) on 2010-07-01
Changed in ayatana-design:
assignee: nobody → Neil J. Patel (njpatel)
Neil J. Patel (njpatel) on 2010-07-02
Changed in ayatana-design:
assignee: Neil J. Patel (njpatel) → nobody
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
milestone: 2010-07-01 → 2010-07-08
Ivanka Majic (ivanka) on 2010-07-02
Changed in ayatana-design:
assignee: nobody → Otto Greenslade (otto-chaotic)
Ivanka Majic (ivanka) on 2010-07-02
Changed in ayatana-design:
importance: Undecided → High
Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Otto Greenslade (otto-chaotic) wrote :

I have looked at a few alternatives and a glow seems to be the best option available. Can we use animation in this area though - this seems like a perfect opportunity for a proximity effect and would draw the eye more than a static glow?

Otto Greenslade (otto-chaotic) wrote :

Also - are limited to the menubar area or can we extend the glow beyond that?

Changed in ayatana-design:
status: New → In Progress
Mark Shuttleworth (sabdfl) wrote :

I think we need:

 - some sort of edge between the button and the rest of the panel (this
was in early mockups)
 - perhaps a mouseover highlight
 - a "clicked" state, for when it's depressed

We definitely don't want a glow all the time, we'll use a blue glow for
the "some app is calling for attention" state, remember.

Mark

On Wed, Jul 14, 2010 at 9:24 PM, Mark Shuttleworth
<email address hidden> wrote:
>
> I think we need:
>
>  - some sort of edge between the button and the rest of the panel (this
> was in early mockups)
>  - perhaps a mouseover highlight
>  - a "clicked" state, for when it's depressed
>
> We definitely don't want a glow all the time, we'll use a blue glow for
> the "some app is calling for attention" state, remember.
>
> Mark
>
> --
> Add some sort of hint that the Ubuntu circle is click-able
> https://bugs.launchpad.net/bugs/592787
> You received this bug notification because you are a direct subscriber
> of the bug.
>

IIRC from your blog post Mark, there was a plan to move the
close,minimize and maximize buttons to the panel so there is extra
vertical space by losing the window border. If that is correct then
the layout is Circle of friend, window buttons, menu, indicators.

The separation then would be easiest by simply using the existing
background of window buttons. I'm talking about the
depressed/carved-out part in which the current buttons sit.

If you do follow this plan I would suggest making circle of friends
bigger. It would protrude out of the panel and into the launcher.
Similar to Windows Vista's start button. That way it would be more
obvious that it is supposed to be clicked (especially if you do the
glow-based-on-mouse-proximity thing) and it would minimize the chance
of user clicking on the close button since the circle of friend would
be a bigger target to hit. The negative effect is that it's then
eating into the launcher but shouldn't be a problem considering the
stacking of icon in the launcher.

Yes, the window buttons will be rendered in the panel when the window is
maximised. That will *separate* the Ubuntu icon from the menu, but it
still doesn't indicate that the Ubuntu button is clickable. For that, we
need the edging.

Mark

Am Mittwoch, den 14.07.2010, 13:17 +0000 schrieb Otto Greenslade:

> Also - are limited to the menubar area or can we extend the glow beyond
> that?

 Theoretically it should be possible to have the glow grow beyond the
height of the menubar-area. But that is very tricky and time consuming!

Limiting the glow to the menubar-area will make things much simpler.

The only place we could straightforwardly make it grow into is the
launcher, which won't always be there (auto-hide will come in 11.04, and
then it won't even be directly connected to the panel).

Mark

Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
milestone: 2010-07-15 → 2010-07-22
Otto Greenslade (otto-chaotic) wrote :

Suggested states for the BFB.

Mark Shuttleworth (sabdfl) wrote :

Thanks Otto, those look good. Can I just ask that you also add the
"alert" (light blue glow) state, and the alert-and-hover state if it
will be different to the standard hover.

Finally, if you have any suggestions as to the "effect" when the states
transition, i.e. how the glow appears if it's not just a straight switch
on-off, please share them with the team.

Mark

Mirco Müller (macslow) wrote :

After extracting/drawing the needed assets from the mockup and panel-background, this is what I got so far. Still some bugs to fix like the flickering on mouse-enter, the non-reverting glow on the COF and unsetting of the the bfb-background for the search-view. See screencast.

Mirco Müller (macslow) wrote :
Mirco Müller (macslow) wrote :

The flickering is fixed in clutk trunk with rev. 237 now.

Mirco Müller (macslow) wrote :

Except for the not resetting glow, all issues fixed now.

Mark Shuttleworth (sabdfl) wrote :

Mirco, please make sure the edge of the clickable BFB is exactly at the
same point as the edge of the launcher. So the BFB sits perfectly on top
of the launcher. The current video has an obvious and ugly discontinuity.

Mirco Müller (macslow) wrote :

More pixel-tweaking...

Mirco Müller (macslow) wrote :

Almost there...

Mark Shuttleworth (sabdfl) wrote :

Looks much better now, thanks Mirco.

Otto Greenslade (otto-chaotic) wrote :

It shouldn't have a drop shadow though - can we remove that please.

Otto Greenslade (otto-chaotic) wrote :

BFB states including the "alert" (light blue glow) state, and the alert-and-hover state

Mark Shuttleworth (sabdfl) wrote :

That portfolio is great, Otto. It would be useful now we've got
something we like to add a statement about the radii and intensities of
the different glow effects, to help Mirco with the implementation.

Also, Mirco, remember that the blue colour is from a standard portfolio.
We want that stored in one place for all indicators (and used in
symbolic icons too) so please coordinate how that data is stored.

Mark

Mirco Müller (macslow) on 2010-07-22
Changed in unity:
status: In Progress → Fix Committed
Mirco Müller (macslow) wrote :

From the spec I remember that the blue color is marked with "not in scope for 10.10". This changed recently? I'll need to re-read that.

Mirco Müller (macslow) wrote :

Just verified by reading the launcher ix spec again. In section 4.6.3 is the remark I recall. Indeed a list with parameter-values for color-values (e.g. like the blue-value in section 4.6.2), spacing, margins, radii etc is always a great help simplifying the implementation. Schematics with values to fill in, like I handed you (Otto) this afternoon, are the most efficient way of passing that info. It eliminates any room for interpretation and keeps the focus on the implementation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.20-0ubuntu1

---------------
unity (0.2.20-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - Right click and selecting application doesn't launch it (LP: #592817)
    - Add some hint that the Ubuntu circle is click-able (LP: #592787)
    - Remove unpinned launchers when quitting the app (LP: #608492)
    - add to launcher isn't changed to remove from launcher (LP: #606266)
    - quicklist should be hidden when drag and drop a launcher (LP: #606258)
    - Fix reorganizing launchers (LP: #600738)
    - Removing active application makes the application closes (LP: #598175)
    - UnityLauncherQuicklistMenu clutter_actor_queue_relayout() warning
      (LP: #599718)
  * debian/control:
    - bump libclutk-dev to latest
  * debian/patches/01_add_dbusmenu_vapi_file.patch:
    - add missing file
  * debian/patches/02_disable_expandable_menu.patch:
    - disable latest changes making mutter respawning with some intel card
 -- Didier Roche <email address hidden> Thu, 22 Jul 2010 22:37:56 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
Mark Shuttleworth (sabdfl) wrote :

For 10.10, it *is* essential that the individual launchers can get a
blue triangle when a window is calling for attention. It would be nice
if the Ubuntu icon glow went blue as well whenever any of the launchers
have the blue state, but it's not essential.

Mark

David Barth (dbarth) on 2010-07-26
Changed in unity:
status: Fix Committed → Fix Released
status: Fix Released → Incomplete
milestone: 2010-07-22 → 2010-07-29
Changed in ayatana-design:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) wrote :

Mark, we have a bug tracking the updates to the "urgent hint set" part of the spec, including the blue arrow (#/582882), I can't guarantee it'll be there for A3, but definitely next week.

I think the confusion over the blue glow on the the Ubuntu button is that, if it goes blue on one of the apps calling for attention, what do we do when the user clicks it? I think it would be confusing if the home-screen popped up, and the button remained blue. Do we plan to provide an indication for the user on how to "un blue" the icon for 10.10, or am I thinking too much into this? :)

Mark Shuttleworth (sabdfl) wrote :

Good point Neil. I'm not too worried about it, I think we don't treat
the button differnetly if it's got the alert (clicking it still brings
up the dash). We *might* want to do something bolder to highlight the
actual apps that are calling for attention, but the real point of the
blue is to be the (sole) reminder of an alert when the launcher is
autohiding later.

Mark

This bug was definitely fixed at some point during the 0.2.22 cycle, but now I don't see the button outline when running the 0.2.22 release

Changed in unity:
status: Incomplete → In Progress
Didier Roche (didrocks) wrote :

confirmed too, there is a regression there

Changed in unity (Ubuntu):
status: Fix Released → In Progress
David Barth (dbarth) on 2010-08-03
Changed in unity:
milestone: 2010-07-29 → 2010-08-05
Mirco Müller (macslow) wrote :

Commit 412 disabled them. Neil's commit-messages doesn't contain the reason for this. I'll check with him why he did this.

Mark Shuttleworth (sabdfl) wrote :

Please don't re-implement the shadow, I've attached a mockup with a groove. Please use this as a guide, with Otto to provide precise pixelling.

David Barth (dbarth) on 2010-08-09
Changed in unity:
milestone: 2010-08-05 → 2010-08-19
David Barth (dbarth) on 2010-08-18
Changed in ayatana-design:
status: Fix Committed → Confirmed
Changed in unity:
status: In Progress → Incomplete
Otto Greenslade (otto-chaotic) wrote :

I have altered the colour slightly to match other representations of grooves elsewhere on the desktop and changed the position fractionally.

Changed in ayatana-design:
status: Confirmed → Fix Committed

On Mi, 2010-08-18 at 09:50 +0000, Otto Greenslade wrote:

> I have altered the colour slightly to match other representations of
> grooves elsewhere on the desktop and changed the position fractionally.
> ...

What's the pressed/active state meant to look like?

Best regards...

Mirco

Otto Greenslade (otto-chaotic) wrote :
Mirco Müller (macslow) wrote :

Drew updated icons, moved them into unity-asset-pool, re-enabled use of different background icons for different button-states.

See lp:unity-asset-pool rev. 36 and lp:~unity-team/unity/unity.fix-592787-2

Changed in unity:
status: Incomplete → In Progress
Mirco Müller (macslow) on 2010-08-18
Changed in unity:
status: In Progress → Fix Committed
Mirco Müller (macslow) on 2010-08-18
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2010-08-20
Changed in unity:
status: Fix Committed → Fix Released
Mark Shuttleworth (sabdfl) wrote :

I'm not seeing it on 0.2.28

 status confirmed

Mark

Changed in ayatana-design:
status: Fix Committed → Confirmed
Mirco Müller (macslow) wrote :

Indeed the correct artwork isn't used in the released version of unity. Realeased unity-asset-pool does have it. I'll look into this.

Neil J. Patel (njpatel) on 2010-08-20
Changed in unity:
milestone: 2010-08-19 → 2010-08-26
status: Fix Released → Triaged
Neil J. Patel (njpatel) on 2010-08-20
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Mirco Müller (macslow) wrote :

Something with the commit (rev 438) to unity trunk must have gone wrong. My changes are not in trunk. Looking at the history the commit for rev. 438 is empty here on LP. I'll resubmit the branch for review.

Mirco Müller (macslow) on 2010-08-23
Changed in unity:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.30-0ubuntu1

---------------
unity (0.2.30-0ubuntu1) maverick; urgency=low

  * New upstream release fixing those issues:
    - clicking on an app window in workspace switcher does not get it to focus
      (lp: #612327)
    - App name stays in panel after exit (lp: #613087)
    - Bright line at the bottom of the launcher bar (lp: #613084)
    - additional round corner when clicking on application places item
      (lp: #612542)
    - removing active application in the launcher make unity crashes
      (lp: #612535)
    - Intermittent loss of all input (lp: #607519)
    - Wallpaper picture-options are not all taken into account (lp: #605788)
    - Add some sort of hint that the Ubuntu circle is click-able (lp: #592787)
    - doesn't render appmenu accelerators correctly (lp: #601011)
    - should highlight the selected items (lp: #600946)
    - Files Place displays mimetype icons for file items when
      thumbnails are available (lp: #599896)
  * debian/control: build-depends on libxcb-icccm1-dev and libutouch-grail-dev
 -- Sebastien Bacher <email address hidden> Thu, 26 Aug 2010 18:31:40 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-09-02
Changed in unity:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Confirmed → Fix Committed
John Lea (johnlea) wrote :

Also remember to look at Bug #683179 which is related

John Lea (johnlea) on 2010-12-15
Changed in ayatana-design:
assignee: Otto Greenslade (otto-chaotic) → nobody
Kieran Hogg (xerosis) wrote :

This doesn't seem to be functional in Natty and something I'd quite like to see. Is that by design?

John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers