Clicking on launcher does not raise the last used window of the application

Bug #592583 reported by Neil J. Patel on 2010-06-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
unity (Ubuntu)
Undecided
Unassigned

Bug Description

If I have three Chromium windows opened, the launcher will decide one of them is the main window and two things happen:

1. I use Chromium window2, then go to xchat, then click Chromium icon, the launcher will raise a random window that it thinks is the main one (not the last chromium window I used, unless it was the main one)

2. If Chromium's window2 is active (and not the main one), and I click chromium again, it raises the main window instead of doing nothing as chromium is already active.

Related branches

Gord Allott (gordallott) on 2010-06-17
Changed in unity:
status: Confirmed → Fix Committed
Neil J. Patel (njpatel) on 2010-06-17
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.10-0ubuntu1

---------------
unity (0.2.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Panels don't reappear after leaving fullscreen (LP: #578956)
    - Background seems to be wrongly detecting screen size (LP: #578686)
    - Unity panels don't disapear when VLC is on full side mode (LP: #583053)
    - Clicking on launcher does not raise the last used window of the
      application (LP: #592583)
  * debian/netbook-launcher.preinst, debian/unity.preinst:
    - add debhelper token
  * debian/patches/01_draw_background_with_nautilus_off.patch:
    - draw background when nautilus don't draw desktop
 -- Didier Roche <email address hidden> Thu, 17 Jun 2010 18:35:26 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
Omer Akram (om26er) wrote :

This dont seem fixed. if empathy contact list and a chat window are opened. and chat window had focus before I switch to another app. then clicking again on the empathy icon bring contact list in focus. maybe this is another bug?

Neil J. Patel (njpatel) wrote :

Hi Omer, there are actually two parts to this bug, one inside unity and the other in bamf. could you make sure that you've got the very latest bamf and that bamfdamon has restarted (just do killall bamfdamon and restarted unity).

If it still doesn't work, then it's a valid bug, yes.

Omer Akram (om26er) wrote :

bamfdaemon == 0.2.30
unity == 0.2.10

did a reboot and the problem is there.

"This dont seem fixed. if empathy contact list and a chat window are opened. and chat window had focus before I switch to another app. then clicking again on the empathy icon bring contact list in focus. maybe this is another bug?"

>>> +1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers