reordered applications launchers don't save their location

Bug #592087 reported by Pete Goodall on 2010-06-10
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Gord Allott
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I have added a bunch of application launchers to the Unity launcher on the left, but wanted to change the order in which they appear. I drag (for instance) the Chromium icon to the top -> Logout -> Login and Chromium is back where it was before. Unity doesn't seem to be saving the location of the launchers.

This is on Maverick:
unity 0.2.7-0ubuntu1

Related branches

Didier Roche (didrocks) on 2010-06-10
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Didier Roche (didrocks) wrote :

additional info:
- new launchers are registered (in .gconf/desktop/unity), but changing the order doesn't change the favorite key order

Neil J. Patel (njpatel) wrote :

They wouldn't change the order of the list, rather they should save their location as a float value to their gconf key. Gord, could you please see what's going on, as I've seen this too ?

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
milestone: none → 0.2.10
Pete Goodall (pgoodall) wrote :

Fwiw, changing the order in gconf changes the order they appear in the launcher. There doesn't appear to be any order key in gconf from what I can see. For each launcher there is just desktop_file and type.

Gord Allott (gordallott) on 2010-06-17
Changed in unity:
milestone: 2010-06-17 → 2010-06-24
status: Triaged → In Progress
Gord Allott (gordallott) on 2010-06-24
Changed in unity:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2010-06-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.12-0ubuntu1

---------------
unity (0.2.12-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - reordered applications launchers don't save their location (LP: #592087)
    - cannot close panel menus unless clicking on particular zones of the
      display (LP: #595880)
    - Add support for switching workspaces (LP: #594157)
    - Indicators should listen to show/hide from GtkWidget (LP: #590920)
    - Race in expose manager event processing (LP: #588299)
    - Files Place (View) - add support for file grouping (LP: #597256)
    - Apps Place (View) - add basic support (LP: #597257)
  * debian/patches/01_draw_background_with_nautilus_off.patch:
    - integrated upstream
  * debian/control:
    - add libclutk-dev as a dep to libunity-dev
    - bump clutk, dee and bamf dep to latest
 -- Didier Roche <email address hidden> Thu, 24 Jun 2010 21:12:40 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
thgreasi (thgreasi) wrote :

I think this bug should be reopened because lately on my 11.10 installation I experience the following problem:
On my launcher I have pinned Home, Firefox, Thunderbird and Workspace Switcher.
Moreover I have made empathy run on startup, witch on every start places itself Firefox and Thunderbird.
I reorder the every time, but the problem reproduces on every startup.

j-stuffer (j-stuffer) wrote :

For me, the last pinned icon in the launcher (I have 10) very often stays the last, when another new (not pinned) application is opened. So VLC is my 10th program in the launcher (super + 0). This happens on my PC and on my laptop and also on the PC of my mother (she does not have 10 icons, but about 5-6).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers