Panels don't reappear after leaving fullscreen

Bug #578956 reported by Adrien Plazas on 2010-05-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Neil J. Patel
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I was playing AisleRiot in fllscreen and when I won the game, a box asked me if I want to start a new game or to exit the program. I decided to exit (still in fullscreen) and neither the panels nor the other windows reappeard, all I had was the wallpaper with a withe rectangle where the left panel was.

Related branches

It happened to me, if you close a program while in fullscreen, Unity doesn't bring panels back.
If you open a window (network-manager, for example), the panels come back. Maybe closing a program doesn't send back the "out of fullscreen" signal it needs to function properly...

Didier Roche (didrocks) wrote :

Definitively reproduceable. I guess this should be targeted to wncksync/liblauncher, but not sure.

Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Neil J. Patel (njpatel) wrote :

We think this is caused by our use of libwnck insIde the mutter plugin, and it causing a race with Mutters main loop. We hope to have the issue fixed by next week's release of Unity.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 0.2.0
Neil J. Patel (njpatel) on 2010-06-04
Changed in unity:
milestone: 0.2.6 → 0.2.8
Neil J. Patel (njpatel) on 2010-06-10
Changed in unity:
milestone: 0.2.8 → 0.2.10
importance: Medium → High
Neil J. Patel (njpatel) on 2010-06-17
Changed in unity:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.10-0ubuntu1

---------------
unity (0.2.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Panels don't reappear after leaving fullscreen (LP: #578956)
    - Background seems to be wrongly detecting screen size (LP: #578686)
    - Unity panels don't disapear when VLC is on full side mode (LP: #583053)
    - Clicking on launcher does not raise the last used window of the
      application (LP: #592583)
  * debian/netbook-launcher.preinst, debian/unity.preinst:
    - add debhelper token
  * debian/patches/01_draw_background_with_nautilus_off.patch:
    - draw background when nautilus don't draw desktop
 -- Didier Roche <email address hidden> Thu, 17 Jun 2010 18:35:26 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers