Background seems to be wrongly detecting screen size

Reported by Tom Haddon on 2010-05-11
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Jason Smith
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I have a script that sets my background to a photo with a certain tag from my F-Spot collection. However, with unity it seems to set/detect the screen size incorrectly, thinking that the desktop is a lot bigger than it actually is and only showing the top left portion.

Related branches

lp:~unity-team/unity/remove-background
Merged into lp:unity at revision 330
Neil J. Patel (community): Approve on 2010-06-11
Tom Haddon (mthaddon) wrote :
Tom Haddon (mthaddon) wrote :
ErM (ermster) wrote :

I too am seeing this issue. Tried to adjust background style setting in "Apperance" to stretch, center, and scale but there was no change.

Trying to be helpful: what is the output when you type xrandr in your terminal?

ErM (ermster) wrote :

:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 220mm x 129mm
   1024x600 60.0*+ 65.0
   800x600 60.3
   640x480 59.9

This is an Asus eeePC 1001p , that maximum size looks a little too large. I'm currently at maximum resolution 1024x600.

toor58 (uharrieman) wrote :

I have this bug as well. Screen resolution is to large for stock Ubuntu wallpapers. I also tried resizing in 'Appearance's'. did not work. Using Desktop Drapes, same issue.

When i use a Bing background image it shows a double picture, with the top one slightly smaller than the background image. Picture attached.

Also using Asus 1005HAB eee pc.

cariboo907 (cariboo907) wrote :

I have the same problem with my Compaq Mini 110. also 1024X600 resolution.

Neil J. Patel (njpatel) wrote :

Seems like the background rendering is ignoring image options and is also wrongly sized. Ideally we should only be showing the background painted by gnome-settings-daemon and not drawing one of our own...

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Low
milestone: none → 0.2.2
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

Don't hide desktop window(s) for window-picker mode, and therefore remove the use of Unity::Background from the mutter target

Changed in unity:
assignee: Neil J. Patel (njpatel) → Jason Smith (jassmith)
importance: Low → Medium
milestone: 0.2.8 → 0.2.10
status: Confirmed → Triaged
Neil J. Patel (njpatel) on 2010-06-17
Changed in unity:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.10-0ubuntu1

---------------
unity (0.2.10-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Panels don't reappear after leaving fullscreen (LP: #578956)
    - Background seems to be wrongly detecting screen size (LP: #578686)
    - Unity panels don't disapear when VLC is on full side mode (LP: #583053)
    - Clicking on launcher does not raise the last used window of the
      application (LP: #592583)
  * debian/netbook-launcher.preinst, debian/unity.preinst:
    - add debhelper token
  * debian/patches/01_draw_background_with_nautilus_off.patch:
    - draw background when nautilus don't draw desktop
 -- Didier Roche <email address hidden> Thu, 17 Jun 2010 18:35:26 +0200

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers