Upper angles of window not curved

Bug #1516403 reported by Fabio Marconi on 2015-11-15
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
High
Marco Trevisan (Treviño)
gtk+3.0 (Ubuntu)
High
Marco Trevisan (Treviño)
Xenial
High
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Medium
Marco Trevisan (Treviño)

Bug Description

Hallo
The upper angles aren't curved as all the other windows, see attached screenshot.
Best regards

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gedit 3.18.2-1ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-19.23-generic 4.2.6
Uname: Linux 4.2.0-19-generic x86_64
ApportVersion: 2.19.2-0ubuntu6
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Nov 15 17:21:04 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-10-11 (35 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151010)
SourcePackage: gedit
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Fabio Marconi (fabiomarconi) wrote :
Changed in gedit (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

Confirmed with photos

Sebastien Bacher (seb128) wrote :

That's an issue with GtkHeaderBar decoration and Unity and being working on from the compiz/unity side

affects: gedit (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Low → High
tags: added: rls-x-incoming
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
status: New → Confirmed
Will Cooke (willcooke) on 2015-11-23
tags: removed: rls-x-incoming
Changed in unity (Ubuntu Xenial):
importance: High → Medium
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: gtk (Ubuntu Xenial) → gtk+3.0 (Ubuntu Xenial)
Changed in gtk+3.0 (Ubuntu Xenial):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Xenial):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160310-0ubuntu1

---------------
unity (7.4.0+16.04.20160310-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Add a "Format..." option to volume icons. (LP: #1057008)

  [ Marco Trevisan (Treviño) ]
  * DashView: ensure that we update scaling when monitor changes (LP:
    #1546690)
  * DecoratedWindow: move the shadow under the window if we've a client-
    side decorated window with corners (LP: #1516403)
  * LauncherController: add overlay shortcut to all the
    WindowedLauncherIcon's we have
  * ThemeSettings: add small class for reading gtk settings for theming
    (LP: #1543757, #1288998)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 10 Mar 2016 10:09:34 +0000

Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
varlesh (varlesh-l) wrote :

Bug not fixed!
Unity 7.4.0+16.04.20160322-0ubuntu1
Font Viewer attcached

varlesh (varlesh-l) wrote :

It's problem tgk themes - Ambiance and Radiance. Because with Adwaita, Arc GTK and other not reproduced.
Please fix Ambiance and Radiance GTK Themes

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.18.9-1ubuntu3

---------------
gtk+3.0 (3.18.9-1ubuntu3) xenial; urgency=medium

  * Merge branch from Marco Trevisan to hide buttons in headerbar apps when
    they are maximised under Unity, and to fix the gradient to look good.

 -- Iain Lane <email address hidden> Thu, 24 Mar 2016 14:41:52 +0000

Changed in gtk+3.0 (Ubuntu Xenial):
status: In Progress → Fix Released

I'm still getting the issue here, except in my case the corners are white instead of black.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers