Force high gfx mode with UNITY_LOW_GFX_MODE == 0

Bug #1491913 reported by Sinclair Yeh on 2015-09-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Sinclair Yeh
7.2
Fix Committed
Low
Sinclair Yeh
unity (Ubuntu)
Low
Sinclair Yeh
Trusty
Low
Unassigned

Bug Description

While discussing bug #1491555, my colleague Brian Paul suggested that in addition to forcing low gfx mode with UNITY_LOW_GFX_MODE = 1, it would also be helpful to force it out of low gfx mode with UNITY_LOW_GFX_MODE = 0.

This way if Unity ends up in low gfx mode unnecessarily due to a wrong renderer string match, e.g. LLVM in the current case, there is a quick workaround to get out of it while a fix works its way through the release process.

The patch (signed-off-by: Sinclair Yeh <email address hidden>) attached adds this capability.

====

[Impact]
Running unity with UNITY_LOW_GFX_MODE=0 doesn't force it to use normal mode (if set from CCSM or requested by hardware)

[Test Case]
1. In CCSM go in unityshell settings, tick the option "Enable Low Graphics Mode"
2. Launch 'unity' from a terminal and it should be now in low-graphics mode
3. Launch 'UNITY_LOW_GFX_MODE=0 unity' from a terminal and it should be now in normal mode

[Regression Potential]
None

Related branches

Sinclair Yeh (sinclair-yeh) wrote :
Andrea Azzarone (azzar1) on 2015-09-08
Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
milestone: none → 7.3.3
Andrea Azzarone (azzar1) wrote :

Here [1] you can find the MP containing this patch.

[1] https://code.launchpad.net/~azzar1/unity/lp-1491913/+merge/270349

The attachment "low-gfx-override.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150910.1-0ubuntu1

---------------
unity (7.3.2+15.10.20150910.1-0ubuntu1) wily; urgency=medium

  [ Andrea Azzarone <email address hidden> ]
  * Add unit tests for unity::lockscreen::DBusManager.
  * Add/Update tests for gnome session manager.
  * Do not allow shutdown when screen is locked. (LP: #1460626)
  * Make sure we update the maximized window when "show
    desktop"/"restore desktop". (LP: #1485559)
  * Merge patch from https://launchpadlibrarian.net/216192448/llvm-
    fix.patch (LP: #1491555)
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)

  [ Andrea Azzarone <email address hidden> ]
  * Properly hide decorations when on "Show Desktop" mode. (LP:
    #1485073)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: force shell to be on top when there's a window
    fullscreen and we've a menu open. (LP: #591189)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 10 Sep 2015 15:37:46 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
assignee: nobody → Sinclair Yeh (sinclair-yeh)
Changed in unity (Ubuntu):
assignee: nobody → Sinclair Yeh (sinclair-yeh)
Changed in unity:
status: In Progress → Fix Committed
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello Sinclair, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Low
Sinclair Yeh (sinclair-yeh) wrote :

Thanks! Verified on trusty-proposed. This fix works for me. However, I've noticed that on 14.04, Unity seems to start in low graphics mode again.

This fix has been released, right?

https://bugs.launchpad.net/unity/+bug/1491555

Maybe there's something wrong with my configuration. I'll poke around a bit more.

Mathew Hodson (mathew-hodson) wrote :

In that bug you linked it says that the bug was fixed in the package unity 7.3.2+15.10.20150910.1-0ubuntu1, which was released for Wily not Trusty.

Sinclair Yeh (sinclair-yeh) wrote :

Ah, you're right.

tags: added: verification-donee
removed: verification-needed
tags: added: verification-done
removed: verification-donee
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers