Scrollbars in the dash show original Unity overlay version instead of the new Gnome OSB

Bug #1481706 reported by Will Cooke on 2015-08-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Committed
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Medium
Marco Trevisan (Treviño)

Bug Description

We decided to adopt upstream OSB in order to reduce our maintenance overhead. In order to maintain consistency we should replicate these new OSB in the dash.

Related branches

Will Cooke (willcooke) on 2015-08-05
tags: added: rls-w-incoming
affects: nux → unity
Andrea Azzarone (azzar1) on 2015-09-16
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2015-11-16
tags: removed: rls-x-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20151211-0ubuntu1

---------------
unity (7.4.0+16.04.20151211-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * unity: ensure we use python3 for the launch script and
    python2.7 for autopilot (LP: #1512909)

  [ Andrea Azzarone ]
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * Properly hide shortcut overlay window to avoid unnecessary redraws.

  [ Bryan Quigley ]
  * debian/control: Remove telepathy from recommends

  [ Eleni Maria Stea ]
  * Replaced deprecated calls in tests to get rid of compiler warnings

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: if a new window opens while spreading,
    spread again with proper match (LP: #1517455)
  * ExpoLauncherIcon: add Quicklist to switch workspace and see the
    selected one (LP: #750497)
  * PanelIndicatorEntryView: Activate menus on click, by drawing them as
    active (LP: #1513523)
  * PanelMenuView: ignore leave events when triggered by feeding nux
    manually (LP: #1513496)
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * SwitcherModel: allow to add/remove icons dynamically and update them
    when they require it (LP: #1512349)
  * SwitcherView: Add support to Alt+Key-right-to-tab to close the
    selected app/window
  * Switcher{View,Controller}: close active selection on Alt+q (LP:
    #1468820)
  * TextInput: show warning also when num lock is enabled
  * XKeyboardUtil: add ability to get keycodes from any relative
    position
  * debian/rules: enable unit tests on arm64 again (LP: #1514538)

  [ Sebastien Bacher ]
  * Updated apport hook to include: the compiz and xorg details, not
    only after asking users if the issue is a graphical one (which is
    weird question) the upstart logs for unity/ups/lockscreen some
    gsettings configurations (LP: #1508974)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 11 Dec 2015 12:46:16 +0000

Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers