new app does not have keyboard shortcut

Bug #1458950 reported by lucas mendes marques gonçalves on 2015-05-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Trusty
Medium
Unassigned

Bug Description

When a new app is opened, it is not added to the keyboard shortcuts
(see píctures)

http://i.imgur.com/SxBZ2fe.png626262

http://i.imgur.com/jhsUqTF.png636363

to reproduce:
1.open new aplication via the dash (i.e. click super key and open an application)
2.hold super and verify that application is not on the list of shortcuts yet
3.change foreground application; press super+number and verify that the new application (that you just opened on step 1) does not come back into focus

===

[Test case]
1. open new aplication via the dash (i.e. click super key and open an application)
2. hold super and verify that application is not on the list of shortcuts yet
3. change foreground application; press super+number and verify that the new application (that you just opened on step 1) does not come back into focus

[Regression potential]
Icons might be badly ordered when added from Dnd from dash or via gsettings

Related branches

description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2015-05-26
Changed in unity:
status: New → Confirmed
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Andrea Azzarone (azzar1) on 2015-05-28
Changed in unity:
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150627.1-0ubuntu1

---------------
unity (7.3.2+15.10.20150627.1-0ubuntu1) wily; urgency=medium

  [ Andrea Azzarone <email address hidden> ]
  * Fix a regression with urgent icons not showing up if launcher is
    hidden. (LP: #1450991)
  * Make sure new icons are added to the model before calling
    SortAndUpdate. (LP: #1458950)
  * This likely could fix
    https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1451613. At
    least the backtraces posted there suggest this. But I think that
    those backtraces are just leftovers of old crashes-on-unloading.

  [ CI Train Bot ]
  * New rebuild forced.

  [ Chris Townsend ]
  * Allow mouse clicks that are not in the visible area of the Quicklist
    to pass through down to the Launcher icon. Fixes a failing AP test.
    (LP: #1456245)

  [ Luke Yelavich ]
  * Implement filter results controls accessibility (LP: #1457071)

  [ Marco Trevisan (Treviño) ]
  * ApplicationManager: add missing features, keep a copy of views
    around
  * DecorationsForceQuitDialog: remove deprecated override style
    functions, use CSS
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT
    changes (LP: #1405349)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires
    a redraw (LP: #1461618)
  * PanelMenuView: connect to target window / application title changes
    (LP: #1418449)

 -- CI Train Bot <email address hidden> Sat, 27 Jun 2015 04:44:56 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed

Cool!

Thanks for the fix.

So... How do I download the package? Is there/can I build a version for 14.04?

Just to followup: is this bugfix coming to 14.04?

I'd kinda hope so, since 14.04 is an LTS release...

Is the bugfix already available on other release?

(I don't know much about the release cycle. Sorry. This is my first report)

Changed in unity:
milestone: none → 7.3.3
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello lucas, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium

Fix works for me on ubuntu 14.04.3

tags: added: verification-done
removed: verification-needed

Installed on 𝐔𝐛𝐮𝐧𝐭𝐮 𝟏𝟒.𝟎𝟒𝐋𝐓𝐒 "Trusty" all 3 patched 𝐔𝐧𝐢𝐭𝐲 𝟕 version 7.2.6+14.04.20151021-0ubuntu1 packages:

unity
unity-services
libunity-core-6.0-9

from the 𝒑𝒓𝒐𝒑𝒐𝒔𝒆𝒅 repo. Tested by opening an app, then before the app opens quickly changed to keyboard navigation mode (hold down Super key). Unity Launcher now shows shortcut number for the new app even though it appeared after the keyboard navigation mode was launched. So, tested and verified that this patch fixes the bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andrea Azzarone (azzar1) on 2017-10-13
no longer affects: unity/7.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers