AP test failure: unity.tests.launcher.test_keynav.LauncherKeyNavTests.test_launcher_keynav_changes_panel(Single Monitor)

Bug #1435830 reported by Stephen M. Webb on 2015-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Stephen M. Webb
unity (Ubuntu)
Undecided
Unassigned

Bug Description

AP test fails consistently on every run.

FAIL: unity.tests.launcher.test_keynav.LauncherKeyNavTests.test_launcher_keynav_changes_panel(Single Monitor)
----------------------------------------------------------------------
/var/log/syslog: {{{
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: login finished
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: Got token: ya29.OwFvVwItMuU7CMLyfIe22KhPBBlD_v62HgletZAa1aS8K5U1WNfqY6QL
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: Search changed to: 'Has'
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: Searching for: Has
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: Search changed to: 'HasFocus'
Mar 19 16:18:46 xt2-14 com.canonical.Unity.Scope.File.Gdrive[1599]: Searching for: HasFocus
}}}

unity-log: {{{
DEBUG 2015-03-19 16:18:41 unity.launcher.icon.application ApplicationLauncherIcon.cpp:173 Compiz active now true
DEBUG 2015-03-19 16:18:41 unity.launcher.icon.application ApplicationLauncherIcon.cpp:173 Terminal active now false
DEBUG 2015-03-19 16:18:52 unity.launcher.icon.application ApplicationLauncherIcon.cpp:173 Compiz active now false
DEBUG 2015-03-19 16:18:52 unity.launcher.icon.application ApplicationLauncherIcon.cpp:173 Terminal active now true
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/unity/tests/launcher/test_keynav.py", line 247, in test_launcher_keynav_changes_panel
    self.assertThat(self.unity.panels.get_active_panel().title, Eventually(Equals("Search your computer and online sources")))
  File "/usr/lib/python2.7/dist-packages/testtools/testcase.py", line 423, in assertThat
    raise mismatch_error
MismatchError: After 10.0 seconds test on MenuView.panel_title failed: !=:
reference = u'Search your computer and online sources'
actual = u''

Related branches

Stephen M. Webb (bregma) on 2015-03-24
Changed in unity:
assignee: nobody → Stephen M. Webb (bregma)
status: Triaged → In Progress
milestone: none → 7.3.3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150410.1-0ubuntu1

---------------
unity (7.3.2+15.04.20150410.1-0ubuntu1) vivid; urgency=medium

  [ Brandon Schaefer ]
  * When we get a launcher key press (ie. super key). We check if the
    command lens is open. If it is then just switch the lens to the home
    lens. This way we dont close the dash. (LP: #1108956)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Gerry Boland ]
  * SwitcherController: add first selection mode property, to decide
    what to select at first (LP: #998285)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: add first selection mode property, to decide
    what to select at first (LP: #998285)
  * UnityScreen: terminate spread if active when initiating Switcher
    (LP: #1412001)

  [ Stephen M. Webb ]
  * (Ubuntu packaging) move the session migration scripts to Python3
    (LP: #1440560)
  * fixed the Panel title string expected by Launcher keynav AP tests
    (LP: #1435830)
  * test_wm_keybindings: fix AP failures caused by upstream Compiz
    change (LP: #1294864)
 -- CI Train Bot <email address hidden> Fri, 10 Apr 2015 21:59:12 +0000

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2015-04-13
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers