firefox icon frequently replaced by placeholder

Bug #1407192 reported by Ian Nicholson on 2015-01-03
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
BAMF
High
Andrea Azzarone
Unity
Invalid
High
Andrea Azzarone
bamf (Ubuntu)
High
Andrea Azzarone

Bug Description

Several times over the last week I have noticed that the when I start firefox, the default icon is replaced by a grey square with a question mark in the center as shown in the attached image.
The only fix I've found is to unlock firefox from the launcher, quit the program, search for "firefox" in the dash, manually drag the icon onto the launcher, and then open it(i.e. if I start firefox directly from the dash, the grey icon appears on the launcher again).
I haven't noticed this occurring with any other program.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: unity 7.3.1+15.04.20141216-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.15.1-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Jan 2 21:38:32 2015
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7520G] [1002:9990] (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fb43]
InstallationDate: Installed on 2014-12-11 (23 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141210)
MachineType: TOSHIBA Satellite L875D
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.16.0-28-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/06/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 6.30
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: PLCSC8
dmi.board.vendor: AMD
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr6.30:bd12/06/2012:svnTOSHIBA:pnSatelliteL875D:pvrPSKFQU-003034:rvnAMD:rnPLCSC8:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite L875D
dmi.product.version: PSKFQU-003034
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.12.0+15.04.20141219-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.58-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.16.2.901-1ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.916+git20141119-1~exp1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Thu Jan 1 20:07:44 2015
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.16.2.901-1ubuntu3
xserver.video_driver: radeon

Related branches

Ian Nicholson (imnichol) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
robert shearer (bdaggg) wrote :

Affects both Firefox and Decibel audio player.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This has occurred on two of my systems so far, both running vivid.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJUq09+AAoJEBwDRDHt9Q7mprkP/2jw856ZWDgZIztN+iTTqOZX
O4Tyn9wAv7T9DbvfbMxH2sSpq5I/xoy9NQrRBuHGHrgsAtFAFAEk031IiXivOmcF
Mcnq7EAgsVpwnnwyex2U1LNQOxqTHBPSnB74mDoXgrBqGNQ4UzvPguc+Rf06lfeN
H9Z3u0NnYy5szhPvcE2/ViUUbMAs7ROFm98tb4h5Jkf3wliqLfq+wmO/amNGoDmi
WkqClNw0ElEEQjKjoXoHs7Nu2Oe8rc/JRxW0XvMM5nWJpnaTTNMUS2BFuFG8kLfh
8MiK9pdyowvXNjPNMBDYXRyb6w41OcVLs7YiMA7u9/1XENNHAOQKQZZ1UU9aE1Rx
kJ8g5hbF5RrJDgjt4knUnVzV+DJgs3lPTArSPIVzfxY3pT6ny1s0ttc7c4LSmW6t
cYubyI9Rl7YegUjYVOCXgThjIwDus2u6nq/pltdKuzhR+2Mrt0kJoCe52ms6X5L6
0fch5mGfMQAvzVsVf/mAL0WcaVTeGhOTcXyNGkKXtV3R5A909r8xDAnHDkHvI262
2ofsD6JqH3DOwGaCt6DArEhTnkVrelg3By65/V0e8CRKA0bw/nQWgeuhXkBlFPq1
IJ2+kZeY5v8A8I1zH4ufVBJQ4warhScnVXVHuQNkABDbrLDLkSvZpnHNa+ZerHZm
spJfZTJVfcxhXxkC53sJ
=wGJw
-----END PGP SIGNATURE-----

Sebastien Bacher (seb128) wrote :

That's happening since the gtk update, could be a bamf issue. Marco could you have a look to that one?

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
Changed in unity:
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Barry Drake (b-drake) wrote :

I get exactly this. The icons affected are: Thunderbird, Firefox, BibleTime, Calibre, and occasionally, other ones. The problem never occurs on the first launch of a particular program, but frequently on the second use of the same program during a session. After re-boot, all icons are restored. Running 15.04 - up-to-date daily.

Andrea Azzarone (azzar1) on 2015-01-13
Changed in unity:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
importance: Undecided → High
Andrea Azzarone (azzar1) on 2015-01-15
Changed in bamf:
importance: Undecided → High
Andrea Azzarone (azzar1) on 2015-01-16
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Changed in bamf (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in bamf:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in bamf:
status: Confirmed → In Progress
Changed in bamf (Ubuntu):
status: Confirmed → In Progress
Rocko (rockorequin) wrote :

I find the launchbar always displays the grey question mark icon for geeqie so long as it's not already locked to the launchbar.

Fabio Marconi (fabiomarconi) wrote :

Seems fixed after today's bamf upgrade

Rocko (rockorequin) wrote :

geeqie still displays the placeholder icon with bamfdaemon 0.5.1+14.10.20140925-0ubuntu2, though, so I suspect it isn't fixed.

Rocko (rockorequin) wrote :

And I just had my permanently-locked firefox icon in the launcher replaced with the placeholder, so it's definitely not fixed in that version of bamf.

Fabio Marconi (fabiomarconi) wrote :

Yes, misspoken earlier, sorry for the noise.
Actually is not fixed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.1+15.04.20150128-0ubuntu1

---------------
bamf (0.5.1+15.04.20150128-0ubuntu1) vivid; urgency=low

  [ Andrea Azzarone ]
  * Replace gtk_icon_theme_has_icon with gtk_icon_theme_lookup_icon.
    (LP: #1407192)

  [ Lars Uebernickel ]
  * Matcher: honor the _GTK_APPLICATION_ID xprop
 -- Ubuntu daily release <email address hidden> Wed, 28 Jan 2015 19:25:54 +0000

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
Andrea Azzarone (azzar1) on 2015-01-28
Changed in bamf:
status: In Progress → Fix Committed
Rocko (rockorequin) wrote :

Seems to be fixed for me now - at least, the geeqie icon is shown correctly now.

Adolfo Jayme (fitojb) on 2015-01-29
no longer affects: unity (Ubuntu)
Gordon (last-ship) wrote :

I've got the same issue. It was fixed very briefly for me in January 2015 after a software update, but has now returned and is affecting Firefox and Thunderbird. I'm running 14.04 in Unity.

Changed in bamf:
milestone: none → 0.5.1

Fix Released in bamf BAMF 0.5.1 "The Trusty BAMF".

Changed in bamf:
status: Fix Committed → Fix Released
To post a comment you must log in.