AP test failures caused by newer pygobject

Bug #1397006 reported by Stephen M. Webb on 2014-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Stephen M. Webb
unity (Ubuntu)
High
Stephen M. Webb

Bug Description

A handful of new AP test failures in the Unity suite started appearing recently after a pygobject upgrade because that library now raises an exception if both static glib and gi Glib are used in the same program.

The following tests fail and need to be modified to use gi instead of static glib.

unity.tests.test_gnome_key_grabber.GnomeKeyGrabberTests.test_grab_accelerator
unity.tests.test_gnome_key_grabber.GnomeKeyGrabberTests.test_grab_accelerators
unity.tests.test_gnome_key_grabber.GnomeKeyGrabberTests.test_grab_same_accelerator

Related branches

Stephen M. Webb (bregma) on 2014-11-27
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20141216-0ubuntu1

---------------
unity (7.3.1+15.04.20141216-0ubuntu1) vivid; urgency=low

  [ Stephen M. Webb ]
  * replace the use of static glib with gi glib in AP test cases (LP:
    #1397006)
  * fix AP test failures due to upstream FileRoller .desktop file rename
    (LP: #1402707)

  [ Andrea Azzarone ]
  * Set the correct size for the lockscreen message. (LP: #1384242)
  * Ungrab the shoutdown dialog as soon as possible. (LP: #1398287)
  * skipped the animation of BGHash on startup to prevent unwanted fade-
    in (LP: #1241757)
 -- Ubuntu daily release <email address hidden> Tue, 16 Dec 2014 13:25:57 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-12-16
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers