Windows in non-focused workspaces have not decorations in expo

Bug #1383468 reported by Marco Trevisan (Treviño) on 2014-10-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
New
Undecided
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned

Bug Description

[ Impact ]

1. Open multiple windows and put them in different workspaces
2. Hit Super+S to open the expo
3. Notice that windows that are not in the focused workspaces have no decorations

[ Test Case ]

See above: decorations should be present with fix.

[ Regression Potential ]

Decorations in the Spread could be drawn incorrectly.

[ Other Info ]

Fix for Ubuntu 14.01 LTS was cherry-picked from upstream Unity where it has been in production testing in Ubuntu "Vivid Vervet" dev release for a few months with no regression.

Related branches

Changed in unity (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20141128-0ubuntu1

---------------
unity (7.3.1+15.04.20141128-0ubuntu1) vivid; urgency=low

  [ Andrea Azzarone ]
  * Unmap all windows during shutdown. (LP: #1370017, #1375271)
  * Make sure GetScreenGeometry returns the correct value. (LP:
    #1374785)

  [ Marco Trevisan (Treviño) ]
  * Decorated Window: still paint decorations if on transformated
    windows in different workspaces (LP: #1383468)
  * DecoratedWindow: make sure we always set a _NET_FRAME_EXTENTS for
    windows that requested it
  * UnityScreen: when filtering out windows in spread, make sure we
    unscale them (LP: #1316265)
  * PanelMenuView: ensure that proper window tiles and buttons are shown
    at the right place (LP: #1384958, #1384910, #1385285)
  * PanelService: inject special key events back to the root window when
    a menu is opened
  * PanelService: use gdbus to notfy upstart of service start/stop
 -- Ubuntu daily release <email address hidden> Fri, 28 Nov 2014 12:56:28 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) wrote :

Attached debdiff between trusty-updates and SRU.

description: updated
Chris J Arges (arges) wrote :

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20141217-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Nekhelesh Ramananthan (nik90) wrote :

This bug does seem to be fixed with Unity 7.2.4 proposed update. However it introduces a visual regression that has been reported at https://bugs.launchpad.net/unity/+bug/1411041. I have thereby marked this as verification-failed as per https://wiki.ubuntu.com/QATeam/PerformingSRUVerification.

tags: added: verification-failed
removed: verification-needed-trusty

Mh, it looks like a different bug, as the one you reported is about the expo plugin, not unity itself... So the unity part I think is verified.

tags: added: verification-done
removed: verification-failed
Stephen M. Webb (bregma) wrote :

The problem reported in #141104 was present previous to this fix going in. I can verify seeing it in Ubuntu 14.04 without -proposed and in 14.10 (which does not have this fix yet).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20141217-0ubuntu1

---------------
unity (7.2.4+14.04.20141217-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Share lockscreen password between screens (lp: #1308540)
  * Allow a distinct pam config file for greeter and for lock-screen.
    (lp: #1305440)
  * Add an arrow activator in the lockscreen. (lp: #1332509)
  * Make sure GetScreenGeometry returns the correct value (lp: #1374785).
  * unmapped all windows prior to shutdown (lp: #1370017) (lp: #1375271)

  [ Brandon Schaefer ]
  * fix tooltip for the "Show Desktop / Restore Windows" icon in the Alt-Tab
    switcher (lp: #1237132)
  * Use CONFIG instead of CACHE to store the first_run.stamp (lp: #1328677)

  [ Eleni Maria Stea ]
  * LayoutSystem: make sure the exposed open windows are displayed in the
    preserved order (lp: #1349281).

  [ handsome_feng ]
  * added support for getting the distro name from /etc/os-release
    (lp: #1329584)

  [ Iain Lane ]
  * When grabbing keys, try prefixing "XF86" if the key isn't found. GNOME
    gives us unprefixed keys sometimes (lp: #1302885).

  [ Marco Trevisan (Treviño) ]
  * make the Launcher icon count badge width depend on the text value width
    and scaling (lp: #1353070) (lp: #1354498) (lp: #796527) (lp: #1066971)
    (lp: #1361713)
  * DecoratedWindow: make edges independent from borders and properly update
    them on actions change (lp: #1276177), (lp: #1299741), (lp: #1301776),
    (lp: #1324104), (lp: #1364225), (lp: #1373695)
  * Lockscreen: scale the UI elements based on current monitor scaling
    (lp: #1292218)
  * UnityScreen: when filtering out windows in spread, make sure we unscale
    them (lp: #1316265).
  * PanelMenuView: ensure that proper window tiles and buttons are shown at
    the right place (lp: #1384910) (lp: #1384958) (lp: #1385285)
  * SearchBar, ActionButtons, IconRenderer: include the font scaling when
    scaling textual items (lp: #1332947) (lp: #1361751) (lp: #1362162)
    (lp: #1362346).
  * ApplicationLauncherIcon: make sure we close the dash if DnD is accepted
    and the application window is about to be focused (lp: #1350331).
  * SwitcherView: set progress on icon render args (lp: #1361679).
  * LockScreenController: wait for the primary shield to get the grab
    before setting the session locked (lp: #1368427) (lp: #1371764).
  * added decorations to windows in non-focused workspaces (lp: #1383468)

  [ Stephen M. Webb ]
  * updated the unity(1) manpage to match the actual command (lp: #1059275)
  * bumped package version to match upstream

  [ Marco Trevisan (Treviño) ]
  * Preparing for unity 7.2.4
 -- Ubuntu daily release <email address hidden> Wed, 17 Dec 2014 20:52:10 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers