The desktop will not shrink back to one monitor when an external monitor is detached if system settings is not running

Bug #1369293 reported by Markus Ilmola on 2014-09-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When an external HDMI monitor is attached, the desktop is automatically extended to it.
But when the same monitor is detached, the desktop will not automatically shrink back to one monitor.
How ever if the system settings program is running while monitor is detached, the desktop does shrink back to one monitor correctly.
The desktop will also shrink back, if the systems settings is run at any time after detaching the monitor.

Using Ubuntu 14.04.1 LTS

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.2+14.04.20140714-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sun Sep 14 20:16:17 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:5024]
InstallationDate: Installed on 2014-05-07 (130 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: LENOVO 80B6QB0
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-35-generic.efi.signed root=UUID=ced59d53-14ee-475e-a6d9-544cd0928b7e ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/07/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: J7ET57WW (2.02 )
dmi.board.asset.tag: Not Available
dmi.board.name: 80B6QB0
dmi.board.vendor: LENOVO
dmi.board.version: 31900058 STD
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrJ7ET57WW(2.02):bd11/07/2013:svnLENOVO:pn80B6QB0:pvrB5400:rvnLENOVO:rn80B6QB0:rvr31900058STD:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 80B6QB0
dmi.product.version: B5400
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sat Sep 13 18:25:51 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 13394
 vendor SDC
xserver.version: 2:1.15.1-0ubuntu2.1

Markus Ilmola (markus-ilmola) wrote :
Markus Ilmola (markus-ilmola) wrote :

This bug is still present in 14.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Alex Willmer (alex-moreati) wrote :

I'm seeing this behaviour in Ubuntu 15.10/Unity 7.3.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers