Mouse cursor tiny when hovering unity elements in high DPI mode

Bug #1359211 reported by Michael Zanetti on 2014-08-20
134
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Compiz
High
Marco Trevisan (Treviño)
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.3
In Progress
Medium
Marco Trevisan (Treviño)
compiz (Ubuntu)
High
Marco Trevisan (Treviño)
Wily
Undecided
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Wily
Undecided
Unassigned
unity-settings-daemon (Ubuntu)
High
Sebastien Bacher
Wily
Undecided
Unassigned

Bug Description

[Impact]

On a high DPI screen (220 DPI) the mouse cursor is really tiny when hovering unity elements. There are various keys in dconf to change the cursor's scale factor or size. I've managed to change it in a way that it looks normal when inside application windows, but its still tiny when on unity elements.

I think this should be set automatically by the scale factor setting in system settings.

(Using unity 7.3.1+14.10.20140811-0ubuntu1)

[Test Case]

 * Log in
 * Launch Firefox
 * Move the mouse over the panel or the launcher,
   then back over the Firefox window.
 * Cursor should always be of the same size

[Regression Potential]

 * Mouse cursors might appear wrong for some actions

Related branches

description: updated
Filip Sohajek (filip-sohajek) wrote :

Hello,
can you please add screen of the issue?
Thanks

Michael Zanetti (mzanetti) wrote :
Michael Zanetti (mzanetti) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2014-12-06
Changed in unity:
status: New → Confirmed
Lukáš Tinkl (lukas-kde) wrote :

This needs to be actually set before the session starts, so adding

Xcursor*size: 48

to /etc/X11/Xresources/x11-common

fixes it for me (48 here is the base size, 24, doubled).

Alternatively, this could be solved by exporting:

export XCURSOR_SIZE=48

somewhere in unity startup code.

tags: added: highdpi
Berte (berte) wrote :

#5 worked for me on hidpi (3200x1800), ubuntu 15.04

Alexander Burkov (a-p-burkov) wrote :

#5 worked for me too (2560x1600), ubuntu 15.04. Thanks, Lukas!

Christian Dreher (cdreher3011) wrote :

I had the same problem on Ubuntu 15.04, but #5 fixed the problem with adding Xcursor*size:48 to the x11-common file. Thank you! Anyway, it would be great if this would be fixed for the next release.

Kai Mast (kai-mast) wrote :

Just saw this in 15.10 :/

tags: added: wily
Changed in unity (Ubuntu):
importance: Undecided → Medium
importance: Medium → High

It seems that reloading unity fixes the thing.

We need to figure a way to get compiz to use this setting when ran.

tags: added: hidpi
removed: highdpi
tags: added: rls-w-incoming
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
milestone: none → 7.3.3
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

https://code.launchpad.net/~seb128/unity-settings-daemon/xsettings-fixes-backport/+merge/273710 helps with the settings change to be reflected, also for qt apps/firefox/libreoffice by writing a Xresource)

Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in unity-settings-daemon (Ubuntu):
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → High
assignee: nobody → Sebastien Bacher (seb128)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in compiz:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in compiz (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → High
Changed in unity:
milestone: 7.3.3 → 7.4.0
Changed in compiz:
milestone: none → 0.9.12.3
tags: added: rls-x-incoming
removed: rls-w-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.2+16.04.20151026-0ubuntu1

---------------
compiz (1:0.9.12.2+16.04.20151026-0ubuntu1) xenial; urgency=medium

  * Move: remember the type of movement and use the proper grabbing for
    it (LP: #1487637)
  * Resize: remember the type of movement and use the proper grabbing
    for it (LP: #1487637)
  * Screen: add cursorChangeNotify function and call it on
    XA_RESOURCE_MANAGER
  * Screen: add pushKeyboardGrab and pushPointerGrab methods to add
    different kinds of grabs
  * Screen: monitor root RESOURCE_MANAGER and update cursors when Size
    or Theme changes (LP: #1359211)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 26 Oct 2015 17:15:54 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20151102-0ubuntu1

---------------
unity (7.4.0+16.04.20151102-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Bumping version to 7.4.0
  * Fix building in xenial

  [ Didier Roche ]
  * Remove unity2d transitional packages. We are post trusty LTS, they
    are not needed anymore

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: if an app is not running and has no desktop
    file, add QL item to add to dash
  * PanelService: unset the idle ID before removal on callback (LP:
    #1501289)
  * Unity: use compiz cursorCache to get properly updated cursors (LP:
    #1359211)
  * UnityScreen: add SpreadAppWindows option and trigger it on
    Super+Ctrl+[Shift]+W

  [ Stephen M. Webb ]
  * changed the wording of the help message and warning message for the
    --reset option (LP: #1486498)

unity (7.3.3-0ubuntu1) UNRELEASED; urgency=medium

  * Releasing Unity 7.3.3

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 02 Nov 2015 13:29:58 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in compiz:
status: In Progress → Fix Committed
Changed in unity-settings-daemon (Ubuntu):
status: In Progress → Fix Released
ercoppa (ercoppa) wrote :

Workaround presented in #5 does not work in Ubuntu 15.10. I hope the fix lands soon in repository: it is very hard to use Unity due to this bug.

Ari Nordström (ari-nordstrom) wrote :

@ercoppa Once you've logged in, hit Alt+F2 and restart Unity by entering 'unity'. It fixes the pointer size until your next reboot.

ercoppa (ercoppa) wrote :

@ari-nordstrom You are right, this works. Thank you very much :)

Alessio Treglia (quadrispro) wrote :

Any chance to see these fixes being backported to wily? This bug is definitely annoying.

Backport to wily is being prepared here:
 - https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-027

That will go through the SRU process, so it will take a while to reach everybody. If you want to test it in the meanwhile, you can just use that PPA (to be removed once installed, as it might then be reused by other projects).

description: updated
description: updated
tags: added: unity-backlog
Sasa Stamenkovic (umpirsky) wrote :

Just installed Ubuntu 15.10 on Asus Zenbook, and I am facing exactly same issue.

Adding Xcursor*size: 48 to /etc/X11/Xresources/x11-common didn't work for me, restarting unity helps, but after reboot it happens again.

Is there any other workaround?

I see adding export XCURSOR_SIZE=48 somewhere in unity startup code is alternative approach, can someone please hint me where can I add this?

Sasa, in 15.10 you can use the provided ppa to install unity (to be purged afterwards) or wait for the SRU.

Otherwise, you can just export that in /usr/share/upstart/sessions/unity7.conf.

Doing exactly the same that COMPIZ_CONFIG_PROFILE is doing.

Hello Michael, or anyone else affected,

Accepted compiz into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/compiz/1:0.9.12.2+15.10.20151202-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Wily):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Michael, or anyone else affected,

Accepted unity into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.3.3+15.10.20151203-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Wily):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu Wily):
status: New → Confirmed
liamdawe (liamdawe) wrote :

The proposed package fixes it.

Hope I have this right: 7.3.3+15.10.20151203-0ubuntu1 is the current version in proposed and it's now actually working as expected, no tiny mouse cursor hooray!!!!!

tags: added: verification-done
removed: verification-needed
liamdawe (liamdawe) wrote :

Actually, this isn't exactly fixed.

While it's true the cursor no longer turns tiny, it's stuck onto one single cursor. When browing the web, you no longer get different cursors while hovering over things like links and such. Basically, you now only have one single cursor.

Changing tag back.

tags: added: verification-needed
removed: verification-done
liamdawe (liamdawe) wrote :

Yeah, it's really not great. As it also forces the big system cursor of the top of cursors in full screen games, I'm going to revert now as it's too buggy.

liamdawe, can you please double check this?

It's weird since those cursors are defined by apps, so there should be no overriding by unity.
Can you give me an example where this fails?

As nobody trying this version in PPA complained about this, nor people using xenial where this fix is for some time now.

liamdawe (liamdawe) wrote :

For some reason I wasn't emailed your reply Marco.

I've re-checked, and something must have gone awry with the last attempt as I can confirm it working fine now, thanks.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.2+15.10.20151202-0ubuntu1

---------------
compiz (1:0.9.12.2+15.10.20151202-0ubuntu1) wily; urgency=medium

  * Screen: monitor root RESOURCE_MANAGER and update cursors when Size
    or Theme changes (LP: #1359211)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 02 Dec 2015 16:47:55 +0000

Changed in compiz (Ubuntu Wily):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.3+15.10.20151203-0ubuntu1

---------------
unity (7.3.3+15.10.20151203-0ubuntu1) wily; urgency=medium

  * Releasing Unity 7.3.3
  * Unity: use compiz cursorCache to get properly updated cursors (LP:
    #1359211)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 03 Dec 2015 10:39:52 +0000

Changed in unity (Ubuntu Wily):
status: Fix Committed → Fix Released
Sasa Stamenkovic (umpirsky) wrote :

@Treviño I only now saw your message.

I still have this issue, and I am restartgin unity on each boot. But that have other bad consequences, like Alt+F4 stops working.

Can you point me at right ppa? What should I run in terminal in order to get this fix?

Thanks.

@Sasa,

No ppa is needed anymore: the fix is already in Xenial and Wily.

Sasa Stamenkovic (umpirsky) wrote :

@Treviño I am running Ubuntu 15.10 and I still have this issue.

Sasa Stamenkovic (umpirsky) wrote :

@Treviño Seems like it is fixed with todays update. Thanks.

Luke Horwell (lah7) wrote :

This update has introduced a regression for the Ubuntu MATE flavour on Compiz desktops whereby the cursor is now invisible, a black X or only appearing in some programs.

LP: #1544814

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers