Nautilus opens twice from launcher when first window browses mounted drive

Bug #1350487 reported by sabby7890 on 2014-07-30
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Medium
Marco Trevisan (Treviño)

Bug Description

Sometimes when Nautilus window is opened, clicking on the icon instead of focusing the window opens a new window.

How to reproduce:

- Open Nautilus window. Mount a second hard drive (in my case) and browse it.
- Unfocus it, focus Firefox
- Click on the Nautilus icon - window should be focused, a new window is opened instead

It doesn't work when you mount a FTP share or SSH share, only when mounting second hard drive (labeled Strefa 51, Area 51). Also, in order to reproduce this bug the first opened window must be browsing second hard drive, everything works correctly when you go to another drive on nth window.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nautilus 1:3.10.1-0ubuntu9.3
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
CurrentDesktop: Unity
Date: Wed Jul 30 20:00:00 2014
GsettingsChanges:

InstallationDate: Installed on 2014-07-18 (12 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

sabby7890 (tsalacinski) wrote :
affects: nautilus (Ubuntu) → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity:
status: Confirmed → Triaged
Changed in bamf:
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in bamf:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.3.1
Changed in bamf:
milestone: none → 0.6.0
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
no longer affects: bamf
tags: added: rls-w-incoming
Changed in unity:
milestone: 7.3.3 → 7.4.0
tags: added: rls-x-incoming
removed: rls-w-incoming
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → ubuntu-16.04
tags: added: unity-backlog
Will Cooke (willcooke) on 2016-02-15
tags: removed: rls-x-incoming
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers