Horizontal Scrolling over Indicator-ng (and sound) does not work as expected

Bug #1342731 reported by Marco Trevisan (Treviño) on 2014-07-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Marco Trevisan (Treviño)
Trusty
Fix Released
Medium
Marco Trevisan (Treviño)
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Released
Medium
Marco Trevisan (Treviño)
libindicator (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
nux (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned

Bug Description

[Impact]
When scrolling on indicator-sound using the horizontal scrolling the result is the opposite to what we expect in unity (left scrolling increases the volume and right scrolling decreases it), while in general is not handled at all for indicator-ng indicators as both left and right scrolling always ends up in a "+1" delta scroll.

[Test case]
1. Hover Indicator-sound in unity
2. Scroll left: the volume should be reduced
3. Scroll right: the volume should be increased

[Regression potential]
The horizontal scroll direction might be inverted with some touchpads

Related branches

Changed in unity:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.3.2
Changed in unity:
milestone: 7.3.2 → 7.3.1
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in nux:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 4.0.7
description: updated

unity_7.2.3+14.04.20140826-0ubuntu1.debdiff

Stephen M. Webb (bregma) on 2014-09-23
Changed in nux (Ubuntu):
status: New → In Progress
Changed in libindicator (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium

The attachment "unity_7.2.3+14.04.20140826-0ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch

Hello Marco, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.3+14.04.20140826-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

In order to verify this fix in trusty, you also need an updated version of nux and libindicator that are about to land.

So please, don't set this as verification-failure, until all the pieces are on proposed.

Sebastien Bacher (seb128) wrote :

(unsubscribing sponsors, I don't think there is anything else ready for upload on that bu)

Chris J Arges (arges) wrote :

Hello Marco, or anyone else affected,

Accepted libindicator into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libindicator/12.10.2+14.04.20141007.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libindicator (Ubuntu Trusty):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu Trusty):
status: New → Confirmed
Mathew Hodson (mathew-hodson) wrote :

Fixed with unity 7.2.3+14.04.20140826-0ubuntu1, libindicator3-7 12.10.2+14.04.20141007.1-0ubuntu1, and libnux-4.0-0 https://launchpad.net/ubuntu/+source/nux/4.0.6+14.04.20140930-0ubuntu1

Changed in nux (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package unity - 7.2.3+14.04.20140826-0ubuntu1

---------------
unity (7.2.3+14.04.20140826-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Remove cross fade effect during lock/unlocking. A simple fading
    works just fine. (LP: #1312107)
  * Manually emit nux::Area::geometry_changed beucase nux can fail to
    emit it. (LP: #1292391)

  [ Pawel Szubert ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Marco Trevisan (Treviño) ]
  * LockScreenAcceleratorController: do ther configured action on power
    special keys press. We finally can suspend, shutdown, hibernate or
    start the screensaver when the screen is locked, using the Suspend,
    Sleep, Hibernate and PowerOff hardware keys. Also the Shutdown
    dialog doesn't allow now to lock the session if it is not allowed by
    settings. (LP: #1306211) (LP: #1320051) (LP: #1320071)
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of search-bar, spinner, categories
    and many other components. (LP: #1339629)
  * FilterWidgets: add support for scaling (LP: #1340171)
  * OverlayRendering: correctly scale the overlays borders and edges to
    match settings. DashStyle has been modified to return smart pointers
    of textures that are loaded depending on the scale level. The cache
    will make sure that we don't duplicate the textures and that they
    get removed when not needed anymore. Also thanks to this the
    SearchBarSpinner textures (and the other spinners as well) uses the
    SVGs scaled at the proper size (I desgined a new SVG for the
    magnifier, as we only had a PNG). (LP: #1283415) (LP: #1340394)
  * Hud: scale to match current DPI settings for monitor. (LP: #1340477)

  [ Eleni Maria Stea ]
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of search-bar, spinner, categories
    and many other components. (LP: #1339629)

  [ Stephen M. Webb ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Chris Townsend ]
  * Bump version to 7.2.3.

unity (7.2.2+14.04.20140714-0ubuntu2) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Remove cross fade effect during lock/unlocking. A simple fading
    works just fine. (LP: #1312107)
  * Manually emit nux::Area::geometry_changed beucase nux can fail to
    emit it. (LP: #1292391)
  * TextInput: use GdkKeymap to check the caps-lock status (LP: #1347735)

  [ Pawel Szubert ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Marco Trevisan (Treviño) ]
  * LockScreenAcceleratorController: do ther configured action on power
    special keys press. We finally can suspend, shutdown, hibernate or
    start the screensaver when the screen is locked, using the Suspend,
    Sleep, Hibernate and PowerOff hardware keys. Also the Shutdown
    dialog doesn't allow now to lock the session if it is not allowed by
    settings. (LP: #1306211) (LP: #1320051) (LP: #1320071)
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of...

Read more...

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libindicator - 12.10.2+14.04.20141007.1-0ubuntu1

---------------
libindicator (12.10.2+14.04.20141007.1-0ubuntu1) trusty; urgency=low

  [ Marco Trevisan (Treviño) ]
  * IndicatorNG: Reverse the scroll delta on left scroll events (LP: #1342731)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 15:24:09 +0000

Changed in libindicator (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
no longer affects: libindicator
Changed in nux (Ubuntu):
status: In Progress → Fix Released
Changed in libindicator (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-08-12
Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers