Scroll wheel uses inverted logic to switch between applications/windows in the switcher

Bug #1342208 reported by Marco Trevisan (Treviño) on 2014-07-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Marco Trevisan (Treviño)
Trusty
Fix Committed
Medium
Marco Trevisan (Treviño)
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Released
Medium
Marco Trevisan (Treviño)
nux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Medium
Unassigned

Bug Description

[Impact]
Scrolling on the Alt+Tab has invalid behavior:
- Scrolling down, moves to the previous icon/window
- Scrolling up, moves to the next icon/window
- Scrolling left, moves to the next icon/window
- Scrolling right, moves to the previous icon/window

[Test case]
1. Press Alt+Tab
2. While pressing the keys, use mouse scroll wheel to scroll vertically (and, if possible, horizontally)

Expected behavior:
- Scrolling down, moves to the next icon/window
- Scrolling up, moves to the previous icon/window
- Scrolling left, moves to the previous icon/window
- Scrolling right, moves to the next icon/window

[Regression potential]
Vertical scrolling code has not been touched by the change, so there's no possibility to regress in this sense.

Related branches

Changed in unity:
milestone: 7.3.2 → 7.3.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.0+14.10.20140731.1-0ubuntu1

---------------
unity (7.3.0+14.10.20140731.1-0ubuntu1) utopic; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Brandon Schaefer ]
  * Fixes FTBFS caused by gcc 4.9. Mostly unused functions. (LP:
    #1350052)

  [ Andrea Azzarone ]
  * == Problem == Lockscreen capslock detection doesn't work well with
    remapped capslocks == Fix == Use gdk keymap to get the state of the
    caps lock. (LP: #1347735)

  [ Marco Trevisan (Treviño) ]
  * PlacesOverlayVScrollBar and VScrollBarOverlayWindow: add support for
    scaling Add a new ScrollView class to create ScrollViews with an
    OverlayScrollbar and with scaling support. Using them in dash Scopes
    and Previews. (LP: #1340996)
  * LockScreenShield: Add GrabScreen function and retry to make sure we
    really get grab It might happen that the grab is not possible
    because the PluginAdapter::IsScreenGrabbed request has still not
    being fully processed, and thus nux is not able to grab the
    pointer/keyboard. By doing this we instead try to grab the screen,
    and if this is not happening, we wait a little until we don't get
    the ungrab event. In this way, if we eventually get the grab, all
    will work as expected. Otherwise, we cancel the lock request (very
    unlikely to happen). (LP: #1349128)
  * PlacesOverlayVScrollBar: redirect the mouse wheel scroll events
    coming from the thumb to the scrollview This will make the
    scrollview to handle then and perform the same scrolling action it
    would do otherwise. (LP: #1340992)
  * This has a "soft" dependency on lp:~3v1n0/nux/horizontal-scroll-
    delta/+merge/227070, this means that this code would just work as it
    used to do (except for the SwitcerView fix) if that nux branch is
    not used, while it will support correctly horizontal scroll events
    when both the branches are used. (LP: #1342208)
 -- Ubuntu daily release <email address hidden> Thu, 31 Jul 2014 18:40:00 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in nux:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 4.0.7
description: updated
Stephen M. Webb (bregma) on 2014-09-18
Changed in nux (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Fix Released

unity_7.2.3+14.04.20140826-0ubuntu1.debdiff

Hello Marco, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.3+14.04.20140826-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

In order to verify this fix in trusty, you also need an update version of nux that is about to land.

So please, don't set this as verification-failure, until all the pieces are on proposed.

All the fixes needed to verify this bug are now in proposed, so please give a try to them and report the results!

I only checked vertical scroll because I don't have a mouse with horizontal scroll wheel.

tags: added: verification-done
removed: verification-needed
Changed in nux (Ubuntu Trusty):
status: New → Fix Committed
Mathew Hodson (mathew-hodson) wrote :

I am confused about the expected behaviour.

The current description says that vertical scrolling has not been touched, but the listed expected behaviour is different from the behaviour under Impact.

What I expect, and what feels naturally correct to me is:
- Scrolling down, moves to the previous
- Scrolling up, moves to the next
- Scrolling left, moves to the previous
- Scrolling right, moves to the next

tags: added: verification-needed
removed: verification-done

You can also verify horizontal scrolling by using a touchpad, scrolling Up should move to the previous, while Down to the next.

That's the same behavior that also Gtk has.

Christopher Townsend (townsend) wrote :

Hmm, Mathew is right, the SRU regression potential says vertical has not been touched, but it certainly has. I will follow up with Marco on what the intended behavior is supposed to be...

description: updated

So, although I don't completely agree with the new vertical scrolling behavior in the Switcher, I don't think we should block the SRU on this since this is how Utopic now behaves. I think I will enter a new bug report about the behavior not being quite what is expected and then flesh that out. If we decide to switch the behavior back, then we will get it into another SRU. That said, marking this verification-done.

tags: added: verification-done
removed: verification-needed

Oh, I did verify the horizontal scrolling now works as expected, which is the bigger issue here.

Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package unity - 7.2.3+14.04.20140826-0ubuntu1

---------------
unity (7.2.3+14.04.20140826-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Remove cross fade effect during lock/unlocking. A simple fading
    works just fine. (LP: #1312107)
  * Manually emit nux::Area::geometry_changed beucase nux can fail to
    emit it. (LP: #1292391)

  [ Pawel Szubert ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Marco Trevisan (Treviño) ]
  * LockScreenAcceleratorController: do ther configured action on power
    special keys press. We finally can suspend, shutdown, hibernate or
    start the screensaver when the screen is locked, using the Suspend,
    Sleep, Hibernate and PowerOff hardware keys. Also the Shutdown
    dialog doesn't allow now to lock the session if it is not allowed by
    settings. (LP: #1306211) (LP: #1320051) (LP: #1320071)
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of search-bar, spinner, categories
    and many other components. (LP: #1339629)
  * FilterWidgets: add support for scaling (LP: #1340171)
  * OverlayRendering: correctly scale the overlays borders and edges to
    match settings. DashStyle has been modified to return smart pointers
    of textures that are loaded depending on the scale level. The cache
    will make sure that we don't duplicate the textures and that they
    get removed when not needed anymore. Also thanks to this the
    SearchBarSpinner textures (and the other spinners as well) uses the
    SVGs scaled at the proper size (I desgined a new SVG for the
    magnifier, as we only had a PNG). (LP: #1283415) (LP: #1340394)
  * Hud: scale to match current DPI settings for monitor. (LP: #1340477)

  [ Eleni Maria Stea ]
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of search-bar, spinner, categories
    and many other components. (LP: #1339629)

  [ Stephen M. Webb ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Chris Townsend ]
  * Bump version to 7.2.3.

unity (7.2.2+14.04.20140714-0ubuntu2) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Remove cross fade effect during lock/unlocking. A simple fading
    works just fine. (LP: #1312107)
  * Manually emit nux::Area::geometry_changed beucase nux can fail to
    emit it. (LP: #1292391)
  * TextInput: use GdkKeymap to check the caps-lock status (LP: #1347735)

  [ Pawel Szubert ]
  * Reduce the scope of the kill command when restarting Compiz.
    (LP: #1324114)

  [ Marco Trevisan (Treviño) ]
  * LockScreenAcceleratorController: do ther configured action on power
    special keys press. We finally can suspend, shutdown, hibernate or
    start the screensaver when the screen is locked, using the Suspend,
    Sleep, Hibernate and PowerOff hardware keys. Also the Shutdown
    dialog doesn't allow now to lock the session if it is not allowed by
    settings. (LP: #1306211) (LP: #1320051) (LP: #1320071)
  * Previews: scale the dash preview contents to match current monitor
    scaling. Improved also the scaling of...

Read more...

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in nux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2015-08-12
Changed in nux:
status: Fix Committed → Fix Released
Mathew Hodson (mathew-hodson) wrote :

Christopher Townsend, did you file a bug about the change is vertical scroll behaviour introduced by this bug?

Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in nux (Ubuntu Trusty):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium

I don't thinkit's abug. Scrolling down should move to the next element, while scrolling up to the previous. As it is now.

Mathew Hodson (mathew-hodson) wrote :

It seems wrong to me, because when you scroll down over the sound indicator, which was also got an update at the same time in bug #1342731, the cursor moves left. So it should move left when scrolling down over the switcher.

Also there's a chance that this behaviour change was a mistake, since it was back-ported in an SRU, and the Regression Potential explicitly said, "Vertical scrolling code has not been touched by the change, so there's no possibility to regress in this sense."

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers