Shortcut hint does not respect monitor scaling factor

Bug #1317356 reported by Marco Trevisan (Treviño) on 2014-05-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Nominated for Trusty by Christopher Townsend

Bug Description

[Impact]
The shortcut hint is not properly scaled in HiDPI monitors

[Test case]
1. From Unity Control Center -> Displays -> Change the monitor scaling to somewhat
   different from 1.0 (might be both bigger and smaller, your choice; but scaling down is
   recommended if your monitor has a small resolution or next point will fail).
2. Hold Super and keep it pressed unless the shortcut hint won't show up
   (note: this might not happen if the monitor resolution is not big enough to contain
   all the shortcuts; see point above)
3. The shortcuts view and all its text should be scaled to match the defined monitor
   scaling factor.
   In Multi-monitor scenario it should match the scaling factor of the monitor where the
   view opens (so where the mouse is).

[Regression potential]
The potential of regression is basically none, since we just moved from fixed sizes to relative sizes and unless the scale value is set to an invalid value, this should work as it happens in other unity views that do support scaling currently.

Related branches

Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → Medium
description: updated
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers