Chromium aura doesn't honor the --class parameter anymore

Bug #1311795 reported by Uriel (CP) on 2014-04-23
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Chromium Browser
Unknown
Unknown
Unity
Won't Fix
Undecided
Unassigned
chromium-browser (Ubuntu)
Undecided
Unassigned

Bug Description

At Ubuntu 13.10, I could have different instances of chromium (with different profiles) have separate icons in unity. All I had to do was change the StartupWMClass= and the --class= in the exec= line in the desktop launcher. Starting with 14.04, Unity ignores these values and groups the chromium windows together. Similarly, webapp instances (created using file-> create application shortcuts) are also grouped under the one chromium icon. This beats the purpose of webapps, as it makes it much more difficult to regard a webpage as an application.

To replicate:
1. copy the chromium-browser.desktop to two different locations: 1.desktop and 2.desktop.
2. Edit 1.desktop to the following values:
Exec=chromium-browser --temp-profile --class=Other %U
StartupWMClass=Other
3. Edit 2.desktop to the following values:
Exec=chromium-browser --temp-profile --class=Other2 %U
StartupWMClass=Other2
4. Start both from nautilus or from the desktop.

In 13.10, this results in separate icons on the launcher, in 14.04, only one.

It seems that I'm not the only one to encounter this problem: http://askubuntu.com/questions/450113/multiple-chromium-icons-in-launcher-of-14-04-lts

And this is further evidence that the icons were separable in previous versions: http://ricardofeliciano.me/how-to-create-a-unity-launcher-icon-for-each-chromechromium-profile-in-ubuntu/

Thanks,
UCP

Uriel (CP) (urielc) wrote :
Changed in unity:
status: New → Invalid
status: Invalid → Won't Fix
Changed in bamf:
status: New → Won't Fix
Changed in chromium-browser (Ubuntu):
status: New → Confirmed
summary: - Unity groups windows that differ in their StartupWMClass value
+ Chromium aura doesn't honor the --class parameter anymore

This is not an Unity/BAMF bug.

New chromium doesn't seem to support anymore the --class parameter, as you can see checking the windows with "xprop WM_CLASS".

Please fill a bug upstream, since we can't do anything at Ubuntu level to recognize these instances as different.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.