Indicators disappear at the panel (clementine, dropbox, skype etc)

Bug #1310200 reported by Yanpas on 2014-04-20
222
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
7.2
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Trusty
Undecided
Unassigned

Bug Description

[Impact]
Some indicators icons (such as skype, clementine, dropbox) disappear from panel when changing graphical state.

[Test case]
1. Run one of the affected software (i.e. skype)
2. The skype icon should show in the unity panel
3. Change your status in skype to something else (i.e. Away)
4. The skype icon in the panel should change without disappearing

[Regression potential]
Nothing known, the icons database is reloaded for safety checks and this does nothing but updating the icons.

----

Unconstant indicators (which are changig their graphical state during work of the app, for example skype, clemetine) disappears on the panel. They appear again if you click the mouse on th closest rightest indicator and pull it into left side or they appear after some time.

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140416-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-20.34-generic 3.11.10.6
Uname: Linux 3.11.0-20-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Sun Apr 20 12:26:14 2014
InstallationDate: Installed on 2014-01-14 (95 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2014-04-18 (1 days ago)

Related branches

Yanpas (yanpaso) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank for your bug report, it looks like indicator-application is having issues, could you add your ~/.cache/upstart/indicator-application.log to the bug after seeing the wrong behaviour?

Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Yanpas (yanpaso) wrote :

There were three log gz archives, there are unpacked logs in ZIP

Viorel Lazar (viorelmarius) wrote :

Also, the log from unity-panel-service because it seems more relevant

Yanpas (yanpaso) wrote :

Violer Lazar, i can't find ~/.cache/upstart/indicator-application.log file. Ontly little archives. Maybe you have such file? If yes - upload it, please.

Viorel Lazar (viorelmarius) wrote :

Mine is also archived, but will upload it here.

BTW, my system is 32bit

Sebastien Bacher (seb128) wrote :

hum, those logs don't have a lot of information. Is the issue happening only when using clementine? What's the output of the "status indicator-application" command when you get the issue? is the service restarting?

Viorel Lazar (viorelmarius) wrote :

The problem appear when icon is refreshed, Clementine shows song progress in it's indicator, so every time the progress change, the icon is changed thus dissappear , then reappear again.
For skype is the same problem: every time icon is changed, it disappear and reappear again after few secconds.

Output of command :
# status indicator-application
indicator-application stop/waiting

Sebastien Bacher (seb128) wrote :

the status is wrong, it should be running...

Yanpas (yanpaso) wrote :

$ status indicator-application
indicator-application start/running, process 1916

Yanpas (yanpaso) wrote :

What do we need to upload to change status to "in progress" or "conformed"? Maybe you may just install clementine on your machine and load a playlist of 30 seconds tracks? The bug is very annoying :) i cant read and listen to music because icon is reappearing... :(

Jarosław Guza (jarekj83-4) wrote :

i agree, its annoyin as hell, it would be so great release if it just wasnt for that bug.

Yanpas (yanpaso) on 2014-04-27
affects: unity (Ubuntu) → unity
Yanpas (yanpaso) on 2014-04-27
summary: - Indicators disappears at the panel
+ Indicators disappear at the panel (clementine, dropbox, skype etc)
Yanpas (yanpaso) on 2014-04-27
Changed in unity:
status: Incomplete → Confirmed
Jarosław Guza (jarekj83-4) wrote :

So, any news on this??? how can a bug like this be in a OS!?

Yanpas (yanpaso) wrote :

Jaroslaw, I suppose most of Canonical powers are on ubuntu touch and unity8. So this uncritical bug will be fixed will be released in half a year or year. Thats only my suggestions. By now I just unchecked option "show clementine in indicators panel". Life became much calmer :)

Jarosław Guza (jarekj83-4) wrote :

Yanpas, yep but its not the only one icon that is doin like that, i have Clementine doin this and Kadu (communicator that i use cause its best for me) so i can turn off icon in Clementine but other app is still havin same problem ;) hope its gonna be fixed asap anyway :)

Ivo Anjo (knuckles) wrote :

So is there some extra debug info we can supply?
14.04 is supposed to be an LTS support version, it's kinda sad if it's being unsupported already :(

Yanpas (yanpaso) wrote :

The problem is reproducable on developers PCs too, so that's not our duty IMHO.

Andrea Azzarone (azzar1) on 2014-05-29
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2014-05-30
Changed in unity:
milestone: none → 7.2.1
milestone: 7.2.1 → 7.3.0
Adolfo Jayme (fitojb) on 2014-05-31
Changed in unity (Ubuntu):
importance: Undecided → High
Eduardo (ludentico) wrote :

I haven't been able to grasp a pattern as to when the Clementine indicator disappears, for it can be any time in the middle of a song, with no obvious relationship with a specific process.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140607-0ubuntu1

---------------
unity (7.2.0+14.10.20140607-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)

  [ Marco Trevisan (Treviño) ]
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general. (LP:
    #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)
 -- Ubuntu daily release <email address hidden> Sat, 07 Jun 2014 16:27:46 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Viorel Lazar (viorelmarius) wrote :

So, the fix is released, but only for utopic unicorn , what about the LTS trusty tahr ?

All,

We have to get that fix in via the SRU process (https://wiki.ubuntu.com/StableReleaseUpdates). This process can take a bit of time and has to be very methodical on getting fixes in. We have targeted this bug for the next 14.04 Unity SRU, so please be patient and keep an eye on this bug for any updates.

Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
Chris Kenyon (chriskenyon) wrote :

The issue impacts normal usage of Skype. I used the following instructions to fix the issue on my 14.04 64 bit install:

3.3 Fix missing Skype tray icon / appindicator on Ubuntu 64bit

On 64bit, the required package to get a Skype tray / appindicator icon is not installed automatically. To fix this, use the following command: sudo apt-get install sni-qt:i386

The Skype tray icon might disappear after you log in, but it should show up after a few seconds.

description: updated

Hello Yanpas, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

I've only checked with Clementine so it probably should be also looked at by people using Skype and Dropbox.

tags: added: verification-done
removed: verification-needed
Yanpas (yanpaso) wrote :

I have just been testing Dropbox, Skype and clementine. Everything works fine. And this fix seems to fix the bug with displaying unplugged flash drive on Launcher :)

Viorel Lazar (viorelmarius) wrote :

Yes, all's well, the bug is fixed in proposed updates. It took three months, but it's better late then never :)

@Viorel,

yeah, sorry about that but the procedure to get fixes in a stable release are a little longer, but this is to ensure quality and avoid regressions.

Viorel Lazar (viorelmarius) wrote :

^You all have my respect

Rabotyahoff (rabotyahoff) wrote :

Skype and clementine are work fine.
Thank you.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers