Launcher damage the left-monitor area also if it's hidden

Bug #1301394 reported by Marco Trevisan (Treviño) on 2014-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Andrea Azzarone
7.2
Triaged
Low
Unassigned
unity (Ubuntu)
Low
Andrea Azzarone
Nominated for Trusty by Christopher Townsend
Trusty
Low
Unassigned

Bug Description

[ Impact ]

When using a hidden Launcher, the area where a non hidden Launcher would be is still damaged, wasting CPU/GPU cycles.

[ Test Case ]

1. Set Launcher in auto-hide mode.
2.

[ Regression Potential ]

None observed.

-----------------------------------------------------------------------------

Original Description:

When in auto-hide mode the launcher damages the area that it would fill when shown, also when hidden.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.04.20140403-0ubuntu1

---------------
unity (7.2.0+14.04.20140403-0ubuntu1) trusty; urgency=low

  [ Stephen M. Webb ]
  * remove libsyncindicator from services/panel-service.c

  [ Dimitri John Ledkov ]
  * Drop U1 default shortcuts & indicator-sync recommendation. (LP:
    #1300916) (LP: #1300916)

  [ Marco Trevisan (Treviño) ]
  * Launcher: hide the launcher window when in auto-hide mode if it's
    not presented (LP: #1301394)
  * ApplicationLauncherIcon: recompute pips when the screen geometry
    changes (LP: #1024101)
  * UnityScreen: reset decoration::DataPool on destruction, otherwise we
    won't have a valid screen ptr (LP: #1291243)
  * DecorationsGrabEdge: Only perform tookit actions on right-click (LP:
    #1301459)
 -- Ubuntu daily release <email address hidden> Thu, 03 Apr 2014 11:10:36 +0000

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
milestone: 7.2.2 → 7.3.1
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Andrea Azzarone (azzar1) on 2015-03-23
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150330-0ubuntu1

---------------
unity (7.3.2+15.04.20150330-0ubuntu1) vivid; urgency=medium

  [ Andrea Azzarone ]
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Hide launcher to avoid damaging window when not needed. Also make
    sure that pressure effect works fine (previous fix has been reverted
    because of this!). (LP: #1301394)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Make sure that signals are auto-desconnected when
    XdndStartStopNotifierImp is destroyed. (LP: #1432231)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Sebastien Bacher ]
  * use the new nautilus .desktop name (LP: #1436297)

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)
 -- CI Train Bot <email address hidden> Mon, 30 Mar 2015 15:48:47 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-30
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Andrea Azzarone (azzar1)
description: updated
summary: - Launcher damange the left-monitor area also if it's hidden
+ Launcher damage the left-monitor area also if it's hidden
Christopher Townsend (townsend) wrote :

We are not going to SRU this fix at this time due to a regression in urgent icon notification when the Launcher is hidden.

Changed in unity (Ubuntu Trusty):
status: In Progress → Triaged
Changed in unity:
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2017-10-13
Changed in unity (Ubuntu Trusty):
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers