Lockscreen: keyboard layout switching shortcuts not working

Bug #1291461 reported by Ruslan Boitsov on 2014-03-12
60
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
William Hua
7.2
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]
New Unity Lockscreen has the same problem as the old one from Gnome: the chosen keyboard shortcut is not switching keyboard layouts on it, the only way is to use mouse.

[Test Case]
1. To make things uncomfortable, switch layout to Russian or any other with your favourite shortcut(i am using alt-shift)
2. Lock the screen with ctrl-alt-l
3. Try to change layout back to English to enter password
Expected:
Layput should change and you should be able to login without touching anything but keyboard.
What's happening:
Nothing, doesn't react on the keyboard shortcut, you have to change layout using indicator on top panel.

[Regression Potential]
1. There may potentially be missing keyboard shorts.
2. Key grabs may persist after the lockscreen has been released.
3. new code contains dynamic memory allocation, which always introduces potential leaks, crashes, or exhaustion

Related branches

Stephen M. Webb (bregma) on 2014-03-12
tags: added: lockscren
tags: added: lockscreen
removed: lockscren
summary: - Unity Lockscreen - layout switching shortcuts not working
+ Lockscreen: keyboard layout switching shortcuts not working

As workaround you can use Alt+F10 to access to the indicators via Keyboard.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Andrea Azzarone (azzar1) on 2014-04-11
Changed in unity:
status: New → Triaged
milestone: none → 7.2.1
Ruslan Boitsov (thermatk) wrote :

https://bazaar.launchpad.net/~unity-team/unity/trunk/revision/3778
Thanks to those who are implementing it finally!
Should already be working? Sound buttons are ok but not input switching

Changed in unity:
assignee: nobody → William Hua (attente)
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
no longer affects: indicator-keyboard
William Hua (attente) on 2014-04-11
Changed in unity:
status: Fix Committed → In Progress
William Hua (attente) wrote :

The fix we had before was very rudimentary... it basically just compared the keysyms directly. The related branch above should allow switching with modifier-only shortcuts too now.

Ruslan Boitsov (thermatk) wrote :

Is something wrong with the fix? It won't be merged because of release?
Actually, in a strange way switching works

Stephen M. Webb (bregma) on 2014-05-07
description: updated
Stephen M. Webb (bregma) on 2014-05-07
Changed in unity:
milestone: 7.2.1 → 7.3.0
Changed in unity (Ubuntu):
status: Fix Released → In Progress

I am used to shift+shift combination for layout switching.

When I set 'shift+shift L' for switching, in unlock screen right shift does nothing, and pressing only left shift (without any other keys) changes layout.

When I set 'shift+shift R' for switching right shift starts switch layouts alone in unlock screen.

And when I set 'Alt + shift L', Alt and then Shift works OK, and Shift then Alt does not.

Hope this helps.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140512.4-0ubuntu1

---------------
unity (7.2.0+14.10.20140512.4-0ubuntu1) utopic; urgency=low

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition
  * disabled precompiled headers on arm64 Ubuntu package builds (LP:
    #1317276)

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * UnityScreen: don't try to show Dash/Hud if the screen is grabbed
    Also move the dash opening out from LauncherController, and get rid
    of UBus as first initialization source, as it can only slow things
    down here. (LP: #741869)
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ William Hua ]
  * Add proper support for modifier-only shortcuts on the lock screen.
    (LP: #1291461)

  [ Jinkyu Yi ]
  * Dash: Fix problem at checking blacklisted unicode range (LP:
    #1251193)

  [ Andrea Azzarone ]
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)
 -- Ubuntu daily release <email address hidden> Mon, 12 May 2014 22:03:27 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Ruslan Boitsov (thermatk) wrote :

Installed Utopic version on Trusty, working great. What about a proper SRU?

Hello Ruslan, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
tags: added: verification-failed
removed: verification-done

Unfortunately the fix doesn't work as it should.

I can change keyboard layout on lockscreen but when the screen unlocks the keyboard layout switches to witchever layout was set when locking tha screen. For example if I lock screen with layout set to English or Persian and then change layout on the lockscreen to Polish and unlock screen the layout will be set to English or Persian not Polish.

Steps to reproduce:

1. Change keyboard layout to Persian
2. Lock the screen
3. Change layout to Polish
4. Unlock the screen

Expected after unlocking the screen keyboard layout is set to Polish.

What is happening the layout after unlock is set to Persian.

I would argue that this is really fixed for the bug at hand. The bug *only* specifies changing the keyboard layout in the lockscreen and does not specify that the newly selected keyboard layout should carry over back into the session. I'd even argue that the original keyboard layout in the session is the correct behavior, but that should be discussed elsewhere.

That said, I think this bug is not verification-failed and a new bug should be entered for discussing whether the newly selected keyboard layout should carry over to the session.

tags: added: verification-needed
removed: verification-failed
William Hua (attente) wrote :

Mateusz, that's not a regression and isn't really related to this bug which is only about the switching using keyboard shortcuts on the lock screen. You can file a new bug, but I think it was done that way by design.

I have tested exactly what this bug is intended to fix and it does indeed work correctly now.

Brian Murray (brian-murray) wrote :

Hello Ruslan, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I honestly can't understand how it is supposed to be an intended behavior and I'm sure going to open a new bug.

All that said this bug is fixed with trusty-proposed package.

tags: added: verification-done
removed: verification-needed

I reported that confusing behavior as Bug #1324489 if anyone else feels that keyboard layout should carry over from lockscreen to session please mark that bug as affecting you.

Stephen M. Webb (bregma) on 2014-06-04
Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers