Unity very slow on Intel 945 + Core2 T5500 @1.66GHz

Bug #1244566 reported by AraKs
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Compiz eats up all the CPUs causing very poor system performance:

top - 09:40:59 up 35 min, 4 users, load average: 2,75, 2,43, 2,13
Tasks: 222 total, 4 running, 218 sleeping, 0 stopped, 0 zombie
%Cpu(s): 69,3 us, 8,3 sy, 21,0 ni, 1,4 id, 0,1 wa, 0,0 hi, 0,1 si, 0,0 st
KiB Mem: 3331296 total, 3067712 used, 263584 free, 196420 buffers
KiB Swap: 4200992 total, 8 used, 4200984 free, 850384 cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2570 mattia 20 0 1815m 322m 41m S 129,2 9,9 44:43.98 compiz
 1078 root 20 0 451m 78m 53m S 16,7 2,4 5:36.68 Xorg
 2579 mattia 20 0 871m 140m 48m S 0,9 4,3 1:26.84 chrome
 3332 mattia 20 0 960m 83m 23m S 0,9 2,6 0:24.53 chrome
 5263 mattia 30 10 258m 19m 9,9m R 0,9 0,6 0:00.26 update-manager
 3205 mattia 20 0 1091m 169m 24m S 0,8 5,2 0:43.69 chrome
 2900 mattia 20 0 572m 20m 13m S 0,7 0,6 0:04.19 gnome-terminal
 3371 mattia 20 0 951m 61m 21m S 0,4 1,9 0:06.23 chrome
 3211 mattia 20 0 945m 65m 21m S 0,3 2,0 0:03.78 chrome
 3225 mattia 20 0 983m 85m 20m S 0,3 2,6 0:08.58 chrome
 2847 mattia 20 0 661m 17m 12m S 0,3 0,5 0:06.56 psensor
 1933 root 20 0 0 0 0 S 0,2 0,0 0:03.68 kworker/0:2
 2680 mattia 20 0 991m 116m 17m S 0,2 3,6 0:33.46 chrome
   33 root 20 0 0 0 0 R 0,2 0,0 0:03.66 kworker/1:1
 1113 mysql 20 0 545m 43m 6804 S 0,1 1,3 0:02.50 mysqld
 3100 mattia 20 0 475m 13m 10m S 0,1 0,4 0:00.19 update-notifier

Why is it running on the software renderer, is it the correct behavior?

mattia@jiraiya:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
OpenGL version string: 2.1 Mesa 9.2.1

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: no

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz-core 1:0.9.10+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
.tmp.unity.support.test.0:

.tmp.unity.support.test.1:

ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,grid,place,resize,snap,mousepoll,vpswitch,imgpng,session,gnomecompat,regex,move,animation,wall,unitymtgrabhandles,expo,ezoom,fade,scale,workarounds,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Fri Oct 25 09:31:46 2013
DistUpgraded: 2013-10-18 12:31:12,207 DEBUG enabling apt cron job
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.16, 3.11.0-12-generic, x86_64: installed
 virtualbox, 4.2.16, 3.8.0-31-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:01d8]
   Subsystem: Dell Device [1028:01d8]
InstallationDate: Installed on 2011-10-13 (742 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
MachineType: Dell Inc. MXC061
MarkForUpload: True
ProcEnviron:
 LANGUAGE=it
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=19052d33-fd14-4d39-bde4-a2cd90df3fa0 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to saucy on 2013-10-18 (6 days ago)
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A10
dmi.board.name: 0MG532
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA10:bd04/02/2007:svnDellInc.:pnMXC061:pvr:rvnDellInc.:rn0MG532:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MXC061
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Fri Oct 25 09:05:47 2013
xserver.configfile: default
xserver.errors: Wacom Bamboo stylus: Invalid type 'touch' for this device.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 41086
 vendor DEL
xserver.version: 2:1.14.3-3ubuntu2

Revision history for this message
AraKs (aracnew) wrote :
affects: compiz (Ubuntu) → unity (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Revision history for this message
Emiliano (retorquere) wrote :

I think I'm experiencing the same issue; I've submitted my logs at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1772366

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers