AP failure: test_launcher_tooltip_disabling

Bug #1233666 reported by Stephen M. Webb on 2013-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

AP failure: unity.tests.launcher.test_tooltips.LauncherTooltipTests.test_launcher_tooltip_disabling(Single Monitor)

_StringException: test-log: {{{
05:22:58.570 INFO globals:49 - ************************************************************
05:22:58.570 INFO globals:50 - Starting test unity.tests.launcher.test_tooltips.LauncherTooltipTests.test_launcher_tooltip_disabling (Single Monitor)
05:22:58.570 DEBUG globals:148 - Starting: ['/usr/bin/recordmydesktop', '--fps=6', '--no-wm-check', '--no-sound', '--no-frame', '-o', '/var/local/autopilot//videos/unity.tests.launcher.test_tooltips.LauncherTooltipTests.test_launcher_tooltip_disabling (Single Monitor).ogv']
05:22:58.591 INFO __init__:302 - Setting compiz option 'num_launchers' in plugin 'unityshell' to 0
05:22:59.144 INFO __init__:302 - Setting compiz option 'launcher_hide_mode' in plugin 'unityshell' to 0
05:22:59.661 DEBUG _X11:344 - Moving mouse to position 512,384 without animation.
05:22:59.703 DEBUG launcher:110 - Moving mouse away from launcher.
05:22:59.704 DEBUG _X11:344 - Moving mouse to position 75,396 without animation.
05:23:00.815 DEBUG _X11:344 - Moving mouse to position 32,56 with animation.
05:23:02.445 DEBUG _X11:299 - Pressing mouse button 1
05:23:02.546 DEBUG _X11:306 - Releasing mouse button 1
05:23:02.933 DEBUG _X11:344 - Moving mouse to position 32,56 with animation.
05:23:04.193 DEBUG _X11:299 - Pressing mouse button 1
05:23:04.295 DEBUG _X11:306 - Releasing mouse button 1
05:23:04.346 DEBUG _X11:344 - Moving mouse to position 32,115 with animation.
05:23:05.772 INFO __init__:302 - Setting compiz option 'launcher_hide_mode' in plugin 'unityshell' to 0
05:23:06.273 INFO __init__:302 - Setting compiz option 'num_launchers' in plugin 'unityshell' to 0
05:23:06.778 INFO __init__:89 - Checking system state for badly behaving test...
05:23:07.003 INFO __init__:152 - Test was well behaved.
}}}

unity-log: {{{
DEBUG 2013-10-01 05:23:02 unity.launcher Launcher.cpp:1162 Overlay shown: dash, can maximise, on monitor 0 (for monitor 0)
DEBUG 2013-10-01 05:23:02 unity.launcher.icon.application ApplicationLauncherIcon.cpp:159 Compiz active now true
DEBUG 2013-10-01 05:23:04 unity.launcher Launcher.cpp:1208 Overlay hidden: dash, can maximise, on monitor 0 (for monitor0)
DEBUG 2013-10-01 05:23:04 unity.launcher Launcher.cpp:1231 Saturate on monitor 0
DEBUG 2013-10-01 05:23:04 unity.launcher.icon.application ApplicationLauncherIcon.cpp:159 Compiz active now false
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/unity/tests/launcher/test_tooltips.py", line 67, in test_launcher_tooltip_disabling
    self.assertEqual(self.get_reveal_behavior(other), self.DELAYED)
  File "/usr/lib/python2.7/dist-packages/testtools/testcase.py", line 322, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/usr/lib/python2.7/dist-packages/testtools/testcase.py", line 417, in assertThat
    raise MismatchError(matchee, matcher, mismatch, verbose)
MismatchError: 2 != 1

Help us localize this page

Related branches

Stephen M. Webb (bregma) wrote :
Andrea Azzarone (azzar1) on 2013-10-01
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
status: New → Confirmed
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.1.1
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → Critical
importance: Critical → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.1+13.10.20131004-0ubuntu1

---------------
unity (7.1.1+13.10.20131004-0ubuntu1) saucy; urgency=low

  [ Brandon Schaefer ]
  * Break the bump detection by moving to the first icon, then down 5
    pixels. Since bump detection needs to move in 3 different
    directions.
  * Move the switcher Alt+<ArrowKey> shortcut handling into nux, from
    compiz. Now nux handles these events instead of compiz. This way its
    makes much more sense code wise and we no longer ungrab the arrow
    gets from X... so Alt+LeftArrow will no longer open the hud. (LP:
    #969039)

  [ Andrea Azzarone ]
  * Fix bad redrawing of dash overlay scrollbar connector. (LP:
    #1233195)
  * Update icon_under_mouse before process mouse movemnt in the tooltip
    manager. (LP: #1172769, #1233666)
  * Hide the tooltip when an app is closed. (LP: #1172769)

  [ Marco Trevisan (Treviño) ]
  * TestIMTextEntry: fix failing tests with IBus, use TEST_F and TEST_P.
  * CairoBaseWindow: only regenerate blur texture when visible and
    damaged. (LP: #1233109)
  * CairoBaseWindow: add fade animator to control both QL and Tooltip
    Removing the animator from LauncherIcon, and handling the tooltip
    animation inside the QL and Tooltip base class.
  * PanelService: close a menu and re-send the keyevent when handling a
    combination Or when we try to open HUD/Dash. Also, close the active
    menu if a new application is opened and focused. (LP: #10905,
    #1234457, #1197071)
  * SimpleLauncherIcon: we need to restore the focus when closing the
    Overlay for activation. (LP: #909870)
  * LauncherIcon: don't try to show again quicklists or tooltip if
    center changed, just move them. (LP: #1234778)
  * AbstractLauncherIcon: add static icon_size property. (LP: #1073103)

  [ Christopher Lee ]
  * Preparing autopilot tests for an upcoming update in autopilot 1.3.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3554
 -- Ubuntu daily release <email address hidden> Fri, 04 Oct 2013 05:23:43 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers