Key navigation over new generation indicators with no position is not consistent

Bug #1229460 reported by Marco Trevisan (Treviño) on 2013-09-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Unassigned

Bug Description

Using key navigation over new generation unity indicators that have no defined their position (such as the keyboard indicator) does not work as expected.
This means that the selection doesn't happen following the visual order (such kind of indicators are selected as the last ones even if they're placed as first ones)

Related branches

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-09-27
Changed in unity (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.1+13.10.20130927.1-0ubuntu1

---------------
unity (7.1.1+13.10.20130927.1-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Add a property to the Scope class
  * Add parameters to Preview::PerformAction
  * Bump ABI version

  [ Brandon Schaefer ]
  * restart the ibus daemon wit hthe right args for tests.
  * Change sleep from 5 to 10, in hopes of appeasing jenkins.
  * If we are switching view ports tell nux to process the events. Even
    though the viewport switcher does grab the mouse, we will still feed
    nux the events so we can correctly update where the mouse is for the
    launcher. (LP: #1231679)

  [ chris.gagnon ]
  * BlackListDriverError moved to Display. (LP: #1227882)

  [ Marco Trevisan (Treviño) ]
  * UBusMessages: remove useless messages (and relative emission).
  * PanelService: set proper priority for floating position-less NG
    indicators. (LP: #1229460)
  * Unity: Use WindowManager average_color property for getting the
    desktop color Having to deal with UBus here was a mess and caused us
    to re-store the same value too many times. Using a nux property
    gives us all the features we need easily while WindowManager is
    already enough shared to be used for this task.
  * VScrollBarOverlayWindow: add quick fade animation on show/hide.

  [ Chris Townsend ]
  * A regression caused by revno. 3515 breaks the recently fixed
    Quicklist and Tooltip active blur. This fixes it by checking if the
    View is a ViewWindow and if so, use QueueDraw() instead of
    NeedSoftRedraw(). (LP: #1228308)
  * The ShowDesktopHandleWindowInterface teardown was missing it's call
    to DeleteHandler() in a recent commit that refactored the handling
    of some Show Desktop code. (LP: #1228915)

  [ Andrea Azzarone ]
  * Don't use sigc::bind with a static value that should be dynamic.
    (LP: #1228965)

  [ Jeremy Bicha ]
  * recommend telepathy-indicator.

  [ Łukasz 'sil2100' Zemczak ]
  * No new recommends/depends now, since at this point of the cycle it's
    not allowed for this project
  * Re-add the telepathy-indicator recommends as it got dropped from
    Main without any valid reasons

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3540
 -- Ubuntu daily release <email address hidden> Fri, 27 Sep 2013 12:44:54 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers