[regression] pressing and holding the alt key in a GTK app does not show the menu bar

Bug #1206582 reported by Stephen M. Webb
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
William Hua
Unity GTK+ module
Won't Fix
Critical
William Hua
unity (Ubuntu)
High
Unassigned

Bug Description

Using the Unity Dash, launch the Text Editor application (gedit). Press and hold the Alt key.

Expected Behaviour:

  The menu bar is displayed in the Panel.

Actual Behaviour:

  Nothing happens.

Note that Qt-based applications and Firefox continue to display the menu bar when the Alt key is pressed and held.

This bug causes the unity.tests.test_panel.PanelWindowButtonsTests.test_window_buttons_show_when_holding_show_menu_key Autopilot test to fail in the Unity project.

Related branches

Revision history for this message
Stephen M. Webb (bregma) wrote :

Setting this to critical because this regression causes a major loss of fundamental functionality in the Unity 7 desktop shell.

summary: - pressing and holding the alt key in a GTK app does not show the menu bar
+ [regression] pressing and holding the alt key in a GTK app does not show
+ the menu bar
Changed in unity-gtk-module:
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
William Hua (attente) wrote :

I'm not sure why, but holding down alt doesn't reveal the menu bar in panel at all for me in Firefox or transmission-qt. Actually in transmission-qt, the menu bar is still in-window rather than in-panel, which seems like a different bug in itself. Is there another qt application you checked this with that I could try?

Revision history for this message
Charles Kerr (charlesk) wrote :

FWIW, menus for transmission-qt built from trunk show up in the panel for me.

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

Charles: yes, this is true also for Firefox as both qt and xul apps have different way to interact with indicator-appmenu, but the issue is present on gtk apps and it's blocking unity due to an AP test failure.

Ted Gould (ted)
Changed in unity-gtk-module:
assignee: nobody → William Hua (attente)
William Hua (attente)
Changed in unity:
assignee: nobody → William Hua (attente)
Changed in unity-gtk-module:
status: Confirmed → Won't Fix
Changed in unity:
milestone: none → 7.2.0
status: New → In Progress
importance: Undecided → High
William Hua (attente)
tags: added: ubuntu-desktop-trusty
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision 3650, scheduled for release in unity, milestone 7.2.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Triaged
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers