unity.tests.test_quicklist.QuicklistKeyNavigationTests.* tests fail if gedit icon is sticky.

Bug #1192503 reported by Andrea Azzarone on 2013-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/unity/tests/test_quicklist.py", line 236, in setUp
    self.assertThat(icon_refresh_fn, Eventually(Equals(None)))
MismatchError: After 10.0 seconds test failed: None != <ApplicationLauncherIcon gedit.desktop id=7717>

Related branches

Andrea Azzarone (azzar1) on 2013-06-19
Changed in unity:
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Medium
milestone: none → 7.1.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.1+13.10.20130702-0ubuntu1

---------------
unity (7.0.1+13.10.20130702-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * A few changes to unity-core API/ABI.

  [ Ted Gould ]
  * Fix upstart job to handle legacy case and not duplicate events.

  [ Marco Trevisan (Treviño) ]
  * ApplicationManager: Use nux::ROProperty for Window and Application
    title and icon So BamfApplicationManager connect to {name,icon}-
    changed signals, set getters for properties and
    ApplicationLauncherIcon update icon tooltip_text and icon when App
    title/icon changes. (LP: #751909)
  * BamfApplicationManager: always use std::make_shared and use
    glib::SignalManager::Add Also add some helper constructors.
  * ApplicationLauncherIcon: only use a simple std::vector to cache the
    quicklist entries Remove the ugly std::string indexed std::map.
  * ConnectionManager: add a class container of sigc::connection that
    takes care of disconnection Connections added will be disconnected
    on class destruction on on explicit removal or replacement request.

  [ Lars Uebernickel ]
  * unity-panel-service: call ido_init() and honor indicator's position
    requests.

  [ Chris Townsend ]
  * Fixes some panel shadow regressions caused by rev. 3381. - No panel
    shadow when logging in, ie, no windows are opened. - Indicator drop
    down menus have the panel shadow painted over them. - Notification
    bubbles cause the panel shadow to be drawn on top of everything. -
    Minimizing all windows caused the panel shadow to not be drawn. (LP:
    #1194865)

  [ Didier Roche ]
  * now build-depends on the desktop definition for scopes as libunity-
    common is dead.

  [ Sebastien Bacher ]
  * use correct ellipses.

  [ Andrea Azzarone ]
  * Remove not necessary assert. (LP: #1192503)

  [ Łukasz 'sil2100' Zemczak ]
  * Revert revision 3380. This caused regression of all autopilot tests
    as show_desktop was invalidly detected every time there are no
    visible windows on screen.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3396
 -- Ubuntu daily release <email address hidden> Tue, 02 Jul 2013 05:32:40 +0000

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers