Panel shadow is drawn above full-screen windows when notifications are shown

Bug #1171934 reported by Marco Trevisan (Treviño) on 2013-04-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Committed
Medium
Marco Trevisan (Treviño)
7.0
In Progress
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]

Panel shadow drawn on a full screen window.

[Test Case]

1) Open Totem
2) make it full-screen pressing F11
3) Change the main volume using the multimedia keyboards

Expected behavior:
4) The volume notification is drawn above it, and the panel shadow is not

Actual behavior
4) The panel shadow is drawn below the notification bubble.

[Regression Potential]

No regression potential.

Changed in unity:
importance: Undecided → Medium
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.0

Changed in unity:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity/7.0 at revision None, scheduled for release in unity, milestone 7.0.1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

Hello Marco, or anyone else affected,

Accepted unity into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.0.0daily13.06.19~13.04-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Raring):
status: New → Fix Committed
tags: added: verification-needed
Petro (petrochemicals) wrote :

I just installed Unity 7.0.0daily13.06.19~13.04-0ubuntu1 and this does not really fix the bug. Instead of the panel shadow being drawn continously above fullscreen apps like Totem when notifictions or right click menu's appear, it now flashes not only the shadow but the sidebar as well.

So not only have you people been sitting on this supposed fix for months, it doesn't even really fix the issue of Compiz drawing crap above fullscreen apps, especially video players. Frankly this is just ridiculous that it took you people months to affectively fix nothing. Maybe if someone had released this fix earlier like was asked repeatedly by many users in the original bug report (https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1170958) we wouldn't have to wait even more months to get a fix for this broken fix.

Does no one working on this care that three months have now been wasted waiting for a fix that doesn't even fix the core issue? Three months out of a short nine month life span of this release and fullscreen videos are still broken. There are computers being sold with this particular release and frankly you devs should be ashamed to have your name attatched to it. There is no excuse for bugs like this anymore. How long have all of you been working on Compiz and Unity and you still can not get it to work? Now you want everyone to beleive you are all going to get a whole display server working in time for the next LTS with it being default in the next release in a couple months. You had years just to get your DE working and you can't even do that.

tags: added: verification-failed
removed: verification-needed
Petro (petrochemicals) wrote :

Here is a video of what the bug is like now with the "fix" installed. You can see the panel and Unity panel blink above the fullscreen video when going from windowed to fullscreen and moving the mouse.

Christopher Townsend (townsend) wrote :

I did confirm the behavior that Petro sees in the movie. However, this behavior is present in Unity version 7.0.0daily13.04.18~13.04-0ubuntu1 (the version in main) and is a completely different bug than this one. Hence, there is no SRU regression here.

Since Petro has confirmed the Panel shadow is indeed gone, this bug is verification-done.

I will create a new bug with the behavior seen in the movie as it still occurs in Unity trunk in Saucy/

tags: added: verification-done
removed: verification-failed
razor (razorxpress) wrote :

Hi, has any one filed the bug on issue Petro raised. In my case, if I play video in vlc or totem it acts just like what Petro showed.

However, if you play a video on smplayer and while in fullscreen, if you move your mouse to the bottom part (bottom control window) unity top menu and launcher becomes visible and does not go away, until you move your mouse from that part.

I like smplayer, because it has a feature that remembers the position of previously played videos.

Also (may be this bug is totally smplayer bug), if you double click smplayer, while in fullscreen there is a gap between menu bar and actual video. I would also like to point out, smplayer has a black strip at the bottom, that shows time on right. When you double click on a fullscreen video, this panel does not show (while there is gap between video and menu). If you click the top menu bar, smplayer returns to its correct state.

I would also like to point out, this bug does not exist in Linux Mint 15..

@razor,

I did file bug #1196724 for the new behavior that Petro observed.

Thanks!

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.06.19~13.04-0ubuntu1

---------------
unity (7.0.0daily13.06.19~13.04-0ubuntu1) raring; urgency=low

  [ William Hua ]
  * Revert 3196 to fix menu highlighting issues with LibreOffice.
    Revision 3196 prevents LibreOffice's menu items from highlighting.
    See Launchpad bug #1153350. (LP: #1153350)

  [ Chris Townsend ]
  * Fixes issue where minimizing a full screen window would not draw the
    Launcher and Panel after minimization. This is a backport of
    lp:unity revno. 3320. (LP: #1064155)

  [ Marco Trevisan (Treviño) ]
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime. (LP: #1181367)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3319 (bootstrap)
  * Automatic snapshot from revision 3320

unity (7.0.0daily13.05.08~13.04-0ubuntu1) raring; urgency=low

  [ Sebastien Bacher ]
  * Some untranslatable and wrong strings in the previews (LP: #1074038)

  [ Andrea Azzarone ]
  * [alt-tab] Disable detail view for webapp icons. (LP: #1169340)

  [ Marco Trevisan (Treviño) ]
  * Launcher - count label pops out in auto-hide mode (LP: #1171476)
  * Panel shadow is drawn above full-screen windows when notifications
    are shown (LP: #1171934)
  * [regression] Icon count is not shown if the icon is not transformed
    (LP: #1171663)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3314
 -- Ubuntu daily release <email address hidden> Wed, 19 Jun 2013 04:02:40 +0000

Changed in unity (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers