Search Plugins previews in the apps lens should not display any ‘review stars’

Bug #1170715 reported by Paweł Stołowski on 2013-04-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity-lens-applications
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

The “Search Plugins” previews in the apps lens should not display any ‘review stars’, and should also not display the number of reviews e.g. the text “0 reviews” should be removed.

Related branches

tags: added: 100scopes 100scopes-design
Changed in unity-lens-applications:
status: New → Confirmed
importance: Undecided → High
Michal Hruby (mhr3) on 2013-04-23
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2013-04-23
Changed in unity:
status: Confirmed → In Progress
Changed in unity-lens-applications:
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~unity-team/unity-lens-applications/libunity7-compatible at revision 340, scheduled for release in unity-lens-applications, milestone Unknown

Changed in unity-lens-applications:
status: In Progress → Fix Committed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~unity-team/unity/libunity-7.0-breakage at revision None, scheduled for release in unity, milestone Unknown

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (12.1 KiB)

This bug was fixed in the package unity - 7.0.0daily13.06.07-0ubuntu1

---------------
unity (7.0.0daily13.06.07-0ubuntu1) saucy; urgency=low

  [ Ted Gould ]
  * gtk_icon_info_free() is deprecated for g_object_unref().
  * Upstart event for when the indicators are loaded by the panel
    service.
  * Add an upstart job to unity-common.
  * Manage Unity Panel Service's lifecycle with Upstart.

  [ Didier Roche ]
  * add dep on autopilot-desktop.
  * Revert the panel on upstart from ted, it doesn't respawn as expected
    when another service try to communicate with the panel service and
    the consequence is a lot of tests failing

  [ Nick Dedekind ]
  * Uses a gobject weak ref to test for object deletion in the
    GLibObject tests. Previously was checking with G_IS_OBJECT on an
    invalid pointer, which was causing a segfault

  [ Manuel de la Pena ]
  * Adds support for payment previews that will allow users to buy music
    from within the dash. .

  [ Mathieu Trudel-Lapierre ]
  * Increase timeouts for hud functional and search tests.

  [ Francis Ginther ]
  * Handle StateNotFoundError when querying the label of a hud button.

  [ Łukasz 'sil2100' Zemczak ]
  * Now that we're using the new HUD, there have been some changes that
    typically cause test_hud tests to fail. Fix the tests to fit the new
    model. The first one is that generally we do not have indicator
    entries visible in the HUD anymore. Only application menu entries
    are in it now. The second one - the way the results are displayed is
    different. Now, instead of "Menu > Entry" we have "Entry (Menu)"
    etc.
  * Fix two HUD failures related to HUD slow action activation.
  * Fix some autopilot test failures, some related to test_shortcut_hint
    and some to test_scroll in launcher.
  * Modify all the hud_query_check lambdas to be more smart and error-
    checking. Same for the selected_hud_button method in the HUD
    emulator. Also, get rid of the troublesome test_gedit_undo and
    change it into test_gedit_save, which is easier to test and anyway
    tests what we want. Besides that we also now try to handle the
    StateNotFoundError exception in the HUD emulator, another cause of
    some AP failures.
  * Add a flag for -Wno-error=unused-local-typedefs, since this causes a
    FTBFS on ARM

  [ Michal Hruby ]
  * Don't activate a result twice after pressing Enter. (LP: #1188191)

  [ Sebastien Bacher ]
  * Use '%s:' string for preview hints, rather than just appending ':'.
    (LP: #1074038)

  [ Marco Trevisan (Treviño) ]
  * IconRenderer: preprocess an icon if its emblem has been shown/hidden
    In that way we can update its transformation. (LP: #1171476,
    #1171663)
  * UnityWindow: don't draw the panel shadow above a fullscreen window.
    (LP: #1171934)
  * UnityCore: add GtkWrapper to handle GtkIconInfo correctly for
    different GTK versions Fix a memory leak in LauncherIcon. (LP:
    #1180790)
  * SwitcherController: use proper long long types for
    WindowActiveNumber Otherwise an overflow can cause bad window
    selection after long uptime.
  * Unity: "s/unsigned long long/uint64_t/g".

  [ Chris Townsend ]
  * Fixes issue where minimiz...

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2013-08-16
Changed in unity:
milestone: none → 7.1.0
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in unity-lens-applications (Ubuntu Raring):
status: New → Won't Fix
Changed in unity (Ubuntu Raring):
status: New → Won't Fix
Andrea Azzarone (azzar1) on 2017-10-13
Changed in unity-lens-applications:
assignee: Andrea Azzarone (azzar1) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers